Subject: Re: [renum] Draft 6RENUM WG charter

From: RJ Atkinson <[email-masked]>
Date: Wed, 18 May 2011 10:08:10 -0400

Earlier, Joel Halpern wrote:
> I like most of what is there. 
> Based on other working groups where things seemed simple and clear, 
> I would be amazed if we could meet the stated schedule.

1) Timetable
Concur with Joel H.  
I'd prefer to have a more realistic initial schedule.

2) Upstream router/prefix discovery

Also, I believe that multi-addressing is still the IPv6
multi-homing plan of record, although SHIM6 is now also
an option for multi-homing.  

A significant challenge with multi-addressing when deployed 
with IP multi-homing is the issue of how nodes/routers inside 
a multi-homed site/domain learn which upstream links are 
active at a given time and hence which of the delegated 
routing prefixes are usable at that time.  I'd like to see 
this issue more clearly/explicitly brought into the charter.

3) Service Discovery

At present, the charter appears to be limited to how IP
addresses are managed within the site.  As RFC-5887 notes,
much of the current renumbering challenge closely relates 
to applications that bind to low-level IP addresses, 
rather than to address-independent names (e.g. FQDNs, 
service names).  If hosts/routers can renumber, but the
renumbering breaks deployed applications, the enterprise
user is still far from having a sufficient solution.  So
I'd like to see this aspect of the renumbering issue 
more clearly/explicitly brought into the charter.

4) Wordsmithing

Last, I'd like to see some of the words in the charter 
changed from singular to plural, so we don't accidentally
preclude having a solution with multiple components
or having different solutions for different environments
(e.g. large enterprise relying upon DHCPv6 vs SOHO using 
SLAAC).

  For example:
	s/numbering tool/numbering tools/
	s/(high level) proposal/(high level) proposals/

Yours,

Ran

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 19 May 2011 10:05:48 +1200

Ran,

> I'd prefer to have a more realistic initial schedule.

We will in any case have to negotiate the dates with the AD,
if the WG is approved.

> this issue more clearly/explicitly brought into the charter.

Agreed; in any case this applies with or without SHIM6. Of course,
the solution(s) might well lie outside the proposed WG's charter.

> more clearly/explicitly brought into the charter.

On the other hand, we can't solve the insoluble and there
are probably parts of this sub-problem that are insoluble
(except by managerial hard graft when the issue arises).

> 	s/(high level) proposal/(high level) proposals/

Seems reasonable. We already have two scenarios, after all.

   Brian

> 
> Yours,
> 
> Ran
> 
> _______________________________________________
> renum mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/renum
>

---

From: Scott Brim <[email-masked]>
Date: Wed, 18 May 2011 21:52:40 -0400

> the solution(s) might well lie outside the proposed WG's charter.

(1) It certainly does apply with or without SHIM6.  IMHO SHIM6 will
never get traction and anything that considers taking it into account
must be general enough to allow for other methods of putting
intelligence in endpoints, at one or multiple layers.

(2) Yes this issue should be in the charter, but I think it's covered
already in some of the bullets.

>> more clearly/explicitly brought into the charter.

Isn't endpoint intelligence a mechanism to "make renumbering a simpler
process"?  Isn't it covered?

Thanks ... Scott

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 21 May 2011 08:57:26 +1200

The draft charter (as previously circulated) is on the IESG agenda
for next Thursday. We can wait to update it until we get the feedback
from that. Even if the current version goes out for IETF review,
we can pick up the comments made here in due course.

Regards
   Brian Carpenter