Subject: [renum] scoping question - how to define Enterprise in the context of 6renum?

From: "George, Wesley" <[email-masked]>
Date: Tue, 19 Jul 2011 15:52:00 -0400

In both the charter and in the enterprise draft, we make a point to specify Enterprise renumbering as being in scope but ISP and SOHO/MANET out of scope. Right now, neither the drafts nor the charter does a particularly good job defining what is considered Enterprise and therefore in-scope, and differentiating how and why the renumbering work we're undertaking is applicable there while it is not in the other cases.

For example, what about renumbering enterprise networking infrastructure (as compared to end hosts)? I would think that this is somewhat of a small-scale version of an ISP network renumber (which was previously identified as out of scope), but it is quite possible that all or part of an enterprise's internal network infra might be subject to a renumbering event (depending on how they numbered things like routers and WAN/LAN links). If this is in scope, how do we make the distinction between SP renumbering and Enterprise renumbering? Is it just scale/amount of renumbering? If it's out of scope, what's our rationale?

I've been on the list mostly since the BOF days, but I don't remember there being a lot of discussion on this specific scoping question, so I'd like some background, either from the draft charter authors or otherwise. The only thing that I could see was some comments on the draft charter from Scott Brim specifically recommending that we remove enterprise/soho/manet in favor of something like managed or unmanaged.

I think there are probably a couple of characterization points - one is scale, the other is management/administrative domain (typically enterprises are more centrally managed), but I think there may be more that aren't occurring to me at the moment, and I'd like to get some discussion going on how we make this clearer so that we can say focused on the right scope (or redefine it if it's currently too narrow).  I think it's better to get some clarity on this now before we get too far along on the drafts and have to revisit them later.

Thanks,

Wes George
Speaking as chair

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Jiangsheng <[email-masked]>
Date: Wed, 20 Jul 2011 08:07:17 +0000

Hi, George,

Good catch, here. I agree ISP renumbering is very similar and should be in the scope.

Actually, there was some private discussion between IESG member and BoF/WG proponents during the WG forming. The main argument and agreement later was SOHO/MANET should be out of scope. Also the WG should avoid overlap work with HOMENET WG, which was announced yesterday.

Regards,

Sheng

From: [email-masked] [mailto:[email-masked]] On Behalf Of George, Wesley
Sent: Wednesday, July 20, 2011 3:52 AM
To: [email-masked]
Subject: [renum] scoping question - how to define Enterprise in the context of 6renum?

Thanks,

Wes George
Speaking as chair

---

From: "George, Wesley" <[email-masked]>
Date: Wed, 20 Jul 2011 08:50:36 -0400

The problem is that http://datatracker.ietf.org/wg/6renum/charter/ item #3 of the "out of scope" section specifically says "ISP renumbering." If the group agrees that this needs to be changed, we can request a charter update, but mainly I'm looking for clarity on how we define the scope, especially what is specifically considered "enterprise" so that we can keep focus on the right things.

Regarding ISP renumbering, my view is that we should focus on Enterprise, including network infra, and that will provide a framework that can be extended to ISP renumbering (with the appropriate charter update) at a later point.

I'll respond to your comment about HOMENET in a separate thread.

Thanks
Wes
Speaking as chair

From: Jiangsheng [mailto:[email-masked]]
Sent: Wednesday, July 20, 2011 4:07 AM
To: George, Wesley; [email-masked]
Subject: RE: [renum] scoping question - how to define Enterprise in the context of 6renum?

Hi, George,

Regards,

Sheng

Thanks,

Wes George
Speaking as chair

---

From: "George, Wesley" <[email-masked]>
Date: Wed, 20 Jul 2011 09:11:08 -0400

New subject for this part of the thread

Regarding HOMENET overlap (and other WGs in general) - since we are an OpsArea WG, we're not going to do much (if any) protocol work. We're going to document BCP and identify gaps + possibly requirements for any solutions to those gaps. Any protocol work necessary would have to be offloaded to other groups, such as DHC. HOMENET might also be one of those offload groups, but I don't expect there to be an overlap problem. That said, one of my colleagues is going to be watching HOMENET carefully, so I expect he'll keep me in the loop on what's happening in that group.
And while we've explicitly excluded MANET and SOHO networks (HOMENET) from our scope, it may be useful for MANET and or HOMENET to generate companion drafts to cover some of the same issues, use cases, and gaps within their space with a draft that we can reference in our own. If there are folks on this list who are also planning to participate in either of those groups, you might mention it on the lists.
It is probably also a good idea for folks to keep an eye on the discussion happening in OpsAWG regarding VM migration in the datacenter, since there may be some use cases that could trigger renumbering events, or would be looking to specifically avoid renumbering events for a number of reasons.

Thanks,

Wes
Speaking as chair

Hi, George,

Regards,

Sheng

Thanks,

Wes George
Speaking as chair

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Jul 2011 09:25:28 +1200

> Regarding ISP renumbering, my view is that we should focus on Enterprise, including network infra, and that will provide a framework that can be extended to ISP renumbering (with the appropriate ch…

Maybe we should interpret the charter for now to mean that we will not work to
identify ISP-specific requirements, beyond what applies to any enterprise
including ISPs. It's obvious that many things will apply both to end-user
enterprise networks and to ISP networks, but (for example) renumbering
mass-market access devices would be ISP-specific. In the other direction,
mechanisms for relating individual host MAC addresses to wiring topology
and to address assignment mainly apply to campus-style enterprise
networks.

Anyway - I agree that there is certainly a need to define crisply what
"enterprise network" means to us. We could look at RFC 4057:

  "Enterprise Network - A network that has multiple internal links, one
                        or more router connections to one or more
                        Providers, and is actively managed by a network
                        operations entity.

   Provider           - An entity that provides services and
                        connectivity to the Internet or other private
                        external networks for the enterprise network."

and at the section "2. Brief Description of a Generic ISP Network" in RFC 4029.

(I'm not sure this was a correct chartering decision, and it could certainly
be reviewed before IETF 82.)

   Brian

---

From: Roger Jørgensen <[email-masked]>
Date: Thu, 21 Jul 2011 08:49:41 +0200

On Wed, Jul 20, 2011 at 11:25 PM, Brian E Carpenter
<[email-masked]> wrote:
<snip>
>                        external networks for the enterprise network."

atleast in my head an ISP is a network build for transporting data
between several edges and toward many uplinks (peers/IXs). Very few
rules on what is allowed or not.
An enterprise network on the other hand is "closer" to the end user
(client). Enterprise networks have many clients on many LANs that they
interconnected, and then they have few uplinks out of their network.
And also enterprise can be considered a semi-closed network protected
by firewall that only allow some traffic outbound and little incoming.

LAN centric vs transport centric?

-- 

Roger Jorgensen           |
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]