Subject: Re: [rfc-i] Fwd: New Version Notification for draft-flanagan-7322bis-00.txt

From: Julian Reschke <[email-masked]>
Date: Wed, 3 May 2017 10:00:29 +0200

On 2017-03-10 21:27, Heather Flanagan (RFC Series Editor) wrote:
> FYI, I am kicking off the refresh of the RFC Style Guide. Significant
> changes include:
> ...

Out of curiosity: what's the plan here? The draft is two months old, 
feedback was sent, then... silence?

Best regards, Julian
_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Wed, 3 May 2017 06:25:30 -0700

> feedback was sent, then... silence?

The plan is to have a -01 out this month. I was discussing some of the
areas of potential change (capitalization of working group, referencing
subseries) with the RPC yesterday, and will be discussing normative
references for open source code with the IESG at their retreat in mid-May.

-Heather

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Thu, 4 May 2017 16:33:58 -0700

On 3/11/17 5:55 AM, Julian Reschke wrote:
> <https://tools.ietf.org/html/draft-flanagan-7322bis-00#section-4.8.6.5>:
> 
>> 4.8.6.5.  Referencing Errata
>>
>>    The following format is required when a reference to an erratum
>>    report is necessary:
>>
>>    [ErrNumber]  RFC Errata, Erratum ID number, RFC number, <URI>.
>>
>>    [Err1912]  RFC Errata, Erratum ID 1912, RFC 2978, xxx.
> 
> In V3, we'd format that as:
> 
>> <reference anchor="Err1912" quoteTitle="false" target="xxx">
>>   <front>
>>     <title>Errata ID 1912</title>
>>     <author><organization>RFC Errata</organization></author>
>>   </front>
>>   <seriesInfo name="RFC" value="2978"/>
>> </reference>
> 
> Observations:
> 
> 1) That makes it look like this references actually RFC 2978, so the
> seriesInfo element is very misleading.
> 
> 2) No date is specified.
> 
> Proposal:
> 
> <reference anchor="Err1912" quoteTitle="false"
> target="https://www.rfc-editor.org/errata_search.php?eid=1912">
>   <front>
>     <title>RFC 2978 Erratum 1912</title>
>     <author><organization>RFC Errata</organization></author>
>   </front>
>   <seriesInfo name="RFC Errata" value="1912"/>
>   <date year="2009" month="October"/>
> </reference>
> 
> Giving:
> 
> [Err1912]  RFC Errata, RFC 2978 Erratum 1912, RFC Errata 1912, October
>            2009, <https://www.rfc-editor.or/errata_search.php?eid=1912>
> 
> a) This make seriesInfo actually meaningful.
> 
> b) The URI of course should be aligned with what the future format is;
> for instance <https://www.rfc-editor.org/errata/1912>.
> 
> c)
> <https://greenbytes.de/tech/webdav/rfc7991.html#element.reference.attribute.quoteTitle>
> allows us to have an unquoted title, but I'd like to question whether we
> *really* need a special case here.
> 
> Best regards, Julian
> 

Hello all,

The effort to make better, stable errata URLs is done. The format of the
URL is:

https://www.rfc-editor.org/errata/eid####

(e.g., https://www.rfc-editor.org/errata/eid4920)

Note that for the concatenated records (the "Full Records" in a search
on the RFC Editor website) those remain URL search strings.

I will be adjusting the Style Guide, and the RPC will manage the
references as needed for documents in our queue.

Please let me know if you have any questions!
Heather

---

From: Julian Reschke <[email-masked]>
Date: Fri, 5 May 2017 08:29:54 +0200

> (e.g., https://www.rfc-editor.org/errata/eid4920)

Awesome.

> on the RFC Editor website) those remain URL search strings.

I assume you mean "all errata for RFC x"? I think it would be good to 
also have a nicer URI for these, but it's not as important than the 
actual erratum ID...

Best regards, Julian

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Fri, 5 May 2017 04:38:49 -0700

> also have a nicer URI for these, but it's not as important than the

Yes, when you search for all errata for an RFC _and_ click on the "Full
Records" option instead of the "Summary Table" option.

-Heather