Subject: [rfc-i] Bibtex and other citation formats for I-Ds and RFCs

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Jul 2019 17:30:08 +0200

One of the most frequently asked questions of my students is “where do I find bibtex for the drafts and RFCs I’m consulting”.  (Actually, they usually google it and use some random bibtex with questionable quality, after which I ask them where that nonsense came from, and then they ask.)

Is that something we can make more accessible to people who need to write papers that employ standards and standards proposals?

Grüße, Carsten

_______________________________________________
rfc-interest mailing list
[email-masked]
https://www.rfc-editor.org/mailman/listinfo/rfc-interest

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 17 Jul 2019 18:17:47 +0200

Hi Carsten,

On 2019-07-17 17:30, Carsten Bormann wrote:
> One of the most frequently asked questions of my students is “where
> do I find bibtex for the drafts and RFCs I’m consulting”. (Actually,
> they usually google it and use some random bibtex with questionable
> quality, after which I ask them where that nonsense came from, and
> then they ask.)
> 
> Is that something we can make more accessible to people who need to
> write papers that employ standards and standards proposals?

Sure; but I'm not sure what to do.  Suggestions?

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Jul 2019 18:24:57 +0200

> Sure; but I'm not sure what to do.  Suggestions?

I think that in addition to 

reference.I-D.birkholz-rats-architecture.xml

we should offer

reference.I-D.birkholz-rats-architecture.bibtex

We should agree how to get from the first to the second based on community consensus citation guidelines (probably starting from https://tools.ietf.org/html/draft-carpenter-rfc-citation-recs-01, but also note the thread behind https://www.rfc-editor.org/pipermail/rfc-interest/2009-August/001435.html).  The actual programming is pretty trivial once we have agreed on the principles.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Jul 2019 18:29:13 +0200

Oh, and we probably should have a friendly interface like the one the students always find first:

http://notesofaprogrammer.blogspot.com/2014/11/bibtex-entries-for-ietf-rfcs-and.html

Except that it could be a bit friendlier (see comments on this page) and actually work.

Grüße, Carsten

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 17 Jul 2019 17:33:24 +0100

WARNING: banning rules detected suspect part(s),
do not open unless you know what you are doing

Subject: Re: [rfc-i] Bibtex and other citation formats for I-Ds and RFCs
From: Stephen Farrell <[email-masked]>
To: Carsten Bormann <[email-masked]>, RFC Interest <[email-masked]>
Date: Wed, 17 Jul 2019 17:33:24 +0100

Hiya,

> write papers that employ standards and standards proposals?

Not sure how good it is, but here's what I do:

- I take rfc.bib from [1]
- I run the attached python script (written by Elwyn Davies
  a few years ago) for internet drafts.

Seems to work well enough.

Cheers,
S.

[1] http://www.tm.uka.de/~bless/bibrfcindex.html

> 
> Grüße, Carsten
> 
> _______________________________________________ rfc-interest mailing
> list [email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Wed, 17 Jul 2019 20:48:20 +0300

> Is that something we can make more accessible to people who need to write papers that employ standards and standards proposals?

The datatracker has this already for each draft and RFC, e.g., https://datatracker.ietf.org/doc/draft-ietf-quic-applicability/bibtex

There is a button in the "Formats" row on each document page, e.g., https://datatracker.ietf.org/doc/draft-ietf-quic-applicability/

Lars

---

From: Lars Eggert <[email-masked]>
Date: Wed, 17 Jul 2019 20:50:08 +0300

> There is a button in the "Formats" row on each document page, e.g., https://datatracker.ietf.org/doc/draft-ietf-quic-applicability/

Oh, and there is also https://eggert.org/software/id2bib.pl and https://eggert.org/software/rfc2bib.pl in case you want a command line thing.

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 17 Jul 2019 20:00:25 +0200

On 2019-07-17 19:48, Lars Eggert wrote:
> The datatracker has this already for each draft and RFC, e.g.,
> https://datatracker.ietf.org/doc/draft-ietf-quic-applicability/bibtex
>
>  There is a button in the "Formats" row on each document page, e.g.,
> https://datatracker.ietf.org/doc/draft-ietf-quic-applicability/

Lars expressed what I intended to reply, here.

Carsten, if you were aware of this, a few words on how to improve this
to help people more easily find the bibxml entries would be valuable.

I'm not sure how to interpret your proposal of resource.*.bibxml files
given the availability of https://datatracker.ietf.org/doc/*/bibtex --
is the extension or resource prefix (resource.I-D....) important here?

If you weren't aware of this, what was the current resource you usually
point your students at?

Best regards,

	Henrik

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Jul 2019 08:53:08 +1200

Roland Bless offers https://tm.uka.de/~bless/rfc.bib which mainly works for me, if I'm not fussy about an expired certificate.

Opinions vary on how to construct the bibtex entry: https://www.cs.auckland.ac.nz/~brian/RFCs-CCR-201001.pdf

Regards
   Brian Carpenter

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 17 Jul 2019 23:03:18 +0200

> to help people more easily find the bibxml entries would be valuable.

The usual place people look for I-Ds is tools.ietf.org/html/---draftname---

(datatracker is branded a bit as an internal cockpit for standards jockeys, so students are less likely to examine the buttons there.)

Maybe tools’ HTML header should add a bibtex link?
(I know it is getting tight in there for some documents.  You might go for non-monospaced for the links and versions, which would also nicely set the links off from the actual content.)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 17 Jul 2019 23:22:45 +0200

On 2019-07-17 23:03, Carsten Bormann wrote:
> (datatracker is branded a bit as an internal cockpit for standards
> jockeys, so students are less likely to examine the buttons there.)

Aha. Ok.

> Maybe tools’ HTML header should add a bibtex link?

Sounds like a plan, yes.

> (I know it is getting tight in there for some documents. You might go
> for non-monospaced for the links and versions, which would also
> nicely set the links off from the actual content.)

Yes.  Mmm.  I'll do some experimentation.  Thanks!

	Henrik

---

From: Michael Richardson <[email-masked]>
Date: Wed, 17 Jul 2019 17:50:40 -0400

In addition to what you proposed,

    > reference.I-D.birkholz-rats-architecture.bibtex

if you go to, for instance:
   https://www.rfc-editor.org/info/rfc7030

you get cite this RFC in TXT and XML, and I'd like to see the RFC-editor
provide the bibtex here.

The biggest question is how to get these pages to rank higher in google
searches of the RFCnumbers.  

https://www.rfc-editor.org/rfc/rfc7030.html
does link back to the /info/rfc7030 page, but I suspect that older RFCs do not.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 18 Jul 2019 06:55:05 +0000

On a related subject, most students and professionals use "Google Scholar" to find sources,
and unfortunately RFCs and IDs don't usually come up there
(or come up in severely mangled form).

As a secondary issue, this also means that RFCs (although having undergone extensive peer review),
do not count there towards citation counts or h-index.

Does anyone here have access to whomever can add the RFC series to Scholar search ?

Y(J)S

-----Original Message-----
From: rfc-interest [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: יום ד 17 יולי 2019 19:29
To: Henrik Levkowetz <[email-masked]>
Cc: RFC Interest <[email-masked]>
Subject: Re: [rfc-i] Bibtex and other citation formats for I-Ds and RFCs

https://eur01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fnotesofaprogrammer.blogspot.com%2F2014%2F11%2Fbibtex-entries-for-ietf-rfcs-and.html&amp;data=01%7C01%7Cyaakov_s%40rad.com%7Ca61493277f1d4ce2c54d08d70ad3eccc%7Cf9047108cc2c4e4897a343fad1b3bf9d%7C1&amp;sdata=%2Fu3zNBGeWE%2FQCHb4s67AJlsk75PEInWugv13DCPeZ7U%3D&amp;reserved=0

Grüße, Carsten

https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Fmailman%2Flistinfo%2Frfc-interest&amp;data=01%7C01%7Cyaakov_s%40rad.com%7Ca61493277f1d4ce2c54d08d70ad3eccc%7Cf9047108cc2c4e4897a343fad1b3bf9d%7C1&amp;sdata=%2Bxd2Ez2nNl0GzJQnnj7fg36rGJ5p0EowoPEVuR6bmv4%3D&amp;reserved=0

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 18 Jul 2019 09:17:47 +0200

Hmm, for me they come up, usually from tools.ietf.org, but also sometimes from random places. 
Rfcs have dois, so they really should be coming up... But even I-Ds do for me.

Sent from mobile

> On 18. Jul 2019, at 08:55, Yaakov Stein <[email-masked]> wrote:
>