Subject: [Rfc-markdown] Element middle content does not follow the DTD, expecting (section)+, got nothing.

From: Niels ten Oever <[email-masked]>
Date: Sat, 15 Jul 2017 23:28:02 +0200

Hi all,

I am getting this weird error while running make that I don't really know how to fix:

$ make
kramdown-rfc2629 draft-451-imp-report.md > 451-imp-report.staging.xml
mv 451-imp-report.staging.xml draft-451-imp-report.xml
xml2rfc draft-451-imp-report.xml --html
Parsing file draft-451-imp-report.xml
ERROR: Unable to validate the XML document: draft-451-imp-report.xml
 draft-451-imp-report.xml: Line 72: Element middle content does not follow the DTD, expecting (section)+, got nothing.
Makefile:11: recipe for target 'draft-451-imp-report.html' failed
make: *** [draft-451-imp-report.html] Error 1

Whereas I think I am following the guidelines.

I found someone else had the same problem here: https://github.com/cabo/kramdown-rfc2629/issues/29

I am using kramdown from the Debian repo:

$ apt-cache show ruby-kramdown-rfc2629 
Package: ruby-kramdown-rfc2629
Version: 1.0.36-1

The draft can be found here: https://github.com/451hackathon/451-imp-report/blob/master/draft-451-imp-report.md and attached.

All pointers very welcome.

Thanks!

Niels

-- 

Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint	   2458 0B70 5C4A FD8A 9488  
                   643A 0ED8 3F3A 468A C8B3

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 16 Jul 2017 00:29:55 +0200

> draft-451-imp-report.xml: Line 72: Element middle content does not follow the DTD, expecting (section)+, got nothing.

I don’t get that.

Maybe there is a problem with the locale set on your system (the markdown contains beyond-ASCII characters).
Can you send me the XML as well?

Maybe you want to call xml2rfc with -u to actually get those beyond-ASCII characters.

Grüße, Carsten

---

From: Niels ten Oever <[email-masked]>
Date: Wed, 19 Jul 2017 14:02:03 +0200

> Maybe you want to call xml2rfc with -u to actually get those beyond-ASCII characters.

It was the locale set! Thank you very much Carsten!

-- 
Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint    8D9F C567 BEE4 A431 56C4
                     678B 08B5 A0F2 636D 68E9