Subject: Re: [Rfc-markdown] [xml2rfc] Is the --v3 switch still needed?

From: Carsten Bormann <[email-masked]>
Date: Sun, 24 Oct 2021 18:33:26 +0200

On 2021-10-24, at 17:07, Robert Moskowitz <[email-masked]> wrote:
> 
> Do we still need to include the --v3 switch on the command line?
> 
> particularly if we have
> 
> <rfc ... version="3">
> 
> getting tired typing it in all the time...

It is generally a big thing to change a command line interface, as the command may be embedded in a lot of scripts (it certainly is for xml2rfc), which then do unexpected things.

I happen to be thinking about a related kind of change for kdrfc, the “driver” command for kramdown-rfc2629.  That change would require some indication of v3ness in the markdown file; but maybe that same indication would be a nice way to get rid of needing to override old defaults (such as setting stand_alone: true, consensus: true if category: std; also the need to declare ipr: trust200902 or pi: [toc, sortrefs, symrefs, comments], etc.).

Feedback about the latter welcome to [email-masked].

Grüße, Carsten

---

From: Tim Wicinski <[email-masked]>
Date: Sun, 24 Oct 2021 15:30:45 -0400

In version 3.10.0 It appears the default for --v3 is True, which is what I
would have done:

    formatoptions.add_argument('--v3', action='store_true', default=True,
                           help='with --text and --html: use the v3
formatter, rather than the legacy one')

Try it w/out the --v3 if you are up to date (and if not....)

tim

On Sun, Oct 24, 2021 at 12:33 PM Carsten Bormann <[email-masked]> wrote:

> It is generally a big thing to change a command line interface, as the
> command may be embedded in a lot of scripts (it certainly is for xml2rfc),
> which then do unexpected things.
>
> I happen to be thinking about a related kind of change for kdrfc, the
> “driver” command for kramdown-rfc2629.  That change would require some
> indication of v3ness in the markdown file; but maybe that same indication
> would be a nice way to get rid of needing to override old defaults (such as
> setting stand_alone: true, consensus: true if category: std; also the need
> to declare ipr: trust200902 or pi: [toc, sortrefs, symrefs, comments],
> etc.).
>
> _______________________________________________
> Rfc-markdown mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rfc-markdown
>

---

From: Robert Moskowitz <[email-masked]>
Date: Sun, 24 Oct 2021 15:38:57 -0400

I am on ver 3.10.0, but like how do you know that the proper txt was 
built and not some fall back to whatever v2 would do?

Perhaps mv what I did with --v3 to a different name, run without the 
option and use rfcdiff to compare the two txt files?

On 10/24/21 3:30 PM, Tim Wicinski wrote:
> In version 3.10.0 It appears the default for --v3 is True, which is 
> what I would have done:
>
> On Sun, Oct 24, 2021 at 12:33 PM Carsten Bormann <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     On 2021-10-24, at 17:07, Robert Moskowitz <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     It is generally a big thing to change a command line interface, as
>     the command may be embedded in a lot of scripts (it certainly is
>     for xml2rfc), which then do unexpected things.
>
>     I happen to be thinking about a related kind of change for kdrfc,
>     the “driver” command for kramdown-rfc2629.  That change would
>     require some indication of v3ness in the markdown file; but maybe
>     that same indication would be a nice way to get rid of needing to
>     override old defaults (such as setting stand_alone: true,
>     consensus: true if category: std; also the need to declare ipr:
>     trust200902 or pi: [toc, sortrefs, symrefs, comments], etc.).
>
>     Feedback about the latter welcome to [email-masked]
>     <mailto:[email-masked]>.
>
>     Grüße, Carsten
>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/rfc-markdown>
>

---

From: Tim Wicinski <[email-masked]>
Date: Sun, 24 Oct 2021 16:35:27 -0400

On Sun, Oct 24, 2021 at 3:39 PM Robert Moskowitz <[email-masked]>
wrote:

> I am on ver 3.10.0, but like how do you know that the proper txt was built
> and not some fall back to whatever v2 would do?
>
I tested it just as you said and my files were identical.

Your Mileage, etc etc

tim

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 24 Oct 2021 22:40:06 +0200

On 2021-10-24, at 22:35, Tim Wicinski <[email-masked]> wrote:
> 
> I am on ver 3.10.0, but like how do you know that the proper txt was built and not some fall back to whatever v2 would do?

The v3 formatter uses a different date format; that is usually the easiest giveaway.

Compare https://datatracker.ietf.org/doc/draft-ietf-emailcore-rfc5322bis/
29 September 2021 (v3 formatter date format)

with https://datatracker.ietf.org/doc/draft-ietf-emailcore-rfc5321bis/
October 24, 2021 (v2 formatter date format)

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 25 Oct 2021 11:29:12 -0400

I just did the test with my draft-ietf-drip-rid doc and they were identical.

I will proceed with caution, but being I am lazy and saving typing 5 
characters (when I copy the draft file name into the terminal window) I 
will happily stop including this option.

As I said, I would *THINK* that the <rfc ... verison=3> content in the 
xml should flag xml2rfc how to proceed.

On 10/24/21 4:35 PM, Tim Wicinski wrote:
>
>
> On Sun, Oct 24, 2021 at 3:39 PM Robert Moskowitz <[email-masked] 
>     I am on ver 3.10.0, but like how do you know that the proper txt
>     was built and not some fall back to whatever v2 would do?
>
>     Perhaps mv what I did with --v3 to a different name, run without
>     the option and use rfcdiff to compare the two txt files?
>
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 25 Oct 2021 17:43:07 +0200

On 2021-10-25, at 17:29, Robert Moskowitz <[email-masked]> wrote:
> I will proceed with caution, but being I am lazy and saving typing 5 characters (when I copy the draft file name into the terminal window) I will happily stop including this option.
> 
> As I said, I would *THINK* that the <rfc ... verison=3> content in the xml should flag xml2rfc how to proceed.

Makes sense.
The most important thing is that, when you are done, you submit the XML and *not* the TXT.

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 25 Oct 2021 11:50:46 -0400

> The most important thing is that, when you are done, you submit the XML and *not* the TXT.

Except when you encounter a bug in the submission tool and it can't 
generate your txt from your xml like I had a couple weeks ago...

:)