Subject: [Rfced-future] Issue 143: RSAB mailing list archives

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 5 Jan 2022 18:37:16 -0700

The draft says:

    The RSAB shall keep a public record of its proceedings, including
    minutes of all meetings and a record of all decisions.

Brian Carpenter noted: "As far as I can see, we don't specify whether 
the RSAB's mailing list does, or doesn't, have a public archive."

Do folks have opinions on this point?

(Without my editor hat on, I think it's preferable to make the list 
archives public, in the interest of transparency.)

Peter

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 6 Jan 2022 14:22:43 +0000

On 1/5/22, 8:37 PM, "Peter Saint-Andre" <[email-masked]> wrote:

    The draft says:

Similar to what I just posted, can't we just say this group MUST follow standard IETF practices for transparency, notification, etc etc?

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 6 Jan 2022 08:44:23 -0800

+1. If people feel we have to copy by value, then let's just do it exactly.

On Thu, Jan 6, 2022 at 6:22 AM Salz, Rich <rsalz=[email-masked]>
wrote:

> Similar to what I just posted, can't we just say this group MUST follow
> standard IETF practices for transparency, notification, etc etc?
>
>
> --
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future
>

---

From: Michael StJohns <[email-masked]>
Date: Thu, 6 Jan 2022 12:20:44 -0500

> Similar to what I just posted, can't we just say this group MUST follow standard IETF practices for transparency, notification, etc etc?
Because this (RSWG) group is not an IETF working group, and because we 
don't want to have to special case this stuff so that changes to IETF 
processes can't cause changes to RSWG processes in a manner that are 
unexpected.

The RSWG will be more like the Nomcom which has its own set of operating 
instructions, but adopts things by reference that are less likely to 
affect its remit (e.g. general IETF harassment guidance) than an IETF WG 
that must change its behavior if the IESG changes an applicable BCP or 
Informational document.   In the instant case, the record keeping, 
meeting schedule, etc are all going to need to be RSAB/RSWG specific.

So copy by value is fine (EKRs note and Peter's draft text), copy by 
reference could be problematic later.

Mike

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 6 Jan 2022 18:53:09 +0000

>  In the instant case, the record keeping, 

Okay. I'm not convinced but I will not argue the point any more.

I wonder how it could be problematic (I dislike building things for hypotheticals), but so be it.

I withdraw my concerns.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 7 Jan 2022 08:58:24 +1300

> archives public, in the interest of transparency.)

So, ignoring the copy-by-value vs copy-by-reference detail, my
opinion is that RSAB email should be in a public archive *except*
for anything that amounts to an "executive session" discussion.

    Brian

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 6 Jan 2022 16:45:47 -0700

> for anything that amounts to an "executive session" discussion.

Proposed text:

###

The RSAB is expected to operate via an email discussion list,
in-person meetings, teleconferencing systems, and any additional
tooling it deems necessary.

The RSAB shall keep a public record of its proceedings, including
minutes of all meetings and a record of all decisions. Email messages
sent to the RSAB email discussion list or exchanged among all members
of the RSAB shall be publicly archived, with the exception of topics
that require confidentiality (e.g., personnel matters). Similarly,
meeting minutes may exclude detailed information about topics
discussed under executive session, but should note that such topics
were discussed.

###

Peter

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 7 Jan 2022 13:51:52 +1300

wfm

Regards
    Brian

---

From: Mirja Kuehlewind <[email-masked]>
Date: Fri, 7 Jan 2022 12:38:13 +0100

I don’t have a strong opinion but I want to note that is not what we do for the IESG and IAB. While there is not necessarily  anything secret on those lists, I always thought is makes the work easier because you can just freely send things without e.g. worrying too much about the exact wording. As noted by Brian and in the text below, there are always things that are confidential and need to be send to a list without public archive. Given such a list always has to exist, my guess it that people would just end up using that list more because it just easier than lengthly considering what to send where.

So why do we think that the mail archive for the RSAB needs to be open in additional to e.g. minutes which should cover all the important points?

> On 7. Jan 2022, at 01:51, Brian E Carpenter <[email-masked]> wrote:
> 
> wfm
> 
> Regards
>   Brian
>

---

From: Lars Eggert <[email-masked]>
Date: Fri, 7 Jan 2022 16:50:15 +0200

+1 to Mirja

-- 
Sent from a mobile device; please excuse typos.

> On Jan 7, 2022, at 13:38, Mirja Kuehlewind <[email-masked]> wrote:
>

---

From: Wes Hardaker <[email-masked]>
Date: Fri, 7 Jan 2022 09:45:49 -0800

> I don’t have a strong opinion but I want to note that is not what we do
> for the IESG and IAB.

Notes: the RFC futures group was tasked with developing a replacement for
the existing mechanism (RSOC) that had better transparency and
accountability.  Public archives offer significantly more transparency, so
the group should think about how far to swing the pendulum from where the
very tightly closed RSOC group was with respect to the decision making
process that the RSAB will need to conduct.

> While there is not necessarily  anything secret on those lists, I always
> thought is makes the work easier because you can just freely send things
> without e.g. worrying too much about the exact wording.

I think in today's internet you must assume that anything you send by mail
is archived.  It's just a question of whether or not it's publicly archived
or whether you have to ask someone for a copy of it, because almost
assuredly someone or multiple someones do have copies.
-- 
Wes Hardaker
USC/ISI

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 8 Jan 2022 09:06:46 +1300

On 08-Jan-22 06:45, Wes Hardaker wrote:
> 
>     I don’t have a strong opinion but I want to note that is not what we do for the IESG and IAB.
> 
> 
> Notes: the RFC futures group was tasked with developing a replacement for the existing mechanism (RSOC) that had better transparency and accountability.  Public archives offer significantly more transparency, so the group should think about how far to swing the pendulum from 
where the very tightly closed RSOC group was with respect to the decision 
making process that the RSAB will need to conduct.
> 
>     While there is not necessarily  anything secret on those lists, I always thought is makes the work easier because you can just freely send things without e.g. worrying too much about the exact wording. 
> 
> 
> I think in today's internet you must assume that anything you send by mail is archived.  It's just a question of whether or not it's publicly archived or whether you have to ask someone for a copy of it, because almost assuredly someone or multiple someones do have copies.

Indeed. And whatever we write here, there will in the real world be two lists. One called [email-masked] with a public archive and one without a public archive. (The second one might not be a mailman list as such, but whatever we write it *will* exist in some form. I don't think I've ever been in a committee or other team that didn't sometimes communicate "off list". That's just how the world works.)

However, IMHO we can best promote transparency and civil discourse by mandating a public archive in this case.

      Brian

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 8 Jan 2022 14:19:40 +0000

On 07/01/2022 17:45, Wes Hardaker wrote:
>   Public archives offer significantly more transparency, so

+1, I'd support whatever "main" list is used by the RSAB
being publicly archived. It's ok if they have one or more
private lists too (same as IAB/IESG "confirmation" lists
and similar) but making the main list archive public is a
good improvement.

Cheers,
S.

---

From: Lars Eggert <[email-masked]>
Date: Mon, 10 Jan 2022 09:20:14 +0200

Hi,

> and similar) but making the main list archive public is a

I'd like to come back to Mirja's question: why do we think we need a public mailing list archive in addition to all the things that are already public, such as minutes, etc., is needed?

I can understand that the pendulum is swinging towards maximum transparency now, given the closed nature of the RSOC.

But as Mirja has outlined, a public archive does put somewhat of a burden on the operation of the RSAB, because one will have to much more carefully word each message to the list.

This may be an acceptable tradeoff for this particular list, but it's also setting a precedent in the IETF, which makes me nervous.

Thanks,
Lars (as an individual)

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 10 Jan 2022 19:45:45 +1100

On Mon, Jan 10, 2022, at 18:20, Lars Eggert wrote:
> But as Mirja has outlined, a public archive does put somewhat of a 
> burden on the operation of the RSAB, because one will have to much more 
> carefully word each message to the list.
>
> This may be an acceptable tradeoff for this particular list, but it's 
> also setting a precedent in the IETF, which makes me nervous.

My opinion only: this is not a group that deals with personnel issues in its normal course of business.  There are few other reasons to conduct private business.  Public archives seem totally fine here.

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 10 Jan 2022 14:23:22 +0000

> also setting a precedent in the IETF, which makes me nervous.

I think it's a good -- nay, excellent -- precedent to set. There are well-understood mechanisms to be used when conversations need to be private; executive session, off-the-record, "off-list" emails, etc. etc.

>    My opinion only: this is not a group that deals with personnel issues in its normal course of business.  There are few other reasons to conduct private business.  Public archives seem totally fi…

Completely agree.

---

From: Wes Hardaker <[email-masked]>
Date: Mon, 10 Jan 2022 08:46:40 -0800

Top posting because... phone...

One major reason for needing public archives is to document discussions for
referring future questions and people back to discussions where topics have
already been discussed. We do this in ietf working groups all the time.

-- 
Wes Hardaker
USC/ISI

On Sun, Jan 9, 2022, 23:20 Lars Eggert <[email-masked]> wrote:

> I'd like to come back to Mirja's question: why do we think we need a
> public mailing list archive in addition to all the things that are already
> public, such as minutes, etc., is needed?
>
> I can understand that the pendulum is swinging towards maximum
> transparency now, given the closed nature of the RSOC.
>
> But as Mirja has outlined, a public archive does put somewhat of a burden
> on the operation of the RSAB, because one will have to much more carefully
> word each message to the list.
>
> This may be an acceptable tradeoff for this particular list, but it's also
> setting a precedent in the IETF, which makes me nervous.
>
> Thanks,
> Lars (as an individual)
>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 11 Jan 2022 08:41:35 +1300

>      > also setting a precedent in the IETF, which makes me nervous.

I understand Lars' hesitation, but I dispute that this sets a precedent
in the IETF. This is not an IETF discussion. The RSAB is not comparable
to either the IAB or the IESG and the arguments are totally different.
I'd be happy to discuss any questions about IETF lists over on an IETF
list.
  
> I think it's a good -- nay, excellent -- precedent to set. There are well-understood mechanisms to be used when conversations need to be private; executive session, off-the-record, "off-list" email…

As I've already pointed out, the RSAB *will* use such mechanisms when they
need to, whatever we do or don't write in the present document.

>>     My opinion only: this is not a group that deals with personnel issues in its normal course of business.  There are few other reasons to conduct private business.  Public archives seem totally…

Neither will the RSAB need to discuss legal, contractual or financial
details. Its remit is really quite narrow, and as Wes said, referring
back to earlier discussions may be very useful.

To be complete, there's one issue where privacy would matter:
Issue 151: Consultation / Approval for RSCE Selection committee.
That would be a case where off-list discussion would be needed.

Regards
    Brian

---

From: Lars Eggert <[email-masked]>
Date: Mon, 10 Jan 2022 21:58:00 +0200

On 2022-1-10, at 18:46, Wes Hardaker <[email-masked]> wrote:
> One major reason for needing public archives is to document discussions for referring future questions and people back to discussions where topics have already been discussed. We do this in ietf working groups all the time.

Would these discussions not happen in the RSWG anyway?

Thanks,
Lars

---

From: Eliot Lear <[email-masked]>
Date: Mon, 10 Jan 2022 21:29:43 +0100

On 10.01.22 20:58, Lars Eggert wrote:
> On 2022-1-10, at 18:46, Wes Hardaker<[email-masked]>  wrote:

Mostly, one would hope.  There are a couple of exceptions specified in 
the draft:

  * When there is an ambiguity/conflict between streams that requires an
    interpretation from the RSAB.
  * Comments that flow to the RSAB from the community.

On this latter point, my one question is whether people sending input to 
the RSAB need some sort of notice that their messages will be publicly 
archived prior to being shared.  That might require a little bit of 
tools work if people agree with my concern.

Eliot

---

From: Wes Hardaker <[email-masked]>
Date: Mon, 10 Jan 2022 18:38:48 -0800

So, bringing it up to a summary level (my previous notes were about why we
do things in other places rather than personal opinion -- I'm generally
trying to stay neutral in these discussions)

Reasons people in this group want a mailing list archive so far:
* transparency
* being able to reference past discussions
* NEW to answer "Would these discussions not happen in the RSWG anyway?":
because it makes the RSAB begins to look like a black box where decisions
are made and minutes report high level summaries without the detailed
discussions that actually took place.
* It matches how the IETF operates (with a counter argument of "this isn't
an IETF WG")

Reasons against:
* free-conversations are easier where people don't have to worry about
being quoted/attributed
* it sets a precedence (though counter arguments have essentially asked
"for who?")

I'm sure I missed something.

---

From: Lars Eggert <[email-masked]>
Date: Tue, 11 Jan 2022 09:10:03 +0200

Hi,

On 2022-1-11, at 4:38, Wes Hardaker <[email-masked]> wrote:
> * NEW to answer "Would these discussions not happen in the RSWG anyway?": because it makes the RSAB begins to look like a black box where decisions are made and minutes report high level summaries without the detailed discussions that actually took place.

so maybe my understanding about the new model is off, but: I have understood the proposed structure to be such that the RSAB really doesn't have a lot of leeway when it comes to not approving proposals by the RSWG, especially not without immediately needing to take the discussion back to the RSWG in such cases. In other words, I'm struggling to come up with examples where significant discussions would happen inside the RSAB only.

> * It matches how the IETF operates (with a counter argument of "this isn't an IETF WG")

IMO, it doesn't. The RSWG is supposed to mirror how an IETF WG works, but not the RSAB, which is much more IESG- or IAB-like.

Thanks,
Lars

> Reasons against:
> * free-conversations are easier where people don't have to worry about being quoted/attributed
> * it sets a precedence (though counter arguments have essentially asked "for who?")
>

---

From: Martin J. Dürst <[email-masked]>
Date: Tue, 11 Jan 2022 16:32:17 +0900

Hello Lars,

On 2022-01-11 16:10, Lars Eggert wrote:
> so maybe my understanding about the new model is off, but: I have understood the proposed structure to be such that the RSAB really doesn't have a lot of leeway when it comes to not approving proposals by the RSWG, especially not without immediately needing to take the discussion back to the RSWG in such cases.

Your understanding of that part of the model is correct. But it also 
means that for that part, there won't be too much to archive anyway.

> In other words, I'm struggling to come up with examples where significant discussions would happen inside the RSAB only.

The RSAB also got another role: To 'arbitrate' between the RFC 
Production Center and the authors. There is an expectation that this 
will create some precedents, and it is preferable that these precedents, 
and the discussions that lead to them, are publicly available.

Regards,   Martin.

---

From: Eliot Lear <[email-masked]>
Date: Tue, 11 Jan 2022 08:33:47 +0100

Lars,

Adding to what Martin just wrote...

On 11.01.22 08:10, Lars Eggert wrote:
> so maybe my understanding about the new model is off, but: I have 
> understood the proposed structure to be such that the RSAB really 
> doesn't have a lot of leeway when it comes to not approving proposals 
> by the RSWG, especially not without immediately needing to take the 
> discussion back to the RSWG in such cases. In other words, I'm 
> struggling to come up with examples where significant discussions 
> would happen inside the RSAB only. 

In general, yes conversation to happen in the RSWG, but there reasons 
why the RSAB members might discuss matters among themselves, 
particularly when it comes to implementation of policies.  For example,  
“I believe I am running into an issue with the RPC over how they are 
implementing this new tool- we don't have permissions or the states we 
need”, so that they can reflect that back to the RPC.  That may not even 
entail any changes to policy, but simply to implementation.

If someone later sees this discussion and decides that the RSAB has 
missed that indeed there is a policy issue, they can raise it in the 
RSWG, but only if the list is publicly archived.  That is- having the 
list archived publicly can help keep the community informed about policy 
implementation.

While there is indeed a trust motivation, as you have mentioned, and 
having things open and transparent *mig**ht *help with that, what we 
cannot do is stop all potential bad behavior. We should be careful just 
how far we go.

Eliot

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 11 Jan 2022 11:11:42 +0100

Please see below.

> On 11. Jan 2022, at 08:32, Martin J. Dürst <[email-masked]> wrote:
> 
> Hello Lars,
> 
> Your understanding of that part of the model is correct. But it also means that for that part, there won't be too much to archive anyway.
> 
> The RSAB also got another role: To 'arbitrate' between the RFC Production Center and the authors. There is an expectation that this will create some precedents, and it is preferable that these precedents, and the discussions that lead to them, are publicly available.

These kind of discussions as well as any discussion on documents should be covered by the RSAB meeting minutes (which would also be the more useful and easy-to-find reference). This is also how the IAB and IESG works: all decisions are minuted in some kind of meeting notes; this means even if a decision is taken on the list, we will add it to the next agenda and minute it there.

I believe this is a good model and think that would also work well for the RSAB.  However, again, no strong opinions here.

Mirja

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 11 Jan 2022 17:41:22 -0700

On 1/11/22 12:33 AM, Eliot Lear wrote:
> particularly when it comes to implementation of policies. 

There's another piece here as well: working through feedback received in 
the community calls for comment. "Constituency X seems to be concerned 
about Aspect Y of Proposal Z; do we think this rises to the level of 
something that could harm the RFC Series as a whole and should one of us 
ballot CONCERN?" Having a public archive of such discussions could be 
quite valuable.

Peter

---

From: John C Klensin <[email-masked]>
Date: Wed, 12 Jan 2022 01:39:59 -0500

--On Tuesday, January 11, 2022 17:41 -0700 Peter Saint-Andre
<[email-masked]> wrote:

>>> so maybe my understanding about the new model is off, but: I
>>> have  understood the proposed structure to be such that the
>>> RSAB really  doesn't have a lot of leeway when it comes to
>>> not approving proposals  by the RSWG, especially not without
>>> immediately needing to take the  discussion back to the RSWG
>>> in such cases. In other words, I'm  struggling to come up
>>> with examples where significant discussions  would happen
>>> inside the RSAB only. 
>> 
>> In general, yes conversation to happen in the RSWG, but there
>> reasons  why the RSAB members might discuss matters among
>> themselves,  particularly when it comes to implementation of
>> policies. 
> 
> There's another piece here as well: working through feedback
> received in the community calls for comment. "Constituency X
> seems to be concerned about Aspect Y of Proposal Z; do we
> think this rises to the level of something that could harm the
> RFC Series as a whole and should one of us ballot CONCERN?"
> Having a public archive of such discussions could be quite
> valuable.

And, of course, if the RSAB is involved in the RSCE selection
process in any way, even just the selection of the selection
committee as some of us have proposed, that would be another
category of discussions that should probably be kept private.   

More generally (apologies if this has been said already),
nothing we say or do is going to prevent the stream managers
from having a private conversation (in person, on line, or in
email), or even a conversation that involves their
representatives if those are different.  Personally, I would
prefer to have the fact of those discussed be recorded, made
public, minuted, and held in the presence of the RSCE (unless
they are about the RSCE) and and ED (unless they are about them)
even if the content is not public rather than having the fact of
such a discussion kept secret and maybe key people kept out
unnecessarily.  And the latter is all I think we would
accomplish by demanding that such discussions not occur.

So, public mailing list, minutes, encouragement to make as much
public (and in those minutes) as possible, but provision for
private/meetings executive sessions if needed (and, if
necessary, a private mailing list), the fact, topics, and, where
relevant, conclusions of such sessions to be be in those public
minutes and mailing list archives even if the contents of the
discussions are not.

   john