Subject: [rmcat] WGLC for draft-ietf-rmcat-cc-requirements-02

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 17 Feb 2014 14:53:09 +0000

Hi,

we'd like to start the working group last call for draft-ietf-rmcat-cc-requirements-02. Please send your feedback to the list.

We're letting this LC run until March 12 (after the London meeting), so there will also be a chance to discuss any feedback there.

Lars

---

From: Michael Welzl <[email-masked]>
Date: Wed, 19 Feb 2014 23:25:21 +0100

Hi,

Sorry if I missed this in Randell's responses to the reviews - but this text is still there and should be fixed IMO:

***
   2.   The algorithm must be fair to other flows, both realtime flows
        (such as other instances of itself), and TCP flows, both long-
        lived and bursts such as the traffic generated by a typical web
        browsing session.  Note that 'fair' is a rather hard-to-define
        term.

        A.  Existing flows at a bottleneck must also be fair to new
            flows to that bottleneck, and must allow new flows to ramp
            up to a useful share of the bottleneck bandwidth quickly.
***

Being fair to other instances of itself is one issue, being "fair" to TCP is another one. The latter is covered by the text about trying to avoid starvation of TCP, so I suggest that this item here should not bring TCP into the mix and only talk about other instances of itself.

Regarding fairness, I don't think that saying "must be fair" and "Note that 'fair' is hard to define" isn't really useful - we need to be clear about what we mean. (Sub-item A doesn't make the paragraph above it clearer, it just adds a restriction. I have no problem with sub-item A although I think it's unnecessary.)

I once proposed: "Send at roughly the same rate under similar conditions."
(with more details in a previous email with subject "Fairness", see the list archives).

It has sldo been said that we should mandate RTT-independence too. I'm for it.

What do others think?

Cheers,
Michael