Subject: [rmcat] Open source code for draft-zhu-rmcat-video-traffic-source

From: Sergio Mena <[email-masked]>
Date: Thu, 29 Oct 2015 15:58:03 +0100

Hi all,

We just got Cisco's green light for open-sourcing the C++ classes 
implementing the synthetic codecs described in 
draft-zhu-rmcat-video-traffic-source, which we use in Cisco for 
evaluating congestion control algorithms.

Please find the source code at the following location:

https://github.com/sergio-mena/syncodecs

There is extensive documentation on how to use the C++ classes in the 
header (".h") files. There are also a couple example applications 
demonstrating the use of the synthetic codecs. The "tar.gz" file 
contains example trace files that can be used with the trace-based codecs.

Feedback/questions/suggestions are welcome.

Thanks,

Sergio

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Thu, 29 Oct 2015 15:54:49 +0000

+1, great!!!

Thanks for the effort.

BR

Zahed

> -----Original Message-----
> From: Sergio Mena [mailto:[email-masked]]
> Sent: den 29 oktober 2015 15:58
> To: [email-masked]
> Cc: Karen E. E. Nielsen; Mirja Kühlewind; Xiaoqing Zhu (xiaoqzhu);
> Zaheduzzaman Sarker
> Subject: Open source code for draft-zhu-rmcat-video-traffic-source
> 
> 
> Hi all,
> 
> We just got Cisco's green light for open-sourcing the C++ classes implementing
> the synthetic codecs described in draft-zhu-rmcat-video-traffic-source, which
> we use in Cisco for evaluating congestion control algorithms.
> 
> There is extensive documentation on how to use the C++ classes in the header
> (".h") files. There are also a couple example applications demonstrating the use
> of the synthetic codecs. The "tar.gz" file contains example trace files that can
> be used with the trace-based codecs.
>