Subject: Re: [rmcat] Generic RTCP feedback message AGAIN

From: Zaheduzzaman Sarker <[email-masked]>
Date: Thu, 3 Dec 2015 15:37:09 +0100

On 2015-11-24 17:27, Colin Perkins wrote:

> I’d suggest either updates to the candidate drafts, or email on the list.
>
>> Assuming Yes. Where shall the outcome of the work be specified ?
>> draft-perkins-rmcat-rtp-cc-feedback-01.txt or new draft
>
> I view the role of that as being to describe what’s possible in terms of responsiveness of RTCP feedback. It talks about how much feedback can be provided, and how quickly, not what feedback information is needed. The combination of that draft, and requirements from the candidate drafts, will tell us whether RTCP feedback is sufficient, or if it needs some extensions/alternatives.
>
+1.

BR
-- 
Zahed

==================================================
ANM ZAHEDUZZAMAN SARKER

Ericsson AB
Services, Media and Network Features
Laboratoriegränd 11
97128 Luleå, Sweden
Phone +46 10 717 37 43
Fax +46 920 996 21
SMS/MMS +46 76 115 37 43
[email-masked]
www.ericsson.com

==================================================

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Thu, 3 Dec 2015 15:36:18 +0100

On 2015-11-16 13:51, Karen Elisabeth Egede Nielsen wrote:
> HI,
>
> At the 2nd RMCAT session we proposed the following:
>
> * Give usage of a common feedback message for sender side only RMCAT CC's
> _a try_.
>
> With the following proposed way forward
>
> *1* Requirements to be considered in each CC algs draft
> *2* Analyse required feedback rates and timing as well as content
>     and point to existing remedies and/or what new needed
>
> At the RMCAT session agreement on this not established.
> Only *1* was agreed upon.  Whereas *2* was left for future potentially.
>
> NOW given the recent discussion on the list it looks (to me) as
> if we in the wg have a more mature view on this task.
> Note the wg already has a milestone to which this work
> can be associated. I.e., "Submit RTCP extension requirements
> for use with congestion control algorithms to AVTCORE (if needed)".
> Please respond to this email and give your view:
>
> Shall we NOW give the usage of a common feedback message
> for a sender side only CC a try ?
> [Yes I want to be part of this - OR -  No I don't want to be part of this]
naturally yes :-).
>
> Assuming Yes. How shall we collect the requirements ?
> Possible options (I can think of):
>
> * have new updates of the CCs alg candidates (incl. SBD, coupled CC as
> applicable)
>     come soon with a good specification of the requested
> * have the same information instead go into a (potentially temporary?)
>      Appendix of draft-perkins-rmcat-rtp-cc-feedback-01.txt or new draft ?
> * others - email ?
email discussions- its easy to just send what is already there in the CC 
docs in a email and then discuss.
> draft-perkins-rmcat-rtp-cc-feedback-01.txt or new draft
My understanding is, this doc describes what can be done and cannot be 
done with current RTCP rate interval - like it says per packet feedback 
may be far fetched while per frame feedback likely possible. Hence I 
think the combination of email discussion and this document should give 
us fair enough information to decide.
>
> BR,
> Karen, on behalf of the chairs
>
>> -----Original Message-----
>> From: Karen Elisabeth Egede Nielsen [mailto:[email-masked]]
>> Sent: 3. november 2015 01:29
>> To: [email-masked]' <[email-masked]>
>> Subject: Generic RTCP feedback message
>>
>> Hi,
>>
>> Following Stefan’s presentation in the RMCAT session yesterday there was
>> agreement at the mike that we in the RMCAT wg should try to give the
> usage
>> of a generic common feedback message a try.
>>
>> It seems a prerequisite for this that the receiver (sender of the
> feedback
>> message) is (in principle) unaware of the particular CC algorithm that
> the
>> sender is using, but will generate a *to be defined* set of  feedback
>> information in a *to be defined* form that will fulfil the requirements
> of all
>> RMCAT CC algorithms.
>>
>> In order to start on this task we hereby solicit for the people working
> with CC
>> algorithms to respond to this email with information on the requirements
>> that they have to such a generic feedback mechanism.
>>
>> In addition _or alternatively_   please (all) provide feedback on
>> * how you think we should proceed with this task, e.g., start a new
> draft to
>> collect this information (eventually to proceed in an ART wg)
>> * concerns with this approach
>>
>> We will try to collect the information provided and have a short follow
> up in
>> Fridays RMCAT meeting.
>>
>> BR, Mirja/Karen
>>
>>
>>
>>
>>
>>
>

-- 
Zahed

Ericsson AB