Subject: [rmcat] I-D Action: draft-ietf-rmcat-video-traffic-model-02.txt

From: [email-masked]
Date: Sun, 08 Jan 2017 20:04:45 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the RTP Media Congestion Avoidance Techniques of the IETF.

        Title           : Modeling Video Traffic Sources for RMCAT Evaluations
        Authors         : Xiaoqing Zhu
                          Sergio Mena de la Cruz
                          Zaheduzzaman Sarker
	Filename        : draft-ietf-rmcat-video-traffic-model-02.txt
	Pages           : 16
	Date            : 2017-01-08

Abstract:
   This document describes two reference video traffic source models for
   evaluating RMCAT candidate algorithms.  The first model statistically
   characterizes the behavior of a live video encoder in response to
   changing requests on target video rate.  The second model is trace-
   driven, and emulates the encoder output by scaling the pre-encoded
   video frame sizes from a widely used video test sequence.  Both
   models are designed to strike a balance between simplicity,
   repeatability, and authenticity in modeling the interactions between
   a video traffic source and the congestion control module.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rmcat-video-traffic-model/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-rmcat-video-traffic-model-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rmcat-video-traffic-model-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Mon, 9 Jan 2017 04:31:00 +0000

Hi, 

This version has been updated based on a new set of encoder output frame traces collected using the modified firefox browser. The traces are driven by two long (>5min) HD test video sequences and cycling through various target rates for sake of observing codec transient behavior.  

The changes to the draft are as follows (mainly in Section 5 and Section 7): 
 
* For the statistical model, added a new parameter SIGMA_t to model the fluctuations in frame intervals as we have observed from recently collected traces; 

* For the transient behavior, revised the parameter in the statistical model to K_B to directly model the burst frame size.  Since we have not observed a constant ratio between burst and reference frame size in the new traces;

* Removed the parameter DELTA (corresponding to uniform distribution of output frame sizes) since there has not been much evidence for uniformly distributed frame sizes; 

* In Section 7, when describing the hybrid model, also mentioned that the frame interval distribution in the statistical model can be used along with frame size from traces to drive the steady-state behavior. 

We are currently in the process of collecting corresponding steady-state traces from the same video sources. Our plan is to present on the dataset (and potentially update the draft again for the steady-state model parameters) in the upcoming IETF-98 meeting.

Thanks,
Xiaoqing

P.S.  Thanks much to Randell from Mozilla for help with modifying the firefox browser. 
   
________________________________________
From: rmcat <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Sunday, January 8, 2017 10:04 PM
To: [email-masked]
Cc: [email-masked]
Subject: [rmcat] I-D Action: draft-ietf-rmcat-video-traffic-model-02.txt

Abstract: