Subject: [rmcat] Request for comment/input for draft-zhu-rmcat-framework-00

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Mon, 9 Jan 2017 16:53:51 +0000

Hi everyone,

This draft has just expired and Zahed and I do plan to revive it soon. Currently we have on our "edit-to-address" list only some questions raised by Varun from IETF-96 (Berlin) regarding RTP taxonomy.  Varun has graciously agreed to provide some specific comments as follow-up, so we are waiting for those (thanks ahead Varun).

In the meantime, I would like to poll the mailing list to collect further review comments on this draft.  Please let us know what other issues you'd like us to address.

https://tools.ietf.org/html/draft-zhu-rmcat-framework-00?

Thanks,

Xiaoqing

---

From: Roni Even <[email-masked]>
Date: Thu, 19 Jan 2017 09:57:39 +0000

Hi,

I read the document and have a question about the multiple streams case.  Figure 2 adds the shared states module.  The text say
“The Rate Controller divides up the aggregate estimated bandwidth (1) from the Network Congestion Controller amongst sub-streams based on their relative priority levels, Shared States, as well as current occupancy level of the Transmission Queue.”
I am not sure what the shared state is but definitely in order to divide the bandwidth there is a need to know the required bw for each of the video streams (as a number or information about the encoding parameters like codec, resolution,…) this is a resource management algorithm that is needed here.

Roni Even

From: rmcat [mailto:[email-masked]] On Behalf Of Xiaoqing Zhu (xiaoqzhu)
Sent: יום ב 09 ינואר 2017 18:54
To: [email-masked]
Cc: Varun Singh
Subject: [rmcat] Request for comment/input for draft-zhu-rmcat-framework-00

Hi everyone,

https://tools.ietf.org/html/draft-zhu-rmcat-framework-00​

Thanks,

Xiaoqing

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Tue, 24 Jan 2017 04:37:50 +0000

Hi Roni,

Thanks for reading the draft and providing your input.   You are right that to a resource management algorithm is needed to decide which flow get how much portion of the aggregate BW calculated by the network congestion controller.  Currently, my intention is for the "Rate Controller" to host that algorithm.  Will add some text to clarify on this part.

An example of the shared states would be the set of "flow state information" mentioned in the coupled-cc draft (https://tools.ietf.org/html/draft-ietf-rmcat-coupled-cc-05), such as priority, current flow rate, etc.  I'll add a reference to the coupled-cc draft to help make this concept more concrete.

Best,

Xiaoqing

________________________________
From: Roni Even <[email-masked]>
Sent: Thursday, January 19, 2017 3:57 AM
To: Xiaoqing Zhu (xiaoqzhu); [email-masked]
Cc: Varun Singh
Subject: RE: Request for comment/input for draft-zhu-rmcat-framework-00

Hi,

I read the document and have a question about the multiple streams case.  Figure 2 adds the shared states module.  The text say
"The Rate Controller divides up the aggregate estimated bandwidth (1) from the Network Congestion Controller amongst sub-streams based on their relative priority levels, Shared States, as well as current occupancy level of the Transmission Queue."
I am not sure what the shared state is but definitely in order to divide the bandwidth there is a need to know the required bw for each of the video streams (as a number or information about the encoding parameters like codec, resolution,...) this is a resource management algorithm that is needed here.

Roni Even

From: rmcat [mailto:[email-masked]] On Behalf Of Xiaoqing Zhu (xiaoqzhu)
Sent: ??? ? 09 ????? 2017 18:54
To: [email-masked]
Cc: Varun Singh
Subject: [rmcat] Request for comment/input for draft-zhu-rmcat-framework-00

Hi everyone,

Thanks,

Xiaoqing

---

From: Ingemar Johansson S <[email-masked]>
Date: Wed, 25 Jan 2017 06:00:02 +0000

Hi
Another example of the resource management is the configurable flow prioritization embedded in the packet scheduling in SCReAM. See https://tools.ietf.org/html/draft-ietf-rmcat-scream-cc-07#page-32

Regards
/Ingemar

From: Xiaoqing Zhu (xiaoqzhu) [mailto:[email-masked]]
Sent: den 24 januari 2017 05:38
To: Roni Even <[email-masked]>; [email-masked]
Cc: Varun Singh <[email-masked]>
Subject: Re: [rmcat] Request for comment/input for draft-zhu-rmcat-framework-00

Hi Roni,

Best,

Xiaoqing

________________________________
From: Roni Even <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, January 19, 2017 3:57 AM
To: Xiaoqing Zhu (xiaoqzhu); [email-masked]<mailto:[email-masked]>
Cc: Varun Singh
Subject: RE: Request for comment/input for draft-zhu-rmcat-framework-00

Hi,

Roni Even

From: rmcat [mailto:[email-masked]] On Behalf Of Xiaoqing Zhu (xiaoqzhu)
Sent: יום ב 09 ינואר 2017 18:54
To: [email-masked]<mailto:[email-masked]>
Cc: Varun Singh
Subject: [rmcat] Request for comment/input for draft-zhu-rmcat-framework-00

Hi everyone,

Thanks,

Xiaoqing

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Wed, 25 Jan 2017 16:38:07 +0000

Hi Ingemar,

Thanks for providing this example.  Will refer to it in the next version of the draft.  Just wondering, if you can help to identify what "shared states" are in the case of SCReAM?  Or does the concept of "shared state" apply at all?

Best,

Xiaoqing

________________________________
From: Ingemar Johansson S <[email-masked]>
Sent: Wednesday, January 25, 2017 12:00 AM
To: Xiaoqing Zhu (xiaoqzhu); Roni Even; [email-masked]
Cc: Varun Singh
Subject: RE: [rmcat] Request for comment/input for draft-zhu-rmcat-framework-00

Hi

Regards
/Ingemar

Hi Roni,

Best,

Xiaoqing

Hi,

Roni Even

Hi everyone,

Thanks,

Xiaoqing

---

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 26 Jan 2017 14:33:05 +0000

Hi

The resource management concept with SCReAM assumes that all the outgoing RTP streams use the same congestion controller (= the same UDP port).
The RTP streams are registered with the SCReAM controller, besides a min and max target bitrate, also a scheduling priority in the range ]0.0 1.0] is given as a parameter.
The shared state in this case is the SCReAM network congestion controller state, i.e. the congestion window.

/Ingemar

From: Xiaoqing Zhu (xiaoqzhu) [mailto:[email-masked]]
Sent: den 25 januari 2017 17:38
To: Ingemar Johansson S <[email-masked]>; Roni Even <[email-masked]>; [email-masked]
Cc: Varun Singh <[email-masked]>
Subject: Re: [rmcat] Request for comment/input for draft-zhu-rmcat-framework-00

Hi Ingemar,

Best,

Xiaoqing

________________________________
From: Ingemar Johansson S <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, January 25, 2017 12:00 AM
To: Xiaoqing Zhu (xiaoqzhu); Roni Even; [email-masked]<mailto:[email-masked]>
Cc: Varun Singh
Subject: RE: [rmcat] Request for comment/input for draft-zhu-rmcat-framework-00

Hi

Regards
/Ingemar

From: Xiaoqing Zhu (xiaoqzhu) [mailto:[email-masked]]
Sent: den 24 januari 2017 05:38
To: Roni Even <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Varun Singh <[email-masked]<mailto:[email-masked]>>
Subject: Re: [rmcat] Request for comment/input for draft-zhu-rmcat-framework-00

Hi Roni,

Best,

Xiaoqing

Hi,

Roni Even

Hi everyone,

Thanks,

Xiaoqing

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Thu, 26 Jan 2017 16:00:50 +0000

​Thanks, Ingemar.   This is helpful.

Best,

Xiaoqing

Sent: Thursday, January 26, 2017 8:33 AM

Hi

/Ingemar

Hi Ingemar,

Best,

Xiaoqing

Hi

Regards
/Ingemar

Hi Roni,

Best,

Xiaoqing

Hi,

Roni Even

Hi everyone,

Thanks,

Xiaoqing