Subject: [rmcat] I-D Action: draft-ietf-rmcat-nada-12.txt

From: [email-masked]
Date: Sat, 24 Aug 2019 21:08:52 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the RTP Media Congestion Avoidance Techniques WG of the IETF.

        Title           : NADA: A Unified Congestion Control Scheme for Real-Time Media
        Authors         : Xiaoqing Zhu
                          Rong Pan *
                          Michael A. Ramalho
                          Sergio Mena de la Cruz
	Filename        : draft-ietf-rmcat-nada-12.txt
	Pages           : 29
	Date            : 2019-08-24

Abstract:
   This document describes NADA (network-assisted dynamic adaptation), a
   novel congestion control scheme for interactive real-time media
   applications, such as video conferencing.  In the proposed scheme,
   the sender regulates its sending rate based on either implicit or
   explicit congestion signaling, in a unified approach.  The scheme can
   benefit from explicit congestion notification (ECN) markings from
   network nodes.  It also maintains consistent sender behavior in the
   absence of such markings, by reacting to queuing delays and packet
   losses instead.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rmcat-nada/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rmcat-nada-12
https://datatracker.ietf.org/doc/html/draft-ietf-rmcat-nada-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rmcat-nada-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Xiaoqing Zhu (xiaoqzhu)" <[email-masked]>
Date: Sun, 25 Aug 2019 04:17:39 +0000

Hi, 

This updated draft addresses Genart and Secdir last call review comments. We also took the opportunity to revise and fix a few minor description errors in the draft. The following content changes are made accordingly: 

* Sec. 1 (Introduction): to highlight key requirements on congestion control schemes from the cc-requirements draft;
* Sec. 4.2 (Receiver-side Algorithm) and Sec. 6.3 (Impact of Parameters):  added brief discussion on the potential risk of delay warping and the need to carefully tune the parameter QTH;
* Sec. 4.3 (Sender-side Algorithm): fixed the pseudo-code to indicate that rate clipping always occurs;
* Sec. 5.1.1 (Estimation of one-way delay and queuing delay): fixed the description of how queuing delay is estimated, now correctly stating that the minimum filtering is applied to the estimation of queuing delay (d_queue), not d_base. 
* Sec. 5.3 (Feedback Message Requirements) and Sec. 6.4 (Sender-based vs. receiver-based calculation): referenced the cc-feedback-message draft; also discussed the alternative implementation where receiver-side calculation can be moved to the sender if per-packet information is provided (as defined in the cc-feedback-message draft);
* Sec. 7 (Reference Implementation): added reference to recent presentations of evaluations of NADA implementation within Mozilla browser; also added discussions on main observations from these evaluation results; 
* Sec. 10 (Security Considerations): incorporated suggestions from Secdir reviews to point to cc-feedback-message draft on additional security concerns regarding misleading information from receivers; broke up the discussions into two paragraphs corresponding to two different type of risks;  

In addition, we have updated the author list and added a Contributors section to address review concerns regarding number of front page authors. 

Thanks,
Xiaoqing

On 8/24/19, 11:09 PM, "rmcat on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    
    Abstract: