Subject: RE: [Rmt] small group replication service, application-level multicast etc.

From: "Bauer, Claus" <[email-masked]>
Date: Wed, 19 Mar 2003 11:40:24 -0800

Do you have a pointer to a description of the Swarmcast ?

-----Original Message-----
From:	Justin Chapweske [mailto:[email-masked]]
Sent:	Wed 3/19/2003 10:44 AM
To:	Rick Boivie
Cc:	Sally Floyd; [email-masked]
Subject:	Re: [Rmt] small group replication service, application-level multicast etc.
Actually, the Swarmcast system that we developed in late 1999 utilized 
Forward Error Correction combined with peer-to-peer (end-system) 
multicast to overcome the first-mile bottleneck in systems like this.

I'd be happy to discuss this approach off-line with anyone that is 
interested.

Thanks,

-Justin

> 
> This problem of maintaining multicast state can be minimized in an
> end-system multicast scheme if the multicast state is kept only in the
> end-systems of the meeting participants.  But this approach doesn't seem
> appropriate if we have limited bandwidth in the first mile (see problem
> statement above).
> 

-- 
Justin Chapweske, Onion Networks
http://onionnetworks.com/

_______________________________________________
Rmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rmt

This message (including any attachments) may contain confidential information intended for a specific individual and purpose. If you are not the intended recipient, delete this message. If you are not the intended recipient, disclosing, copying, distributing, or taking any action based on this message is strictly prohibited.
_______________________________________________
Rmt mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rmt

---

From: Rick Boivie <[email-masked]>
Date: Thu, 20 Mar 2003 18:59:34 -0500

Justin>So, while this approach obviously wouldn't work for a conference
call
Justin>VoIP application where latency is very critical, it might work well
for
Justin>a near-live news or sports broadcast where latency can be traded off
for
Justin>better performance and reliability.
Justin>

Yuji>>   For me, this looks the example of "There is no one-fits-all
Yuji>>   multicast transport protocol."

Justin>
Justin>So true.

Agreed.