Subject: [rohc] Partial_State_ID calculation at compressor End

From: [email-masked]
Date: Wed, 12 May 2004 10:19:24 +0530

RFC 3321 says 

"The compressor must only use states   that are established at the remote 
decompressor, otherwise a decompression failure will occur.  For this 
reason,  acknowledgements are necessary, at least for unreliable 
transport."

My case is as follows :

1. EP1 sends compressed INVITE message with decompression BYTECODE to EP2.
2. EP2 saves state EP2_S1.
2. EP2 sends compressed 100 Trying  message with decompression  BYTECODE 
to EP1.
3. EP1 saves state EP1_S1.
4. Now when EP2 wants to send 180 ringing and it has not go the ack for 
state EP1_S1.

My question is in case of TCP, can the EP2 send the partial_state_Id 
instead of uploading BYTECODE again when it sends 180 Ringing.

If so how the partial_state_id will be calculated at EP2 compressor End.

---

From: suman <[email-masked]>
Date: Wed, 12 May 2004 12:22:10 +0530

In your example, the 180 ringing will always carry the bytecode in case of both UDP and TCP.
This is because the other endpoint could be stateless with sms = 0. 
Without receiving feedback from the peer endpoint, it cannot be assumed that the states are saved.

thanks
suman
  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] 
  Sent: Wednesday, May 12, 2004 10:19 AM
  Subject: [rohc] Partial_State_ID calculation at compressor End

  RFC 3321 says 

  "The compressor must only use states   that are established at the remote decompressor, otherwise a decompression failure will occur.  For this reason,  acknowledgements are necessary, at least for unreliable transport." 

  My case is as follows : 

  1. EP1 sends compressed INVITE message with decompression BYTECODE to EP2. 
  2. EP2 saves state EP2_S1. 
  2. EP2 sends compressed 100 Trying  message with decompression  BYTECODE to EP1. 
  3. EP1 saves state EP1_S1. 
  4. Now when EP2 wants to send 180 ringing and it has not go the ack for state EP1_S1. 

  My question is in case of TCP, can the EP2 send the partial_state_Id instead of uploading BYTECODE again when it sends 180 Ringing.