Subject: [rohc] ROHC channel reordering

From: Ramin <[email-masked]>
Date: Sun, 02 May 2004 13:00:28 -0700

Given that ROHC header includes a sequence number, why is it required 
that the channel between the compressor and decompressor preserve the 
ordering?  Same question about duplication.  Shouldn't The decompressor 
be able to re-order compressed packets based on the ROHC sequence number?

Thank you,

-Ramin

RFC 3095 says:
"Reordering
The channel between compressor and decompressor is required to
maintain packet ordering, i.e., the decompressor must receive
packets in the same order as the compressor sent them."

"Duplication
The channel between compressor and decompressor is required to not
duplicate packets. "

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Mon, 3 May 2004 08:15:24 +0200

The SN in compressed packets is very small, only a few bits. Considering that packets can be lossed, it is a non-trivial task to put packets back in order. Further, to be able to reorder packets, a decompressor would have to buffer in case of "early arrival", which would add delay and maybe the missing packet(s) will never arrive, due to losses.

By making the in-order assumption, we were able to make the scheme more efficient and robust to losses (which were our main requirements).

/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Ramin
> Sent: den 2 maj 2004 22:00
> To: [email-masked]
> Subject: [rohc] ROHC channel reordering
> 
> 
>