Subject: [rohc] Limiting the number of IP header in IP-only profile

From: Kristofer Sandlund <[email-masked]>
Date: Mon, 10 May 2004 16:54:12 +0200

Hi all!

I know I'm a bit late here since the IP profile has passed last call, but 
there's one feature that I think could be quite useful to add.

Section 3.1 in ip-only-05.txt says:
    Instead, the static chain is terminated if the "Next Header /
    Protocol" field of a static IP header part indicates anything but IP
    (IPinIP or IPv6).

It would be useful for the compressor to decide to only compress a few of the IP 
headers instead of having to compress "all or none".

To do this, the compressor would somehow have to indicate in the static chain 
that an IP header is the last compressed IP header, even if the protocol field 
indicates the prescence of more IP headers.

Since only the IPv4 header has "reserved bits" (the 4 bits right after version), 
there are no free bits that work for both IPv4 and IPv4. But, since we're 
sending all 4 of the IP version bits, while we anyway only handle them to be "4" 
and "6", the IP only could be extended to work with some extra bit patterns.

The only of these four bits that actually needs to be read from the static chain 
is the third one (4=0100 and 6=0110) so any of the other three bits could be 
used to mark the end of the static chain. So, let's say that we use the top bit 
to indicate the end of the static chain, the version field would be:

0100= IPv4 non-final header
0110= IPv6 non-final header
1100= IPv4 final header (end of static chain)
1110= IPv6 final header (end of static chain).

Obviously, these changes would only need to apply to the IP profile since that 
is the only one that can terminate in an IP header, so this would not have any 
impact on any other profiles. If it can be added to the current IP-only profile 
that would be great but otherwise it might be something for the next revision of 
the profile.

Rgds,
	Kristofer Sandlund, Effnet AB

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Tue, 11 May 2004 10:50:53 +0200

Kristofer,

I understand your concern and agree with your point. I also find
your proposal reasonable. The question is, what should we do at
this point? We could argue for making this change to the IP
profile before publication, as it is a new problem that is
unique for the IP profile, and it would be bad to not have
that resolved. I am not sure this is a sufficiently significant
problem in practice, but it might be tricky to implement it
without the ability to limit the compressed chain length.

So, while we are anyway waiting for the IANA action, let's figure
out what text should had been in the document. If we can agree on
that, we can consider whether we should bother the AD's with it
at this point.

/L-E

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Kristofer Sandlund
> Sent: den 10 maj 2004 16:54
> To: [email-masked]
> Subject: [rohc] Limiting the number of IP header in IP-only profile
> 
> 
> Hi all!
>

---

From: "Ghyslain Pelletier (LU/EAB)" <[email-masked]>
Date: Tue, 11 May 2004 15:49:07 +0200

NEW (part of 3.2):
   As explained above, the static chain within IR packets can be of
   arbitrary length, and the chain is terminated by the presence of a
   non-IP header (not IPinIP nor IPv6). Alternatively, the chain may be
   explicitly terminated with a special IP version number, as described
   in section 3.1. The dynamic chain is structured analogously.

[Ghyslain] s/with a special IP version number/with a special code value in the IP version field/  ?