Subject: RE: [rohc] Use of UDVM registers 6 to 9

From: "Richard Price" <[email-masked]>
Date: Thu, 20 May 2004 17:27:55 +0100

Hi,

The first 32 bytes are only set at UDVM startup; there is no
special significance to this memory area afterwards.  This
means that the UDVM bytecode is free to use these locations
for any other purpose a memory location might be used for; it
just has to be aware they are not necessarily initialized to zero.

Regards,

Richard

>From: suman <[email-masked]>
>To: [email-masked]
>CC: "Lajos Zaccomer (IJ/ETH)" <[email-masked]>
>Subject: [rohc] Use of UDVM registers 6 to 9
>Date: Thu, 20 May 2004 18:47:20 +0530
>
>Section 7.2 of rfc 3320 describes the format of the first 32 bytes in UDVM
>memory.
>
>"  Addresses 6 to 9 are initialized to the length of the partial state
>    identifier, followed by the state_length from the retrieved state
>    item. "
>
>Does it mean that the state_length will be updated with the state_length of
>the
>state item for which a STATE-ACCESS/STATE-CREATE instruction is executed ?
>
>Just rephrasing the above statement with an example..
>
>if a STATE-CREATE instruction is executed for a state-item whose
>state-length is 300 bytes,
>will the value of registers, 8-9 in UDVM be loaded with 300. Will this be
>done by state handler ??
>
>Please confirm,
>
>thanks
>suman
>
>
>_______________________________________________
>Rohc mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/rohc

_________________________________________________________________
Want to block unwanted pop-ups? Download the free MSN Toolbar now!  
http://toolbar.msn.co.uk/

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: sasidhar <[email-masked]>
Date: Fri, 21 May 2004 10:51:27 +0530

Hi,
    If these first 32 bytes of the UDVM are set only at the startup, do they correspond to the bytecode which will be loaded at the UDVM startup? And then what is the use of the partial_state_ID_length and state_length. 
    Please clarify this.

with regards,
Sasidhar