Subject: [rohc] Shared compression

From: sasidhar <[email-masked]>
Date: Mon, 24 May 2004 10:53:02 +0530

Hi,
    The following statement is from RFC 3321. 

"Note that new shared state items must not be created unless the compressor has made enough state memory available (as decompression failure could occur if the shared state pushed existing state out of the state memory buffer)."

Does it mean that an endpoint cannot even delete an existing shared state which has already been used once by the peer endpoint?

Please clarify this.

with regards,
Sasidhar

---

From: "Lajos Zaccomer (IJ/ETH)" <[email-masked]>
Date: Mon, 24 May 2004 08:13:16 +0200

Hi Sasidhar,
 
No, it does not. The statement below means, the compressor may save a shared state only if there is enough memory to store it, without deleting any other (shared or regular) states in the state memory. Thus, you are right only when there is not enough free state memory to save a new shared state. The other compressor is responsible for deleting the useless states.
 
BR/Zacco

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of sasidhar
Sent: Monday, May 24, 2004 7:23 AM
To: [email-masked]
Subject: [rohc] Shared compression

Hi,

 
Please clarify this.
 
with regards,
Sasidhar