Subject: RE: IP-ID clarification (was: [rohc] The discussion on slope(s) ( redu x))

From: "Surtees, Abigail" <[email-masked]>
Date: Fri, 10 Dec 2004 11:30:42 -0000

Agreed.  Is it also worth explicitly stating that there is no way to change
its SN offset slope? 

(The alternating IP-ID example was an example to show that the concept slope
could be useful rather than anything else.  I.E. I agree that 'For IP-ID
(offset), there is clearly no learned slope in 3095.')

Best regards,

Abbie

> -----Original Message-----
> From: Lars-Erik Jonsson (LU/EAB) 
> [mailto:[email-masked]] 
> Sent: Friday, December 10, 2004 11:22 AM
> To: 'Carsten Bormann'
> Cc: West, Mark; Surtees, Abigail; [email-masked]
> Subject: IP-ID clarification (was: [rohc] The discussion on 
> slope(s) (redu x))
> 
> 
> To capture this conclusion and avoid further confusion on IP-ID offset
> encoding, I propose to add the following at the end of section 8.2 of
> the implementer's guide:
> 
>    "When RND=0 but no IP-ID bits are sent in the compressed 
> header, the
>     SN offset for IP-ID stays unchanged, meaning that Offset_m equals
>     Offset_ref, as described in Section 4.5.5. This is 
> further expressed
>     in a slightly different way (with the same meaning) in 
> Section 5.7,
>     where it is said that "default-slope(IP-ID offset) = 0", 
> meaning that
>     if no bits are sent for IP-ID, its SN offset slope defaults to 0."
> 
> /L-E
> 
> 
> > > I think there is nothing missing when it comes to IP-ID 
> and slopes,
> > > more than to clarify the meaning of default_slope on page 
> 75, which
> > > simply means exactly what is said on the second and third line of
> > > page 35 (the additional mentioning on page 75 is thus just 
> > confusing).
> > 
> > Yes.
> > 
> > Gruesse, Carsten
>  
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Fri, 10 Dec 2004 13:10:03 +0100

> Agreed.  Is it also worth explicitly stating that there is no 
> way to change its SN offset slope?

Since there is nothing in 3095 that in any way says anything
that could be interpreted as if the offset slope could be
changed, I thought that explicitly stating it can not be 
changed would not be needed. Spelling out what is already in
3095, i.e. that "if no bits are sent for IP-ID, its SN offset
slope defaults to 0", should make that clear anyway, right?

/L-E