Subject: RE: [rohc] The discussion on slope(s) (redux)

From: "Lars-Erik Jonsson (LU/EAB)" <[email-masked]>
Date: Thu, 9 Dec 2004 15:26:31 +0100

> > It seems like 1) and 2) are "clear" from 3095, while what is really
> > missing is a defined decompression (and thus compression)
> > logic for 3).
> 
> Well, at least 3095 says that Tsc is 1 in the context, so 
> SCALED is the more likely interpretation, I'd say.

Yes, to make the default_slope=1 wording on page 75 correct,
that should be the interpretation.

> > The "default slope" value would be an important
> > part of that logic, and I guess most implementers have actually
> > used that value for the simple function
> > TS_SCALED=(SN-SN_OLD)*default_slope + TS_SCALED(SN_OLD)
> > for decompression of TS_SCALED when no TS bits are sent.
> >
> > Q: Would default_slope be used when decompressing based
> >    on TS bits actually sent?
> 
> No.  4.5.3 is quite clear on what to do.

Clear to the extent that it does not define the use of slope,
but 4.5.3 does not really care if bits are sent or not, that
is part of the compression step, after scaling. That 4.5.3
does not say anything does not make 3095 clear on that point.
However, I just wanted to ensure we agree the whole
slope/default_slope thing is only about "inferred decompression".

> > Q: Can default_slope be anything but 1?
> 
> (If Tsc is 1:) No.  See 5.7.
> 
> > Q: Can TS bits ever be omitted when sent unscaled?
> 
> Yes, with an ext3 if Tsc is 0, R-TS is 0, and no TS bits are in the 
> base (i.e., UOR-2-ID) header carrying the ext3.

True, you're right there is a case. This means we will have to
define "inferred decompression" both for scaled and unscaled TS.

> But the logic is clear: Look at Tsc, if it is 0, the default-slope is 
> TS-STRIDE, if it is 1, the default-slope is 1.

Yes, the "only" thing that is missing is an explanation of what 
default-slope is and how to use it for "inferred decompression".
A rather important tiny detail. Also "default slope" can be a
confusing name, as there is no way to ever change it.

/L-E

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 9 Dec 2004 16:06:14 +0100

> A rather important tiny detail.

Yes.

> Also "default slope" can be a

Well, it's the slope you use to "default" TS in case it's not present 
in the header.

Gruesse, Carsten