Subject: [rohc] More on USD upload

From: "Jan Christoffersson (LU/EAB)" <[email-masked]>
Date: Fri, 9 Sep 2005 14:46:09 +0200

Hi,
to illustrate the need for an out-of -band USD upload message consider the following example of the inefficiencies involved in uploading a USD state.

Suppose we have a 2K DMS and that the size of bytecode+compressed message is 500 bytes (assume this size is static for simplicity). This leaves 1500 bytes that can be used for the USD. The question is how do we upload a 1500 bytes USD? It is only possible to upload 750 bytes with the current message since we need two copies of the uploaded state (one appended to the message and one for the circular buffer).

If we want to continue to upload the rest of the USD with the next message, then only 375 bytes can be uploaded since we now have 2000-500-750=750 bytes available for the two copies of the uploaded part. Continuing in this way, we can upload 187, 93, 46 and so on bytes with consecutive messages. Of course it will not take forever but the example illustrates the inefficiencies involved.

What I think could be important benefits with an out-of-band upload mechanism is that it could be made independent of the DMS size. It should also be made independent of the link MTU (which typically limits the SIP messages size to 1300 bytes). Hence, it should be possible to upload a USD in one message, before the time critical signalling.

BR
Jan

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 9 Sep 2005 14:52:15 +0200

So -- how big do you think a USD should be?

Gruesse, Carsten