Subject: RE: [rohc] Question about SMS size zero

From: "Surtees, Abigail" <[email-masked]>
Date: Fri, 23 Sep 2005 15:15:19 +0100

Hi Carrie,
> 
> So, if I am decompressor, I got state creation request, if my
> SMS is zero, I should still put whatever data from the requested
> feedback item into my returned feedback item in the header
> of next SigComp message, and at the same time I should put
> the SigComp parameters including DMS, SMS, CPB in the same
> SigComp message?

Yes.  Unless it receives advertisements that say otherwise, a compressor
must assume the default values of SMS, DMS and CPB (either as defined in
RFC3320 or as specified by the application making use of SigComp (e.g.
as specified in 3GPP TS 24.229)).
> 
> If so, then every time the returned feedback item is received by
> SigComp, the SMS needs to be checked, if SMS is zero, then
> the state corresponding to the returned feedback item shall not
> be used for future compression, because the far decompression
> had been failed to create this state. Is my understanding correct?
> 
Whether or not the decompressor SMS is zero, the compressor needs to
know its value because it has to keep track of what state is present at
the decompressor.  So yes, your understanding is correct.

> Another question related to feedback is that, if the DMS size is not
> enough in decompression side, what should the decompressor
> return to compressor? If NACK is supported, what would be the
> proper error code; if NACK is not supported, can feedback
> handle this case?
> 
The error code will depend on how the decompressor fails e.g. 
if the uploaded bytecode will not fit into UDVM_memory_size (calculated
from DMS) then the error code would be BYTECODES_TOO_LARGE
Alternatively, if the bytecode fits but then when it runs it tries to
read/write to an address greater than UDVM_memory_size the error code
would be SEGFAULT.

If NACK is not supported, then the failed message is discarded and no
feedback stored nor any state requests made.  No information is returned
to the compressor.

It is up to the compressor (based on the information it has either the
default or from advertised parameters) to ensure that decompression can
successfully take place in the DMS available.

Best regards,

Abbie

> Thanks a lot,
> Carrie
> 
> -----Original Message-----
> From: Pekka Pessi [mailto:[email-masked]]
> Sent: Thursday, September 22, 2005 2:10 PM
> To: [email-masked]
> Cc: Rohc
> Subject: Re: [rohc] Question about SMS size zero
> 
> 
> Carrie Zhang <[email-masked]> writes:
> >Reading Implementer's guide for sigcomp, section 9 as below:
> >=============================
> >9.  Feedback when SMS is zero
> 
> >   If an endpoint receives a request for feedback then it 
> should return
> >   the feedback even if its SMS is zero.  The storage overhead of the
> >   requested feedback is NOT part of the SMS.
> >=============================
> >I got confused. I agree that "storage overhead of the 
> requested feedback
> >is NOT part of the SMS".
> 
> >The first question is : when SMS is zero, the sate creation 
> request will
> >fail. If the state creation fails, will UDVM still forward 
> the feedback
> >to State Handler?
> 
> It should. In general case, the compressor can not know the
> contents of the state item created at remote end. That is because
> a single state item is truncated at state memory size - 64 bytes.
> SMS zero is just a special case.
> 
> >The 2nd question is, if the feedback is returned to far 
> compressor, in
> >case of dynamic compression, the far compressor will take 
> this returned
> >feedback as an acknowledgement for the state it requested 
> the decompression
> >to create, but actually the state is NOT created in 
> decompressor due to
> >the zero SMS size. When compressor makes use of this kind of state,
> >decompression failure will occur, because "STATE_NOT_FOUND", right?
> 
> >I think when the SMS is zero, no feedback shall be returned.
> 
> The remote end should return parameters along with the feedback
> item. In your case, you should discard feedback if you are not
> returned parameters. Of course, you can assume you have 2048 bytes
> of SMS for SIP, for instance.
> 
> --Pekka
> 
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rohc
> 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Carrie Zhang" <[email-masked]>
Date: Fri, 23 Sep 2005 14:32:24 -0500

Abbie,

Thanks a lot.

Carrie

-----Original Message-----
From: Surtees, Abigail [mailto:[email-masked]]
Sent: Friday, September 23, 2005 9:15 AM
To: [email-masked]; Pekka Pessi
Cc: Rohc
Subject: RE: [rohc] Question about SMS size zero

Hi Carrie,

Best regards,

Abbie