Subject: Re: Re: [rohc] Re: FW: [tcpm] WG last-call of TCP header compression

From: "Lars-Erik Jonsson" <[email-masked]>
Date: Thu, 29 Sep 2005 07:54:32 +0200

> > I must admit to being slightly disheartened that
> > somebody with a formal language background is 
> > having difficulty with the notation - it really is
> > pretty simple considering what it's aiming to 
> > communicate.

> That's the issue. Simple can be awkward, and things
> even 'based on Prolog' are awkward to follow. 
> Elegant to write compact representations, and
> elegant to run (when actual code), but inaccessible
> as a way to communicate to another human, which is,
> after all, what I hope the primary goal of the FN
> would be.

Joe,

On this point I fully agree with you. As the WG knows,
I have never had any positive feelings about the FN,
but this has been a controversal issue and the very
rough consessus has been to keep the FN.

Getting this clear message from someone who has not
been part in the ROHC TCP work is really valuable, and
it tells me we have probably made a mistake when
fooling ourselfs into believing the FN will simplify
understanding of ROHC TCP. This is in some way an
editorial issue, as we would not change anything
technically, but it would imply a significant re-write
of the specification. At this point in time, I am not
sure we can get the engagement to do the work needed.

Therefore, I am not sure how to go on from here, i.e.
whether we should go on as planned and *ignore* this
feedback, or if we should address the comment and do
the rather significant work needed to get rid of the
FN.

/L-E 

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: Joe Touch <[email-masked]>
Date: Thu, 29 Sep 2005 03:48:35 -0700

> the rather significant work needed to get rid of the

That's your call; all I can do at this point is, as they say in American
baseball, is "call them as I see them". ;-)

Joe