Subject: [rohc] Constant RTP TS

From: "Klaus Warnke" <[email-masked]>
Date: Fri, 10 Feb 2006 17:02:10 +0100 (CET)

Hi RoHC'ler,

I am not sure, how I compress a constant RTP TS the right way.
There are serveral postings in the mailing list, but I can't find the right one.
(Yes, I read the implementers guide version 18, section 4)

Is it possible/wanted to transmit a constant RTP TS without sending RTP TS bits itself?
I mean the video example from http://www1.ietf.org/mail-archive/web/rohc/current/msg03084.html.

I think, the only way to transmit a constant RTP TS value without sending RTP bits is to set the
TS_STRIDE = 0.
If the compressor sends another packet than an extension 3, the context(Tsc) is always 1, so RTP
TS scaling takes place and the default-slope is 1 (Impl Guide 4.2). If the default-slope is 1, I
have always an delta_TS > 0 (delta_TS = delta_SN * default-slope). But a constant value has no
delta. The only way to get a constant RTP TS value according TS = TS_SCALED * TS_STRIDE +
TS_OFFSET is to set TS_STRIDE = 0, so the TS_SCALED value has no effect to the resulting TS and
TS_OFFSET is the constant TS value (but I can't find something about how to set TS_OFFSET in the
TS_STRIDE = 0 case).
So I assume, if the compressor detects an constant RTP TS, it sents an extension 3 with Tsc = 0
and TS_STRIDE = 0 with the unscaled, absolute TS value. And subsequent packets without TS bits are
resulting at decompressor site a constant TS.
Is that right?

Btw: In which szenario an Ext3 with Tsc=0, TS_STRIDE present, but without TS bits takes place?
     Does it mean, that the resulting delta_TS affects the unscaled TS instead of the scaled?

BR
-- 
Klaus Warnke
[email-masked]

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Lars-Erik Jonsson \(LU/EAB\)" <[email-masked]>
Date: Wed, 15 Feb 2006 13:41:58 +0100

> There are serveral postings in the mailing list, but I can't find the
> right one. (Yes, I read the implementers guide version 18, section 4)
> 
> Is it possible/wanted to transmit a constant RTP TS without sending
> RTP TS bits itself? I mean the video example from
> http://www1.ietf.org/mail-archive/web/rohc/current/msg03084.html.
> 
> I think, the only way to transmit a constant RTP TS value
> without sending RTP bits is to set the TS_STRIDE = 0.

Correct!

/L-E