Subject: [rohc] Saving bytecode as state

From: "Vishal Sudan" <[email-masked]>
Date: Wed, 8 Feb 2006 15:28:10 +0530

Hi,

The rfc3320 details two ways to save a bytecode as a state - by using a STATE-CREATE instruction and using state creation as part of END-MESSAGE. 

My question being  - does the the sigcomp standard entail that a remote endpoint save sent-over bytecode as state if such bytecode is sent as part of message the first time around ? And if not, would the future sigcomp releases have such a behaviour? 

Thanks,
Vishal

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Gustav E" <[email-masked]>
Date: Wed, 08 Feb 2006 12:02:33 +0100

Hi,

I'm not sure I understand your question completely.
During a session the first message is of the type containing UDVM code. When 
that code executes at an endopoint it typically stores its entire code as a 
state. Once a compressor is certain that the remote point successfully has 
established that state, it can send messages refering that state.
In other words, it is up to the compressor to send UDVM code that during 
first execution stores the code as state.

Hence in the ideal case the UDVM code must only be sent to an enpoint once.

Does that answer your question?

/Gustav

>From: "Vishal Sudan" <[email-masked]>
>To: <[email-masked]>
>Subject: [rohc] Saving bytecode as state
>Date: Wed, 8 Feb 2006 15:28:10 +0530
>
>Hi,
>
>The rfc3320 details two ways to save a bytecode as a state - by using a 
>STATE-CREATE instruction and using state creation as part of END-MESSAGE.
>
>My question being  - does the the sigcomp standard entail that a remote 
>endpoint save sent-over bytecode as state if such bytecode is sent as part 
>of message the first time around ? And if not, would the future sigcomp 
>releases have such a behaviour?
>
>Thanks,
>Vishal
>
>

_________________________________________________________________
Don't just search. Find. Check out the new MSN Search! 
http://search.msn.click-url.com/go/onm00200636ave/direct/01/