Subject: RE: [rohc] Saving bytecode as state

From: "Chintan Shah" <[email-masked]>
Date: Wed, 8 Feb 2006 16:49:10 +0530

To add more to Gustav, state is saved "if" it is instructed as a part of
END-MESSAGE.

Byte-code (or UDVM Instructions) are sent in first message. This
byte-code can be asked to stored as stated by providing additional
information within END-MESSAGE. After receiving acknowledgement of state
created on peer end, state can be directly referred for decompression
within next message.

BR,
Chintan Shah

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Gustav E
Sent: Wednesday, February 08, 2006 4:33 PM
To: [email-masked]; [email-masked]
Subject: RE: [rohc] Saving bytecode as state

Hi,

I'm not sure I understand your question completely.
During a session the first message is of the type containing UDVM code.
When 
that code executes at an endopoint it typically stores its entire code
as a 
state. Once a compressor is certain that the remote point successfully
has 
established that state, it can send messages refering that state.
In other words, it is up to the compressor to send UDVM code that during

first execution stores the code as state.

Hence in the ideal case the UDVM code must only be sent to an enpoint
once.

Does that answer your question?

/Gustav

>From: "Vishal Sudan" <[email-masked]>
>To: <[email-masked]>
>Subject: [rohc] Saving bytecode as state
>Date: Wed, 8 Feb 2006 15:28:10 +0530
>
>Hi,
>
>The rfc3320 details two ways to save a bytecode as a state - by using a

>STATE-CREATE instruction and using state creation as part of
END-MESSAGE.
>
>My question being  - does the the sigcomp standard entail that a remote

>endpoint save sent-over bytecode as state if such bytecode is sent as
part 
>of message the first time around ? And if not, would the future sigcomp

>releases have such a behaviour?
>
>Thanks,
>Vishal
>
>
>_______________________________________________
>Rohc mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/rohc

_________________________________________________________________
Don't just search. Find. Check out the new MSN Search! 
http://search.msn.click-url.com/go/onm00200636ave/direct/01/

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

#########################################################
THIS EMAIL MESSAGE IS FOR THE SOLE USE OF THE INTENDED
RECIPIENT(S) AND MAY CONTAIN CONFIDENTIAL AND PRIVILEGED
INFORMATION. ANY UNAUTHORIZED REVIEW, USE, DISCLOSURE OR
DISTRIBUTION IS PROHIBITED.BEFORE OPENING ANY ATTACHMENTS
PLEASE CHECK FOR VIRUSES AND DEFECTS.IF YOU ARE NOT THE
INTENDED RECIPIENT, PLEASE NOTIFY US IMMEDIATELY BY REPLY
E-MAIL AND DELETE THE ORIGINAL MESSAGE.
##########################################################

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Vishal Sudan" <[email-masked]>
Date: Wed, 8 Feb 2006 17:06:54 +0530

I meant to ask whether a remote endpoint is obligated to save the UDVM bytecode ( which may be typically sent only once - in first message) if the bytecode does not explicitly save itself ( or part of itself ) by using STATE-CREATE or END-MESSAGE.
In other words is it implicit that a bytecode sent as part of message may always be saved as a state?

Thanks,
Vishal

-----Original Message-----
From: Gustav E [mailto:[email-masked]]
Sent: Wednesday, February 08, 2006 4:33 PM
To: Vishal Sudan; [email-masked]
Subject: RE: [rohc] Saving bytecode as state

Hi,

I'm not sure I understand your question completely.
During a session the first message is of the type containing UDVM code. When 
that code executes at an endopoint it typically stores its entire code as a 
state. Once a compressor is certain that the remote point successfully has 
established that state, it can send messages refering that state.
In other words, it is up to the compressor to send UDVM code that during 
first execution stores the code as state.

Hence in the ideal case the UDVM code must only be sent to an enpoint once.

/Gustav

>STATE-CREATE instruction and using state creation as part of END-MESSAGE.
>
>endpoint save sent-over bytecode as state if such bytecode is sent as part

---

From: "West, Mark" <[email-masked]>
Date: Wed, 8 Feb 2006 12:47:51 -0000

Vishal,

There is no implicit behaviour to store bytecode.  And I don't see why or how there should be!  

If the state were implicitly stored then how do you determine:
- state priority;
- actual state start address (which may include 'registers' that aren't included in the bytecode);
- state length / end address (similar to previous point); and
- the state entry point (which may not be the same as the entry point on first execution).

(even ignoring the philosophical issue that the compressor is in control of the decompressor's behaviour.)

Therefore it only makes sense to try and store state when explicitly requested in bytecode (by the compressor).  Since the message in your example must contain bytecode, it is trivial for this bytecode to perform any state creations.

As pointed out by others, the ack mechanism can be used to establish secure reference; or you could support NACK and be optimistic about bytecode creation.

Cheers,

Mark.

-----Original Message-----
From: [email-masked] on behalf of Vishal Sudan
Sent: Wed 2/8/2006 11:36 AM
To: [email-masked]; Gustav E
Subject: RE: [rohc] Saving bytecode as state

Thanks,
Vishal

-----Original Message-----
From: Gustav E [mailto:[email-masked]]
Sent: Wednesday, February 08, 2006 4:33 PM
To: Vishal Sudan; [email-masked]
Subject: RE: [rohc] Saving bytecode as state

Hi,

/Gustav

---

From: "Vishal Sudan" <[email-masked]>
Date: Wed, 8 Feb 2006 18:57:43 +0530

This is my first post here - thanks for making it useful.I wrongly assumed to be an implicit state save there .
 
Thanks,
Vishal
 
 -----Original Message-----
From: West, Mark [mailto:[email-masked]]
Sent: Wednesday, February 08, 2006 6:18 PM
To: Vishal Sudan; [email-masked]; Gustav E
Subject: RE: [rohc] Saving bytecode as state

Vishal,

Cheers,

Mark.

-----Original Message-----
From: [email-masked] on behalf of Vishal Sudan
Sent: Wed 2/8/2006 11:36 AM
To: [email-masked]; Gustav E
Subject: RE: [rohc] Saving bytecode as state

Thanks,
Vishal

-----Original Message-----
From: Gustav E [ mailto:[email-masked]]
Sent: Wednesday, February 08, 2006 4:33 PM
To: Vishal Sudan; [email-masked]
Subject: RE: [rohc] Saving bytecode as state

Hi,

/Gustav