Subject: [rohc] sigcomp NACK - "return" error

From: Cristian CONSTANTIN <[email-masked]>
Date: Tue, 7 Feb 2006 18:03:11 +0100

hi!

is there any special NACK error for a call-less return?

thanks!
bye now!
cristian
-- 
 _          | There are many people who use UNIX or Linux  
(_'_        | who IMHO do not understand UNIX.
  (_'rist   |              --David Korn  
GPG public key at wwwkeys.de.pgp.net
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Surtees, Abigail" <[email-masked]>
Date: Wed, 8 Feb 2006 09:13:42 -0000

Hi Cristian,

Yes, I think it would be the STACK-UNDERFLOW instruction.

The error cases for CALL and RETURN are listed as being in section 8.3
of SigComp which in turn states that "Decompression failure occurs if
stack_fill is
   zero at the commencement of a popping operation.  POP and RETURN pop
   values from the stack."

If when RETURN is called there hasn't been a CALL instruction then
either
	stack_fill has been set using PUSH (or overwriting it) and you
jump to wherever the next value on the stack sends you, or
	stack_fill is zero in which case you get decompression failure
and the STACK-UNDERFLOW error code fits:

"9.   STACK_UNDERFLOW
        An attempt to pop a value off the UDVM stack was made with a
        stack_fill value of 0."

Best regards,

Abbie

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Cristian CONSTANTIN
> Sent: Tuesday, February 07, 2006 5:03 PM
> To: [email-masked]
> Subject: [rohc] sigcomp NACK - "return" error
> 
> 
> hi!
>