Subject: Re: [rohc] testing sigcomp code.

From: "Sarvamangala" <[email-masked]>
Date: Mon, 3 Apr 2006 13:06:39 +0530

RE: [rohc] testing sigcomp code.Hi

sorry couldn't participate in the discussion as we had a long weekend.

i will tell you what exactly is the problem

i am using zlib-1.1.3 library for compression and later formatting the compressed message to sigcomp message.
I have written the UDVM myself . 

if the input message is 

"INVITE sip:[email-masked] SIP/2.0\r\n Via: SIP/2.0/UDP pc33.atlanta.com;branch=z9hG4bKnashds8;comp=sigcomp\r\n Max-Forwards: 70\r\n To: Bob <sip:[email-masked]>\r\n From: Alice <sip:[email-masked]>;tag=1928301774 Call-ID: a84b4c76e66710 CSeq: 314159 INVITE Contact: <sip:[email-masked]> Content-Type: application/sdp Content-Length: 142"

Then the sigcomp message is 
f8 13 54 1f a2 6f 6 0 0 a4 0 0 f 86 7a a4 0 b6 e4 5 a4 0 0 3 0 4 0 5 0 6 0 7 0 8 0 9 0 a 1 b 1 d 1 f 1 11 2 13 2 17 2 1b 2 1f 3 23 3 2b 3 33 3 3b 4 a0 43 4 a0 53 4 a0 63 4 a0 73 5 a0 83 5 a0 a3 5 a0 c3 5 a0 e3 0 a1 2 0 1 0 2 0 3 0 4 1 5 1 7 2 9 2 d 3 11 3 19 4 21 4 31 5 a0 41 5 a0 61 6 a0 81 6 a0 c1 7 a1 1 7 a1 81 8 a2 1 8 a3 1 9 a4 1 9 a6 1 a a8 1 a ac 1 b b0 1 b b8 1 c 80 20 1 c 80 30 1 d 80 40 1 d 80 60 1 1d 3 22 9f b4 1e 20 a0 65 4 7 0 17 80 40 11 1 30 a0 bf 0 0 a0 c0 a0 c7 80 40 29 1 a1 90 a1 ff a0 90 17 50 80 40 11 9 a0 46 13 22 21 1 13 21 1 23 16 9f d1 8 10 4 12 50 4 22 1d 51 22 9f d7 6 12 51 1e 20 9f cf 1 5 0 1f 2f 8 10 4 12 50 4 26 1d 53 26 f6 6 14 53 e 20 63 14 54 52 23 22 50 52 16 9f 9e e 2a a4 86 f 38 4 bf c0 86 a1 40 6 d 38 bf c8 2c 23 2a a1 35 bf c0 86 a1 40 6 0 fb e5 7 df e5 e6 78 f9 6c a 95 fa 83 96 ca a0 da 20 29 3f c9 21 29 33 27 bf 22 53 f 58 cc c3 ca 7f 5e 2e 5 8c ea a0 20 d9 d8 58 2f b1 4 d8 49 28 49 4 a9 45 ab 6 f2 12 8b 33 52 8a 2d 50 2a d a0 31 a8 75 83 39 c8 64 50 f1 ee 94 9f a4 60 83 69 bf 1d 50 1a 52 1b 38 e6 80 c6 2e c0 4a 12 41 4c 7 24 9b ed c0 95 83 a1 a5 91 85 b1 81 a1 b9 b9 89 2 bc 72 49 b4 30 49 32 49 36 37 4b 35 33 33 7 76 dc 20 15 8a b1 a1 89 a1 a9 25 ac 2a 82 d7 3e 48 66 a3 7b cd 4e 1 b5 39 83 d6 7a 55 40 af 40 d 4d 8c 18 0 69 37 6c 20 

which is getting decompressed properly.

but if the sip message is

"MESSAGE sip:[email-masked] SIP/2.0\r\nFrom: ""\"k""\" <sip:[email-masked]>;tag=67730261211273137;comp=sigcomp\r\nTo: ""\"k""\" <sip:[email-masked]:7010>\r\nCall-ID: [email-masked]\r\nCSeq: 1 MESSAGE\r\nVia: SIP/2.0/UDP 172.16.182.196:7020;rport;branch=z9hG4bK1300070742443613620;comp=sigcomp\r\nMax-Forwards: 70\r\nAllow: INVITE,ACK,CANCEL,BYE,OPTIONS,SUBSCRIBE,NOTIFY,MESSAGE,INFO,REFER,PUBLISH\r\nContent-Length: 6\r\nContent-Type: text/plain" 

Then the sigcomp message is 

f8 13 54 1f a2 6f 6 0 0 a4 0 0 f 86 7a a4 0 b6 e4 5 a4 0 0 3 0 4 0 5 0 6 0 7 0 8 0 9 0 a 1 b 1 d 1 f 1 11 2 13 2 17 2 1b 2 1f 3 23 3 2b 3 33 3 3b 4 a0 43 4 a0 53 4 a0 63 4 a0 73 5 a0 83 5 a0 a3 5 a0 c3 5 a0 e3 0 a1 2 0 1 0 2 0 3 0 4 1 5 1 7 2 9 2 d 3 11 3 19 4 21 4 31 5 a0 41 5 a0 61 6 a0 81 6 a0 c1 7 a1 1 7 a1 81 8 a2 1 8 a3 1 9 a4 1 9 a6 1 a a8 1 a ac 1 b b0 1 b b8 1 c 80 20 1 c 80 30 1 d 80 40 1 d 80 60 1 1d 3 22 9f b4 1e 20 a0 65 4 7 0 17 80 40 11 1 30 a0 bf 0 0 a0 c0 a0 c7 80 40 29 1 a1 90 a1 ff a0 90 17 50 80 40 11 9 a0 46 13 22 21 1 13 21 1 23 16 9f d1 8 10 4 12 50 4 22 1d 51 22 9f d7 6 12 51 1e 20 9f cf 1 5 0 1f 2f 8 10 4 12 50 4 26 1d 53 26 f6 6 14 53 e 20 63 14 54 52 23 22 50 52 16 9f 9e e 2a a4 86 f 38 4 bf c0 86 a1 40 6 d 38 bf c8 2c 23 2a a1 35 bf c0 86 a1 40 6 0 fb e5 7 df e5 e6 78 f9 6c a 95 fa 6d 98 c1 a c2 30 c 86 7d 94 b1 73 98 f9 db 9a 58 95 21 9e 14 3c 8 e2 43 c8 c0 83 be 3f d8 ae ed 70 9d f7 b4 49 2f f9 be bf 45 11 23 e 3e 47 a8 e9 20 5d c8 55 1d bc 14 4 94 b5 dc e 6d 73 88 85 43 55 d8 8f 2b 5a 54 43 86 17 18 c0 a8 85 d5 19 35 d2 2e 9f ae a8 7b ed 94 c1 fd f 1c e0 a1 ce e9 76 63 59 d8 7b 56 23 d5 91 42 9 34 f9 11 7f c0 b5 68 62 78 ff 8e 16 50 91 b 96 99 95 d5 19 e7 ac c0 4a a8 9b 4f 3f 27 9b f2 a4 c9 89 6b 14 10 47 29 4d 52 a0 35 e5 2f 1d 9a bc 8e 92 87 50 9e 95 62 e6 a2 31 f6 d1 ed 71 ba 5e ee e7 25 8d a5 96 a9 f8 2b b8 e e fa 7c ad be b0 ff 75 bf 

and in this case i am not getting the proper decompressed message.

Regards
Sarvamangala

  ----- Original Message ----- 
  From: Vishal Sudan 
  To: West, Mark ; Sarvamangala ; [email-masked] 
  Sent: Friday, March 31, 2006 11:32 AM
  Subject: RE: [rohc] testing sigcomp code.

  My mistake. I wrote a small program to convert the bytecode given by Sarvamangala to C string 
  to test. I see now that you are right and my small program is behaving badly.

  Please neglect my wrong "analysis" retrospectively.

  Thanks,
  Vishal Sudan

    [Vishal Sudan]  -----Original Message-----
    From: West, Mark [mailto:[email-masked]]
    Sent: Thursday, March 30, 2006 2:49 PM
    To: Vishal Sudan; Sarvamangala; [email-masked]
    Subject: RE: [rohc] testing sigcomp code.

    Hi Vishal,

    I haven't run the code yet (I will do so later), but your answer still confused me!

    In the quoted bytecode I can only see the sequence of bytes: 0x1d 0x03 0x22 0x9f 0xb4 ...
    ... which is INPUT-BITS with 3 parameters.  This is followed by INPUT-HUFFMAN (opcode 0x1e; 0x1f is STATE-CREATE).

    Cheers,

    Mark.

    -----Original Message-----
    From: Vishal Sudan [mailto:[email-masked]]
    Sent: Thu 3/30/2006 8:16 AM
    To: Sarvamangala; [email-masked]
    Subject: RE: [rohc] testing sigcomp code.

    I ran the bytecode in my UDVM . After the INPUT-BITS  is executed the Program counter gets to a
    invalid opcode. Since the bytecode around that is
    \x1d\x3\x22\x1f\xb4\                  ; where \x1d is the input bits opcode.

    Assuming that \x1f mentioned above is INPUT-HUFFMAN, the INPUT-BIT is one argumnet short.

    Thanks and Cheers,
    Vishal Sudan

    PS By mistake I did'nt send my first reply to the ROHC forum, rectifying it this time around

    -----Original Message-----
    From: Sarvamangala [mailto:[email-masked]]
    Sent: Wednesday, March 29, 2006 6:59 PM
    To: Vishal Sudan
    Subject: Re: [rohc] testing sigcomp code.

    Hi Vishal

    could u tell me the exact meaning of !

    regards
    Sarvamangala

    ----- Original Message -----
    From: Vishal  <mailto:[email-masked]> Sudan
    To: Sarvamangala <mailto:[email-masked]> 
    Sent: Wednesday, March 29, 2006 4:59 PM
    Subject: RE: [rohc] testing sigcomp code.

    Hi Sarvamangala,

    It seems to me that you have not compiled the third argument of the INPUT-BITS( 3, , ) which
    comes after the first MULTILOAD.  Because of that an invalid opcode gets hit.

    Thanks and Cheers,
    Vishal Sudan

    -----Original Message-----
    From: Sarvamangala [mailto:[email-masked]]
    Sent: Wednesday, March 29, 2006 3:14 PM
    To: [email-masked]
    Subject: [rohc] testing sigcomp code.

    Hi
    i am facing a unique problem. my code works if the sip message is small and fails for bigger sip messages.

    could someone please check if ur udvm is decompressing this sigcomp code correctly.

    f8 14 74 1f a2 81 6 0 0 a4 0 0 f 86 7a a4 0 b6 e4 5 a4 0 0 3 0 4 0 5 0 6 0 7 0 8 0 9 0 a 1 b 1 d 1 f 1 11 2 13 2 17 2 1b 2 1f 3 23 3 2b 3 33 3 3b 4 a0 43 4 a0 53 4 a0 63 4 a0 73 5 a0 83 5 a0 a3 5 a0 c3 5 a0 e3 0 a1 2 0 1 0 2 0 3 0 4 1 5 1 7 2 9 2 d 3 11 3 19 4 21 4 31 5 a0 41 5 a0 61 6 a0 81 6 a0 c1 7 a1 1 7 a1 81 8 a2 1 8 a3 1 9 a4 1 9 a6 1 a a8 1 a ac 1 b b0 1 b b8 1 c 80 20 1 c 80 30 1 d 80 40 1 d 80 60 1 1d 3 22 9f b4 1e 20 a0 65 4 7 0 17 80 40 11 1 30 a0 bf 0 0 a0 c0 a0 c7 80 40 29 1 a1 90 a1 ff a0 90 17 50 80 40 11 9 a0 46 13 22 21 1 13 21 1 23 16 9f d1 8 10 4 12 50 4 22 1d 51 22 9f d7 6 12 51 1e 20 9f cf 1 5 0 1f 2f 8 10 4 12 50 4 26 1d 53 26 f6 6 14 53 e 20 63 14 54 52 23 22 50 52 16 9f 9e e a1 36 bb 1 1c 1 a1 35 a2 5a 1c c1 34 a1 38 a2 5a e 2a a4 86 f 38 4 bf c0 86 a1 40 6 d 38 bf c8 2c 23 2a a1 35 b6 a4 86 a1 40 6 0 fb e5 7 df e5 e6 78 f9 6c a 95 fa 65 d8 c1 a 83 30 c 6 e0 3d 4a 9e 40 16 9b b5 15 46 71 7b 93 c4 d 26 c8 3a d0 c3 1e 7f a9 4e b1 f5 d6 43 68 e8 e5 ff 92 fe 53 39 69 20 51 5a e9 87 f8 ed 2b 8d f9 35 ff e1 80 c1 a7 33 a6 e2 49 57 84 89 53 65 81 c0 9b c7 d7 63 f4 19 19 90 bb e0 54 6a d f6 7b 14 b8 1e 3b 7 58 14 b8 d e9 cf 62 2e e0 74 6c 77 3d c3 8c 2 36 b5 37 67 74 8e 60 43 85 3d 9 75 ce 3e ad 75 ba b0 2d 90 18 24 bc 34 2b 41 9b 3a bb bb cb 47 5 c8 c7 98 62 6a 85 12 4e a4 fa f4 3 a 4e 6b c4

    Regards
    Sarvamangala

This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message.Global Edge Software Ltd has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Global Edge Software Ltd reserves the right to monitor and review the content of all messages sent to or from this e-mail address
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Vishal Sudan" <[email-masked]>
Date: Tue, 4 Apr 2006 14:56:12 +0530

Hi Sarvamangala,
 
I'd like to point out that you seem to initialize registers byte_copy_left and byte_copy_right with 1024 and 5860 respectively. 
 
In the first mesasge the first Multiload goes like 
            1024     5860 
f 86 7a   <a4 0>   <b6 e4>   5
 
This would result in an overwritten rfc3485 ( loaded at 1024 ). This is not a problem with your current code but if usage of rfc3485 were
interwoven later on, it would possibly result in decompression error or jumbled message.

Thanks and Cheers,
Vishal Sudan

-----Original Message-----
From: Sarvamangala [mailto:[email-masked]]
Sent: Tuesday, April 04, 2006 2:33 PM
To: West, Mark; Vishal Sudan; [email-masked]
Subject: Re: [rohc] testing sigcomp code.

Hi Mark,
 
Thanks for the help. after i configured the compressor to work wth static coding its working fine.
 
Regards
Sarvamangala 

----- Original Message ----- 
From: West,  <mailto:[email-masked]> Mark 
To: Sarvamangala <mailto:[email-masked]>  ; Vishal  <mailto:[email-masked]> Sudan ; [email-masked] 
Sent: Tuesday, April 04, 2006 1:04 AM
Subject: RE: [rohc] testing sigcomp code.

Hi Sarvamangala,

Two observations (based on a very cursory glance at your bytecode):

1/ I don't understand the presence of the 6 bytes '78 f9 6c a 95 fa' in the messages, immediately following the bytecode.  However, if I remove these, then the first message does indeed decompress correctly.

2/ (Making the same assumption about the actual start of the zlib compressed block on the second message.)  The message appears to be compressed using dynamic Huffman codes (note the different block-type in the 3 bit block header) -- which would explain the correlation with message size.  Since the bytecode is written for static codes, you should probably configure the compressor to only use static codes...

Cheers,

Mark.

-----Original Message-----
From: Sarvamangala [ mailto:[email-masked]]
Sent: Mon 4/3/2006 8:36 AM
To: Vishal Sudan; West, Mark; [email-masked]
Subject: Re: [rohc] testing sigcomp code.

if the input message is

Regards
Sarvamangala

  ----- Original Message -----
  From: Vishal Sudan
  To: West, Mark ; Sarvamangala ; [email-masked]
  Sent: Friday, March 31, 2006 11:32 AM
  Subject: RE: [rohc] testing sigcomp code.

  Thanks,
  Vishal Sudan

    From: West, Mark [ mailto:[email-masked]]

    Hi Vishal,

    Cheers,

    Mark.

    -----Original Message-----
    From: Vishal Sudan [ mailto:[email-masked]]
    Sent: Thu 3/30/2006 8:16 AM
    To: Sarvamangala; [email-masked]
    Subject: RE: [rohc] testing sigcomp code.

    Thanks and Cheers,
    Vishal Sudan

    -----Original Message-----
    From: Sarvamangala [ mailto:[email-masked]]
    Sent: Wednesday, March 29, 2006 6:59 PM
    To: Vishal Sudan
    Subject: Re: [rohc] testing sigcomp code.

    Hi Vishal

    regards
    Sarvamangala

    ----- Original Message -----
    From: Vishal  < mailto:[email-masked]> Sudan
    To: Sarvamangala < mailto:[email-masked]>
    Sent: Wednesday, March 29, 2006 4:59 PM
    Subject: RE: [rohc] testing sigcomp code.

    Hi Sarvamangala,

    Thanks and Cheers,
    Vishal Sudan

    -----Original Message-----
    From: Sarvamangala [ mailto:[email-masked]]
    Sent: Wednesday, March 29, 2006 3:14 PM
    To: [email-masked]
    Subject: [rohc] testing sigcomp code.

    Hi

    Regards
    Sarvamangala