Subject: [rohc] IP-Only Profile in *-rohv2-profiles-00.txt

From: Carl Knutsson <[email-masked]>
Date: Tue, 06 Mar 2007 17:29:21 +0100

Kristofer, Ghyslain, rohcers,

The IP-only profile could benefit from having a endpoint flag (field) in the
compressed formats ipv4_static and ipv6_static. So that the compressor can choose
to compress fewer IP-headers than what is present in the uncompressed packet.

Example: The compressor could compress only the IPv4/ part of an IPv4/IPv6 header.

The flag is necessary if the decompressor should be able to decompress the static
chain, since the last extension header of the innermost IP header may have
protocol number that is compressible for the profile.

RFC 3843 sends this information in the version field of the IPv4/IPv6 static item.
In this draft, we could use the reserved fields in compressed formats ipv4_static
and ipv6_static for this purpose.

Best regards,
/Calle

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: "Kristofer Sandlund \(LU/EAB\)" <[email-masked]>
Date: Wed, 7 Mar 2007 08:18:00 +0100

Hi Calle,

sounds like a reasonable addition, so I will add it to my local copy at
once.
Should be simple to just add an indicator bit and add an
ENFORCE(is_innermost == innermost_indicator.UVALUE) in the static
formats, so
I don't think any extra text needs to be added based on this.

/Kristofer

Carl Knutsson <mailto:[email-masked]> wrote on den 6 mars 2007
17:29 :

> The IP-only profile could benefit from having a endpoint flag (field)
> in the compressed formats ipv4_static and ipv6_static. So that the
> compressor can choose to compress fewer IP-headers than what is
> present in the uncompressed packet. 
> 
> The flag is necessary if the decompressor should be able to
> decompress the static chain, since the last extension header of the
> innermost IP header may have protocol number that is compressible for
> the profile. 
> 
> RFC 3843 sends this information in the version field of the IPv4/IPv6
> static item. In this draft, we could use the reserved fields in
> compressed formats ipv4_static and ipv6_static for this purpose.
> 
> Best regards,
> /Calle