Subject: [rohc] Doubt in RFC 3321

From: "Gangadharan G, TLS-Chennai" <[email-masked]>
Date: Wed, 14 Mar 2007 15:33:09 +0530

Hi All,

I have a doubt in the RFC 3321.

For Dynamic Compression, It mentions that Compressor1 has to save a
buffer as a state that will use while compressing the later message (in
Page 8).

(1): Compressor 1 saves e.g., state(A)

For Shared Compression, It mentions that Compressor1 has to save an
uncompressed message as a state so that the remote compressor
(Compressor2) will use the received message for compressing the message
(in Page 10).

(1): Compressor 1 saves e.g., state(M), which is the uncompressed

                  version of the current application message to be
compressed and

                  sent.

My doubt is:

                       In case of dynamic compression, Compressor will
save the state in its local memory and not in the State-handler i.e.,
State Memory of the compartment.

                       In case of shared compression, Compressor will
save the state in the State-handler and not in its local memory.

                       This information is not clearly mentioned in the
RFC.

                       Please let me if I have stated anything wrong.

                       Also, is compressor capable of creating only
locally available state items i.e., state with state_retention_priority
as 65535?

Thanks,

Gangadharan.

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc

---

From: [email-masked]
Date: Wed, 14 Mar 2007 17:09:49 +0530

Hi Gangadhar,

My doubt is:
                       In case of dynamic compression, Compressor will 
save the state in its local memory and not in the State-handler i.e., 
State Memory of the compartment.
                       In case of shared compression, Compressor will save 
the state in the State-handler and not in its local memory.
                       This information is not clearly mentioned in the 
RFC.
                       Please let me if I have stated anything wrong.
 
                       Also, is compressor capable of creating only 
locally available state items i.e., state with state_retention_priority as 
65535?

<Rasheed> your understanding is correct. ie in case of dynamic 
compression, the state is saved in its local memory not in SMS but in case 
of shared compression, the state is saved in SMS not in local memory.

Regards,
Rasheed

"Gangadharan G, TLS-Chennai" <[email-masked]> 
03/14/2007 03:33 PM

To
<[email-masked]>
cc

Subject
[rohc] Doubt in RFC 3321

Hi All,

For Dynamic Compression, It mentions that Compressor1 has to save a buffer 
as a state that will use while compressing the later message (in Page 8).

 
 
My doubt is:
                       In case of dynamic compression, Compressor will 
save the state in its local memory and not in the State-handler i.e., 
State Memory of the compartment.
                       In case of shared compression, Compressor will save 
the state in the State-handler and not in its local memory.
                       This information is not clearly mentioned in the 
RFC.
                       Please let me if I have stated anything wrong.
 
                       Also, is compressor capable of creating only 
locally available state items i.e., state with state_retention_priority as 
65535?
 
Thanks,
Gangadharan.

DISCLAIMER:

The contents of this e-mail and any attachment(s) are confidential and 
intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its 
affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect 
the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, 
modification, distribution and / or publication of 
this message without the prior written consent of the author of this 
e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender 
immediately. Before opening any mail and 
attachments please check them for viruses and defect.

***********************  Aricent-Unclassified   ***********************
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of 
the individual to whom it is addressed. It may contain privileged or confidential information and should not be 
circulated or used for any purpose other than for what it is intended. If you have received this message in error, 
please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly
prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for 
loss or damage arising from the use of the information transmitted by this email including damage from virus."
_______________________________________________
Rohc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rohc