Subject: [rohc] ROHC over Mobile IPv6

From: Frank Xia <[email-masked]>
Date: Fri, 09 Jan 2009 16:57:39 -0600

Hi All   

Mobile IPv6 (MIPv6) is widely adopted by 
WiMAX/3GPP/3GPP2.  To improve MIPv6 
performance, IETF mobility community, 
especially MIPSHOP and MEXT WG, 
has been working on tunnel optimization for a while.
The solution was questioned by IESG last November
during MIPSHOP Rechartering.  IESG suggested
ROHC should be considered in this work.

Mobiel IPv6 specifies a protocol which allows 
a mobile  to remain reachable while moving around
the internet. The mobile node is always  identified 
by its home address, regardless of its current point 
of attachment to the Internet.  While situated away 
from its home, the mobile node is also associated 
with a care-of address, which provides information 
about the mobile node's current location.  IPv6 packets 
addressed to the mobile node's home address are 
intercepted by a home agent, and routed to the
mobile node through a bidirectional tunnel. Tunnel
encapuslation could be IPSec, IPv6inIPv6, IPv4inIPv6,
IPv4 in UDP, or others .

Mobile IPv6 uses Binding Update (BU)/Binding 
Acknowledgement(BA) to create/delete tunnel,
and Generic Signaling Messages for other 
purpose communication. 

is it possible to have a  channel  parameters 
negotiation document to facilitate MIPv6 using 
ROHC?

BR
Frank
_______________________________________________
Rohc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rohc

---

From: Robert Stangarone <[email-masked]>
Date: Fri, 09 Jan 2009 15:12:06 -0800

Frank,

You might take a look at a the following documents that propose how to
negotiate ROHC Channel Parameters for the use ROHC within an IPsec
tunnel with IKEv2:

Integration of Robust Header Compression (RoHC) over IPsec Security
Associations
http://www.ietf.org/internet-drafts/draft-ietf-rohc-hcoipsec-09.txt

IKEv2 Extensions to Support Robust Header Compression over IPsec(RoHCoIPsec)
http://www.ietf.org/internet-drafts/draft-ietf-rohc-ikev2-extensions-hcoipsec-07.txt

IPsec Extensions to Support Robust Header Compression over IPsec
(RoHCoIPsec)
http://www.ietf.org/internet-drafts/draft-ietf-rohc-ipsec-extensions-hcoipsec-03.txt

Cheers,

Bob

---

From: Frank Xia <[email-masked]>
Date: Fri, 09 Jan 2009 17:32:03 -0600

Hi Bob

Thank your reply!
I had a glance at  these documents.

The problem is  that MIPv6 never mandates using
IPSec tunnel when forwarding data packets.
That is, it is possible that there is no any IPSec
SA between tunnel ends.

BR
Frank