Subject: [rohc] Reg:Reordering in ROHC

From: R Ranjith kumar <[email-masked]>
Date: Sat, 3 Oct 2009 16:06:20 +0530

Hi ROHCers...

I am having some doubt in re_ordering  in ROHC

In *5225*  sec: *4.1*

Out-of-order delivery between compression endpoints

      The definition of the ROHCv2 profiles places no strict requirement
      on the delivery sequence between the compression endpoints, i.e.,
      packets may be received in a different order than the compressor
      has sent them and still have a fair probability of being
      successfully decompressed.

This means that almost no need to maintain the order
if so, then what is the use of getting the reorder packets after
decompression

i think after getting reorder packets decompressor has to decompress it and
maintain those packets in order....

Plz reply for my doubt

Bye

-- 
Ranjith Kumar. R

  ("`-''-/").___..--''"`-._
   `6_ 6  )   `-.  (     ).`-.__.`)
   (_Y_.)'  ._   )  `._ `. ``-..-'
 _..`--'_..-_/  /--'_.' ,'
(il),-''  (li),'  ((!.-'

---

From: Carl Knutsson <[email-masked]>
Date: Mon, 05 Oct 2009 10:08:17 +0200

Kumar,

The requirement is for the channel between the compressor and
decompressor. It means you can use ROHCv2 over channels that reorder
packets.

cheers,

/Calle

R Ranjith kumar wrote:
> i think after getting reorder packets decompressor has to decompress it
> and maintain those packets in order....
> 
> 
> Plz reply for my doubt
> 
> Bye
> 
> 
> 
>  
> 
> -- 
> Ranjith Kumar. R
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rohc

---

From: R Ranjith kumar <[email-masked]>
Date: Wed, 7 Oct 2009 14:29:57 +0530

Thank U Carl

Could U suggest me a good tool for RTP/UDPlite packet

because for RTP/upd/ipv((4,6) i used VLC player. is it possible to generate
rtp/udplite packet using VLC player?
is so please guide me....

-- 
Ranjith Kumar. R

---

From: Carl Knutsson <[email-masked]>
Date: Wed, 07 Oct 2009 11:23:49 +0200

I am not aware of any application that sends RTP/UDPlite packets.

/calle

R Ranjith kumar wrote:
> because for RTP/upd/ipv((4,6) i used VLC player. is it possible to
> generate rtp/udplite packet using VLC player?
> On Mon, Oct 5, 2009 at 1:38 PM, Carl Knutsson <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Kumar,
> 
>     > [email-masked] <mailto:[email-masked]>