Subject: Re: [rohc] [Technical Errata Reported] RFC5225 (3248)

From: Wesley Eddy <[email-masked]>
Date: Sat, 28 Jul 2012 19:08:57 -0400

This errata looks correct to me; if nobody objects, I'll mark it
as "Verified" in the errata tool later this week.

On 6/7/2012 10:14 AM, RFC Errata System wrote:
> 
> The following errata report has been submitted for RFC5225,
> "RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=5225&eid=3248
> 
> --------------------------------------
> Type: Technical
> Reported by: FWX <[email-masked]>
> 
> Section: 6.8.2.4
> 
> Original Text
> -------------
> page 67:
> 
>   COMPRESSED udp_lite_endpoint_dynamic {
>     ENFORCE(profile_value == PROFILE_UDPLITE_0108);
>     reserved =:= compressed_value(4, 0)                      [  4 ];
>     coverage_behavior =:= irregular(2)                       [  2 ];
>     reorder_ratio     =:= irregular(2)                       [  2 ];
>     checksum_coverage =:=
>       checksum_coverage_dynchain(coverage_behavior.UVALUE)   [ 16 ];
>     checksum          =:= irregular(16)                      [ 16 ];
>     msn               =:= irregular(16)                      [ 16 ];
>   }
> 
> page 68:
> 
>   COMPRESSED udp_lite_regular_dynamic {
>     ENFORCE(profile_value == PROFILE_RTP_0107);
>     coverage_behavior =:= irregular(2)                       [  2 ];
>     reserved =:= compressed_value(6, 0)                      [  6 ];
>     checksum_coverage =:=
>         checksum_coverage_dynchain(coverage_behavior.UVALUE) [ 16 ];
>     checksum =:= irregular(16)                               [ 16 ];
>   }
> 
> 
> Corrected Text
> --------------
> page 67:
> 
>   COMPRESSED udp_lite_endpoint_dynamic {
>     ENFORCE(profile_value == PROFILE_UDPLITE_0108);
>     reserved =:= compressed_value(4, 0)                      [  4 ];
>     coverage_behavior =:= irregular(2)                       [  2 ];
>     reorder_ratio     =:= irregular(2)                       [  2 ];
>     checksum_coverage =:=
>       checksum_coverage_dynchain(coverage_behavior.UVALUE)   [ 0, 16 ];  <===
>     checksum          =:= irregular(16)                      [ 16 ];
>     msn               =:= irregular(16)                      [ 16 ];
>   }
> 
> page 68:
> 
>   COMPRESSED udp_lite_regular_dynamic {
>     ENFORCE(profile_value == PROFILE_RTP_0107);
>     coverage_behavior =:= irregular(2)                       [  2 ];
>     reserved =:= compressed_value(6, 0)                      [  6 ];
>     checksum_coverage =:=
>         checksum_coverage_dynchain(coverage_behavior.UVALUE) [ 0, 16 ];  <====
>     checksum =:= irregular(16)                               [ 16 ];
>   }
> 
> 
> Notes
> -----
> checksum_coverage_dynchain(behavior) compression method (page 66) may compress the checksum_coverage field to 0 bits if behavior is set to UDP_LITE_COVERAGE_INFERRED.
> 
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC5225 (draft-ietf-rohc-rfc3095bis-rohcv2-profiles-06)
> --------------------------------------
> Title               : RObust Header Compression Version 2 (ROHCv2): Profiles for RTP, UDP, IP, ESP and UDP-Lite
> Publication Date    : April 2008
> Author(s)           : G. Pelletier, K. Sandlund
> Category            : PROPOSED STANDARD
> Source              : Robust Header Compression
> Area                : Transport
> Stream              : IETF
> Verifying Party     : IESG
> _______________________________________________
> Rohc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rohc
> 
> 

-- 
Wes Eddy
MTI Systems

---

From: RoHC Team <[email-masked]>
Date: Sun, 29 Jul 2012 11:08:21 +0200

Hello,

  Thank you for your post.

  Best regards,

              FWX.

---

From: Carl Knutsson <[email-masked]>
Date: Tue, 31 Jul 2012 08:21:55 +0200

It looks correct to me too.

/Calle