Subject: Split Horizon with Poison Reverse

From: Sam Ford <[email-masked]>
Date: Wed, 15 May 2002 13:48:43 -0700 (PDT)

Hello,

I was going through IPv4 router requirements RFC
and I didn't understand the following.

-----
RIP Split Horizon and Static Routes

   Split horizon SHOULD be applied to static routes by
default.  An
   implementation SHOULD provide a way to specify, per
static route,
   that split horizon should not be applied to this
route.
-----

What does it mean by split horizon should be applied
to
static routes?
- Does it mean that static routes defined in the
router
  should be omitted in advertisements to others?
- I thought RIP had no way to distinguish whether the
  received route is static route or not.
- Or is this only refering to default route received
  from neighbor?

I appreciate any clarification on this issue.
Regards,
-SF

__________________________________________________
Do You Yahoo!?
LAUNCH - Your Yahoo! Music Experience
http://launch.yahoo.com

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: "Smith, Mark - Sydney" <[email-masked]>
Date: Thu, 16 May 2002 09:40:29 +0800

Hi Sam,

I would interpret it as follows (comments embedded)

> -----Original Message-----
> From: Sam Ford [mailto:[email-masked]]
> Sent: Thursday, 16 May 2002 6:49
> To: [email-masked]
> Subject: Split Horizon with Poison Reverse
> 
> 
> Hello,
> 
> default.

1) from the point of view of the split horizon function, there is nothing
special about static routes, and therefore split horizon should be applied
to static routes (as well as all other routes learned by RIP (eg connected,
learnt from peers) by default.

  An
>    that split horizon should not be applied to this

2) however, as static routes are manually defined / configured, there should
be an ability to switch off the split horizon function on a per static route
basis.

>   should be omitted in advertisements to others?

See 1) above

>   received route is static route or not.

I think the above is referring to the router that would be distributing the
static route into the RIP routing domain. I think your right, I don't think
there is a way of distinguishing a static vs other route when received
within a RIP advertisement (at least with RIPv1 anyway - RIPv2 supports
route tags, I would think the RFC description would be more RIP version
specific if it was referring to RIPv2 route tags).

> - Or is this only referring to default route received
>   from neighbor?
> 

I think all static routes.

HTH,
Mark.

---

From: Joe Loiacono <[email-masked]>
Date: Thu, 16 May 2002 09:09:55 -0400

My guess would be the following:

A static route can be viewed *as if it has come from* the neighbor to which
it points. In that regard, it should not be provided to that neighbor.

Joe

                    Sam Ford                                                                                                 
                    <[email-masked]>          To:     [email-masked]                                       
                    Sent by:                       cc:                                                                       
                    routing-discussion-admi        Subject:     Split Horizon with Poison Reverse                            
                    [email-masked]                                                                                               

                    05/15/2002 04:48 PM                                                                                      

Hello,

-----