Subject: Doubts on RIP Route Tag and Route Redistribution

From: Sam Ford <[email-masked]>
Date: Wed, 8 May 2002 13:21:56 -0700 (PDT)

Hello,

I have doubts on RIP Route Tag and Route
Redistribution.

RIPv2 defines Route Tag but it doesn't describe how
exactly Route Tag is used during best route
computation.
So, I assume that Route Tag is not used for route
computation by RIP, but it's just a tag to indicate
what kind of route it is that may be used during
route redistribution.
Is my understanding correct?

Also, in the route redistribution, the way I
understand
is that when a route is redistributed from one routing
protocol to another, only the route that is selected
as the best route by the router is redistributed.
In other words, when OSPF to RIP redistribution is
enabled, OSPF learned route to destination A but a
static
route is defined for the same destination A.
So, the router does not use the route learned from
OSPF
but instead use the static route to destination A
assuming
administrative distance for static is less than OSPF.
In such a case, I assume the router should not
redistribute the route to A learned from OSPF into
RIP,
since it's not the best route and itself does not use
the route, as per router requirement RFC.
Is my understanding correct?

Thanks in advance for any help.
Regards,
-SF

__________________________________________________
Do You Yahoo!?
Yahoo! Health - your guide to health and wellness
http://health.yahoo.com

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Acee Lindem <[email-masked]>
Date: Thu, 09 May 2002 14:12:01 -0400

Hello Sam,

I'll take a shot at your questions.

> Is my understanding correct?

Yes. The tag has no bearing on route computation. Conceivably,
one could a RIPv2 route's tag for the following types of
policy decisions.

    1. Determining whether a RIPv2 route is accepted (globally or
       at a RIPv2 interface level).
    2. Determining whether a RIPv2 route is advertised (globally or
       at a RIPv2 interface level).
    3. Determining whether a RIPv2 route is redistributed into a
       another protocol instance.

Also note that since the tag is carried across the RIPv2 routing
domain, one could classify a route and have a consistent policy
applied throughout the RIPv2 routing domain. At one time, I believe
it was envisioned that you'd have RIP-BGP interaction similar to
the OSPF-BGP interaction described in RFC 1745 (now historic). Of
course, OSPF-BGP interaction never caught on since the tag
did not carry enough info and providers had to run IBGP anyway.

> as the best route by the router is redistributed.

Yes - although there have been some recent exceptions
with respect to connected routes and MPLS VPNs.

> Is my understanding correct?

I'm not sure exactly where this is stated but in general
a router should not advertise a route it is not using.

-- 
Acee