Subject: RE: AW: Differentiated Routing, not only plain rambo-SPF

From: "Naidu, Venkata" <[email-masked]>
Date: Wed, 24 Jul 2002 14:38:05 -0400

Noel,

-> From: J. Noel Chiappa [mailto:[email-masked]]
->     > From: Hummel Heinrich <[email-masked]>
-> 
->     > In normal, state-less IP routing
-> 
-> You just hit one of my hot buttons.
-> 
-> Normal IP routing is not stateless. It has lots of state in 
-> the network.
  
  Hummel is not talking about *state* in the network.
  The information (in your words: a Header) required to 
  route packets is state-less. Routing is purely based on
  *destination* address. Isn't it?
  
-> - just a destination address (in which case the paths 
-> selected are independent of any kind of service)

This is what Hummel meant by *Classical state-less IP-Routing*

  All the below *routing schemes* are considered as
  extra states (in addition to destination address)

-> - a destination address plus some sort of service selection 
-> (be it ToS, or	DiffServ, or whatever)
-> - a path selector (think ATM or MPLS)
-> - a loose source route
-> - a complete source route

  IMO, most of the confusions in the lists are because of 
  our terminology. I have been trying to convince Fred
  about the difference and what we need to achieve based
  on *Traffic Management* and *Traffic Engineering*.
  But I failed to express in the right way.

  I know...I know that Traffic "Engineering" is for
  efficient use of network resources in SPs. Where as
  Traffic "Management" is a local decision on how a
  router must forward/queue/schedule packets to achieve
  a desired CoS QoS.

  IMHO, just using DSCP bits on per-hop won't achieve 
  QoS "Globally". You have to combine TE also.
  That "QoS using TE" has been neglected by us.
  That is what I am trying to convince Fred. 
  
  If you consider IP is a superset, MPLS, QoS and TE are
  some overlapping subsets (pictorially):

       IP Superset
       +-----------------------------------+
       |     __________    __________      |
       |    /          \  /           \    |
       |   /   MPLS     \/    QoS      \   | 
       |  /             /\              \  | 
       | |             |  |             |  | 
       | |             |  |             |  |
       | |             |  |             |  |
       | |          ___|__|___          |  |
       |  \        /    \/    \        /   |
       |   \      /     /\     \      /    |
       |    \____/_____/  \_____\____/     |
       |        |                |         |    
       |        |                |         |
       |        |                |         |
       |         \      TE      /          |
       |          \            /           |
       |           \__________/            |
       |                                   |
       +-----------------------------------+

   You can just do MPLS (for fast label look-up etc).
   You can achieve QoS using MPLS (without TE)
   You can achieve better QoS using TE (with or 
   without MPLS) etc etc...

   IMHO, the intersection of all the subsets (ie., 
   (QoS using MPLS-(DiffServ-Aware-TE) will make a 
   *real-good* impact on end-to-end performance in the 
   global Internet.
   
   I am not alleging these points here. There has been
   some research & simulation in this area. Please 
   look at an old neglected paper by Raj Jain's group: 
ftp://ftp.netlab.ohio-state.edu/pub/jain/ietf/draft-bhani-mpls-te-anal-00.tx
t
   
  Simulation & analysis in a simple topology shows:
  "..in order to benefit from traffic engineering, MPLS 
   trunks should be implemented end-to-end (first router
   to last router). If some part of the network is 
   MPLS-unaware, the benefits are reduced or eliminated."

  So, are we doing MPLS-TE end-to-end to achieve desired QoS?
  If not (I am sure we are not - we are still doing MPLS-TE
  in small areas), then what are the alternatives?

--
Venkata.

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: shen jing <[email-masked]>
Date: Fri, 26 Jul 2002 10:27:29 +0800

IMO,  Hummel present a very interesting question: how could traffic be routed
according to their DiffServ classes?

ECMP or OMP has been investigated in past days,  and simulation results showed
they can improve network
performance under the experiment conditions. If I do not make a mistake, there
is someone publishing a paper
on "alternative routing with DSCP" in "Computer Network". In that paper, the
author stated to reroute
traffic according to DSCP in packet header when congestion happens along the
primary path.

On the other side, routing is the basic mechanism to carry traffic through the
network, so it is one the key factors for  load balancing (TE)
or QoS.Without cooperation between routing , CAC and schedulting ,  QoS is
impossible, while load balancing may be done with
routing.  Starting from this, I think it should not be the center of
consideration whether IP routing is stateless or the contrary. We must
make clear what we want to achieve first.

It seems Hummel thought about "multipath routing with DSCP network " overlaid
above IP networks.  I think there may be some
very diffcult problem with such a idea:

1. What's the target?
    I think the answer may be :  Differentiated service between flows + Load
balancing over networks + routing stability

2.  The basic method ?
   It may be :  multipath routing + DSCP based path selection  ( We do not
consider too much of CAC or the like here because we want to walk around
congestied
   part of network by routing with multipath path )

3. How could the overlaid network be built?
    I think this may be most difficult, as :  connection-oriented or
connectionless,  how could the path be computed, how could the path be
establised over network?
    MPLS may be a useful tool, but what about the scalability?

4. Is there any confliction between  routing and  congestion control mechanism
in TCP ?

>   *destination* address. Isn't it?

[snip]

---

From: shen jing <[email-masked]>
Date: Fri, 26 Jul 2002 10:27:29 +0800

1. What's the target?

2.  The basic method ?

[snip]