Subject: Differentiated Routing, not only plain rambo-SPF

From: Hummel Heinrich <[email-masked]>
Date: Mon, 22 Jul 2002 18:40:02 +0200

In normal, state-less IP routing we cannot do QoS-Routing, nor sneak-around the conjestion-area routing, nor traffic balanced routing. Instead, all of this is left to MPLS, where multiple states and multiple LSPs and multiple signalling is required.

However, I am pretty sure that normal state-less IP routing could do all of it much better and like to launch a discussion
on, well, Differentiated Routing. 

Additional reasons for doing it:

As far as I know, all multicast models build their delivery channels based on SPF-results. By accomplishing
QoS-routing for normal IP, QoS-routed Multicast delivery channels might consequently  come for free (or almost for free).
Also: It would prevent that further thoughts are given to Equal-Cost Multipath (ECMP) which I think is not worth the effort.

Differentiated Routing would certainly stress Differentiated Services and I think that the reason why it hasn't been 
introduced together with DiffServ is that IETF folks are only seeing the advantages of SPF routing but not its disadvantages, i.e. were therefore blocked.

2 Examples, i.e 2 analogies well-known from our roads and highways:

1) QoS Routing
Right now, there are many Europeans going on vacation by driving southbound who are willing to pay the fees for using the highways of whichever country they pass (Germany excepted) while others aren't willing. So each group has a different set of roads available to use. As a result each one will find the optimal route in accordance with what he/she likes to spend on money. 

2)
On the way south there are several hot spots which are famous for being points of conjestion. A vacationer is well advised to pull off the highway and follow the posted signs that mark asneak-around detour as to reenter further south.  
Now let's have a look at our famous rambo-zambo SPF routing paradigma. You pull off the highway.At the first junction you cry for the shortest path to your destination.Because the answer is "crankback to the highway, this option drops out, and you choose randomly any other direction. This behavior repeats at each junction. This rambo will start looping and will soon  run out of gas before he reaches the Alpes, so that the Time-To-Live is over. The smart driver however follows the detour signs, and while he is on the detouring route, he forgets about the final destination. Instead his intermediate destination is the point where he will reenter the highway. As soon as the detouring route has been done, the focus will be again on the original destination.
Isn't  this a perfect routing tunnel? the outer dest address is the re-entrance point of the autobahn,while the route to it is computed based on the fee-less set of roads.The inner destination is somewhere south at the beach and the respective forwarding may be based on computations which takes all roads and all paid highways into consideration.

So my initial question is: why can't we go after Differentiated Routing ?!
And also: why can't we go after better routing paradigmas (with respective algorithms) than SPF-routing ?!

Heinrich 

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Fred Baker <[email-masked]>
Date: Mon, 22 Jul 2002 10:54:46 -0700

At 06:40 PM 7/22/2002 +0200, Hummel Heinrich wrote:
>Differentiated Routing would certainly stress Differentiated Services and 
>I think that the reason why it hasn't been introduced together with 
>DiffServ is that IETF folks are only seeing the advantages of SPF routing 
>but not its disadvantages, i.e. were therefore blocked.

The reasons are far more mundane. Routing is not only a different working 
group, it is a different area, and the work that the IETF did on the 
subject of differentiated routing in the past (mostly in OSPF) wound up not 
being important commercially and eventually got pulled out.

That said, there is some current interest in routing infrastructures that 
use both destination address and DSCP. As a result, some from the vendor 
community are looking at resurrecting and retargeting the (SPF-based) OSPF 
algorithms for that.

The key to those algorithms is not so much finding an intermediate 
destination to route to as it is to find a better metric for the traffic 
that actually results in a different and better route. TOS-based OSPF used 
the duration of a bit as the metric, and then decided whether or not to 
advertise a link as having low delay (satellite links?) or any of the other 
parameters. It would probably be better if we could actually somehow 
quantify those characteristics rather than having include/exclude lists.

>algorithms) than SPF-routing ?!

I should think this is largely a matter of market requirement. Demonstrate 
a market, and we can probably design something to meet its requirements. 
Absent a way to turn it into money, you might have difficulty drumming up 
commercial interest.

---

From: Fred Baker <[email-masked]>
Date: Mon, 22 Jul 2002 10:54:46 -0700