Subject: Re: End-to-End QoS Routing

From: Fred Baker <[email-masked]>
Date: Mon, 22 Jul 2002 14:10:10 -0700

At 04:24 PM 7/22/2002 -0400, [email-masked] wrote:
>   You completely misunderstood my good intensions.

Sorry you felt that way. I wasn't questioning your intentions.

>   Question:
>   All the current QoS routing (MPLS-TE)

I'm not convinced that all QoS routing is in MPLS-TE. That is simply what 
is visible as IETF effort.

>Using all these QoS routing extensions are confined to these small areas 
>will not buy us (an end users) anything in the long run (end-to-end 
>Internet perspective). Do you agree?

That's a *really* open-ended question.

Traffic engineering is not really there to help you, the end user; it is 
there to help the service provider give a service to its customers (not you 
personally, the company that contracts service on your behalf) in a 
consistent and cost-effective manner. If you are having a problem with 
inconsistent service, having your service provider do some traffic 
engineering might help, and might not; if you're not having that problem, 
all the traffic engineering in the world won't help with whatever problems 
you do have.

>   If not,
>   "How can we deliver real-time services (differentiated)
>    with some end-to-end guarantee over the Internet?"

Again, exactly what *problem* do you need to solve? Do you need 
differentiation? What guarantees do you need that you are not getting now?

>   Possible Solution(s):

Until I have a problem statement, it's really hard to comment on potential 
solutions. I gave you several problem statements that I am dealing with. 
Give me yours?

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Fred Baker <[email-masked]>
Date: Mon, 22 Jul 2002 14:10:10 -0700

---

From: [email-masked]
Date: Mon, 22 Jul 2002 16:24:47 -0400

Fred,

-> >PS: I am speaking as an individual.
-> 
-> This is an IETF list. We are all individuals in this forum. 
-> Frankly, if 
-> your opinion would be different if you posted from a different email 
-> address, it's not actually your opinion, and I'm not particularly 
-> interested in it.

  As an young individual I don't want to convince you about
  my good intensions. Please read on...

-> I guess my question is "please state the problem".
-> What is the problem you want to solve, that your proposal might be a 
-> solution to?

  Hummel question is different. Both of us provided the
  same answer to Hummel question.

  My question is nothing to do with Diff-Routing. It's about
  QoS Routing w.r.t End-End behavior. I am not at all 
  asking to route at the circuit level.

  Question:
  All the current QoS routing (MPLS-TE) is limited to 
  an Area (a small fraction in the Internet). Using all 
  these QoS routing extensions are confined to these small
  areas will not buy us (an end users) anything in the 
  long run (end-to-end Internet perspective). Do you agree?

  If not,

  Possible Solution(s):
  1. Hierarchical QoS Routing
  ---------------------------
  This is already an on-going discussion in IETF & IRTF:

  "Do you think that there is no such need for
   Hierarchical QoS Routing in the Internet (to provide
   differentiated service end-to-end)?" 
  
  2. Other Possible Solutions
  ---------------------------
  If we worry about scalability & aggregation of
  hierarchical QoS routing, we can search for other
  possibilities. For example, "LSP stitching" from
  source AS till destination AS. This does not 
  require any enhancements to IGPs but requires
  some way of communications of the QoS parameters
  across EGP boundaries.

  Regardless of Routing possibilities, signaling 
  protocols must provide mechanisms for accross AS 
  signaling. That is under NSIS study. Am I right?

  Again, to be specific, what are the different 
  alternatives for end-to-end QoS routing? Is 
  there any requirement to "extend" QoS routing
  beyond AS boundaries? 

  I think there is definite need (based on transport 
  area WG efforts to provide real-time services over 
  Internet). Do you agree?

  PS: Fred, I request you not to frame any opinions
      based on from address. :) SMTP doesn't validate 
      sender's address. :-)

--
Venkata.