Subject: RE: Loop Detection

From: "Amir Hermelin" <[email-masked]>
Date: Thu, 4 Jul 2002 01:11:53 +0300

my 2 cents:
* Yes, such a tool would be very nice. Although, a small portion of our salaries is due to the fact that routing loops are so scary ;-)
* The approaches would be different for types of protocols. In IGPs, assuming correct implementations, the protocol takes care of loop possibilities as long as the lspdb is in sync. When its not due to transient states, a tool wouldn't help since you'd have to run it constantly for every router's view.
* I agree that detecting BGP mis-configuration is hard. As for MPLS, there are methods that are more susceptible to loops than others (e.g. one implementation of TE-shortcuts can lead to loops even in a seemingly correct configuration, due to metric values).
* If this stuff moves forward, it might even mandate a whole new workgroup. 

--
Amir Hermelin                  <mailto:[email-masked]>
Charlotte's Web Networks Inc.   <http://www.cwnt.com>

> -----Original Message-----
> From: Hummel Heinrich [mailto:[email-masked]]
> Sent: Tuesday, July 02, 2002 11:17 AM
> To: [email-masked]
> Subject: Re: Loop Detection
> 
> 
> Wouldn't it be a fine goal to standardize a tool/mechanism/protocol
> which double-checks, within milliseconds, that all routing 
> tables of some network domain are in sync ?
> Or at least, that the topological view, aquired by all nodes 
> of some network domain complies with the physical reality ?
> Wouldn't this be a powerful OAM-application ? IMHO:it would 
> be better than the religious fights on OAM-MPLS.
> 
> Heinrich Hummel
> Siemens AG
> 
> 
> 
>  On Tue, 4 Jun 2002, Jing Shen wrote:
> 
> > Given a network with several routers, is there any 
> tool/application to
> > detect loops in the routing tables?
> 
> As far as I know, there isn't.
> Also if the loop is due to a misconfiguration which does not show up
> in BGP updates, then it's harder to detect.
> 
> -Sue
> 
> 
> _______________________________________________
> routing-discussion mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/routing-discussion
> 

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: "John Renwick" <[email-masked]>
Date: Wed, 3 Jul 2002 17:59:07 -0500

Isn't TTL a very direct and immediate form of loop detection?  
If you had a network tool that would illuminate the routers that 
are counting a lot of packets dropped because of TTL expiration, 
it could be showing you points on a routing loop.

--
John Renwick                          Agere Systems
Software Technical Manager            1230 Northland Drive
Phone: (651) 675-2986                 Mendota Heights, MN 55120
FAX:   (707) 897-7928                 Cell:  (612) 669-9397
mailto:[email-masked]             http://www.agere.com

> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Amir Hermelin
> Sent: Wednesday, July 03, 2002 5:12 PM
> To: Hummel Heinrich; [email-masked]
> Subject: RE: Loop Detection
> 
> 
> my 2 cents:
> * Yes, such a tool would be very nice. Although, a small portion 
> of our salaries is due to the fact that routing loops are so scary ;-)
> * The approaches would be different for types of protocols. In 
> IGPs, assuming correct implementations, the protocol takes care 
> of loop possibilities as long as the lspdb is in sync. When its 
> not due to transient states, a tool wouldn't help since you'd 
> have to run it constantly for every router's view.
> * I agree that detecting BGP mis-configuration is hard. As for 
> MPLS, there are methods that are more susceptible to loops than 
> others (e.g. one implementation of TE-shortcuts can lead to loops 
> even in a seemingly correct configuration, due to metric values).

---

From: Jing Shen <[email-masked]>
Date: Thu, 11 Jul 2002 09:34:04 +0800

Why do you think MPLS is more susceptible to loop than other technology? 
As I think, LSP is set up by signalling along the path computed by edge
router or
following the items of routing tables. That is, if we just set up 
LSPs according to routing table of IGP or EGP, the occurance of loop
will be
the same level of  traditional routing. 

To detect loop in network, I think it's nearly impossible for a node to
detect
loops on some directions if it could not track routing tables at real
time. But,
if CR-LDP is used to set up transmission tunnel in networks, the problem
may 
be overcomed at the stage of setup.

-- 
Jing Shen

Email: [email-masked]

**********************************************************************
* The SunShine of life is made up of very little beams which is      *
*  bright all the time                                               *
**********************************************************************