Subject: AW: Differentiated Routing, not only plain rambo-SPF

From: Hummel Heinrich <[email-masked]>
Date: Tue, 23 Jul 2002 15:19:09 +0200

Hi all debaters,
Thanks for this echo on my initial email yesterday evening, European time.
May I conclude that there is indeed a lot of interest in DiffRout  (if nsis exists as a WG, but
depends on Differentiated Routing (DiffRout), then we should have a diffrout WG, too:-)

Certainly, the basic idea of DiffRout is to use the DSCP-Bits, or even all 8 TOS-bits, for addressing different
Routing Tables for looking up the next hop link (you can as well have one common Routing Table but search for the right entry while using destination address AND DSCP as search keys - this is up to the programmer).
 
The big question however is, what shall the Routing Tables, inside of multiple routers and accessed by the same DSCP, represent?
My thinking is, they should implement a particular (logical) road system - next to other road systems on top of a given
physical network infrastructure.

Some of these road systems may have overlapping links. Some of them
must not have overlapping links. Some may serve different users or different services. Let me indulge in  analogies:

A road system for pedestrians comprises side-walks, sky-walks, streets, country roads, state roads, but not highways and express ways.
A road systems for cars comprises streets, country roads, state roads, highways, express ways, conditionally toll roads, but definitively no side walks and no sky walks (only in Hollywood movies).
A road system towards downtown might also have an associated overflow road system, which is a generalized form of a detour.
And even the overflow road system may have its overflow road system...
You see, some road system may even be defined based on/dependent on the existence of other road systems.

Traffic towards downtown using DSCP X may, at the rim of downtown, be redirected, by also changing DSCP X to DSCP X-overflow, if momentarily and locally available traffic load measurement data do advise so.  

We may consider a couple of  overflow road systems whereby, e.g. the forth one, is determined by disregarding the roads of the first three road systems. These four road systems may be used alternatively so that traffic is well balanced, i.e. so that overflow situations will not occur in the first place.And yet all packets of any given micro flow would use one of these four DSCPs, so that they would all take the same route.

Or consider a road system (=detour route)which is  just a single route tunnel from one road system to the other. And if a detour route between San Francisco and L.A. is associated with DSCP=5, no one would bother if another detour route road system between N.Y. and Baltimore were associated with the same DSCP=5.

We may even allocate bandwidth to some road system (and/or to its center )and may determine its links based on 
sufficiently available bandwidth (road system admission control !).

Also: If we LOCK e.g.the pedestrian traffic onto/into one road system we keep this traffic off the other road system
(and vice versa).

In summary: this is the way I look at it. And the goal should be  to develop solutions which implements such road systems:-)
What is your opinion?

Heinrich

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Fred Baker <[email-masked]>
Date: Tue, 23 Jul 2002 10:24:27 -0700

At 03:19 PM 7/23/2002 +0200, Hummel Heinrich wrote:
>The big question however is, what shall the Routing Tables, inside of 
>multiple routers and accessed by the same DSCP, represent?

no. The big question is "what problem are you trying to solve?" If it is a 
lack of roads/circuits/channels in IP routing, I'm not convinced that is a 
problem.

---

From: Fred Baker <[email-masked]>
Date: Tue, 23 Jul 2002 10:24:27 -0700