Subject: Re: fast protocol hellos

From: Curtis Villamizar <[email-masked]>
Date: Fri, 01 Nov 2002 01:11:42 -0500

In message <[email-masked]>, 
"Naidu, Venkata" writes:
> Curtis,
> 
> -> Note that a slow reciever can consider the dead interval to 
> -> be longer.
> -> The sender is only indicating that it can send regularly at 
> -> the higher
> -> interval.
> -> 
> -> It still might be worth having a "slower please" message to indicate
> -> that while the sender can put out one packet per microsecond the
> -> receiver would have trouble processing the load and it would do no
> -> good to send faster than some specified rate.
> 
>   To be frank, I don't think adding messages to do *flow control* is
>   necessary. Keep the protocol simple and fast - as simple as
>   as to implement in line cards.

I didn't mean flow control.  What I meant was a one time message
indicating a maximum rate (minimum Dead Interval) that the receiver
can (is willing to) tolerate.

>   If we keep adding such messages for *binary on/off flow control*
>   mechanisms then some "state machine" is also required. How much
>   slow is slow to the receiver ? All such questions require
>   some statistical data (as TCP guys did over years).

Agreed.  Lets not do that.

>   Though your suggestion solves some issues, possibly, unnecessary
>   packet loss of hellos if the senders rate is higher than
>   receiver's processing speed, but I don't think that solve
>   any practical problems in practical networks (apart from corner
>   cases).
> 
>   Comments are welcome. Thanks You.
> 
> --
> Venkata.

I think you misunderstood what I was suggesting.

Curtis
_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Curtis Villamizar <[email-masked]>
Date: Fri, 01 Nov 2002 01:11:42 -0500

Curtis