Subject: Multicast IP address

From: suman sabbani <[email-masked]>
Date: Sat, 30 Nov 2002 13:57:58 -0500 (EST)

Hi Guys,
        I have this application which needs to run using a multicast IP
address and I have no clue to how to figure out what is the multicast IP
address of my computer(if at all if it has one). My application does not
run if I use a random multicast address(class-D address). All I need to
know is how to setup (or find out) the static multicast IP address for
(of) my computer so that I can run my application using that
address.Thanks for patiently looking at my mail.

Suman

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Jeff Parker <[email-masked]>
Date: Thu, 12 Dec 2002 09:59:35 -0500

> Hi Guys,
>         I have this application which needs to run using a 
> multicast IP address and I have no clue to how to figure 
> out what is the multicast IP address of my computer 
> 
> Suman

Suman -
	It's doesn't have a multicast address to call it's own.
I'm not really sure if your application has picked one, or if 
you get to pick one.  

	Check out Ethereal (ethereal.com) for a free-ware sniffer
that you may be able to use to see what your application is 
sending, if it is sending anything.  You might also have
access to tcpdump, which can display the same info. 

	Check out Steven's "Unix Network Programming" for a 
description of how to bind a multicast socket.  Rusty 
Harold's book "Java Network Programming" discusses how to
do this in Java, which may be a lower bar to entry.

- jeff parker

---

From: Jeff Parker <[email-masked]>
Date: Thu, 12 Dec 2002 09:59:35 -0500

Suman -

- jeff parker