Subject: RE: IPv6 site-locals... end of story...

From: "Manfredi, Albert E" <[email-masked]>
Date: Mon, 24 Mar 2003 13:12:31 -0500

Tony Li wrote:

> Yes, obviously the architecture SHOULD be able to support NAT,
> and it clearly does.  However, we do NOT have to actively
> support NAT, especially when support of NAT eliminates the
> only true need for v6.

Tony,

You said a mouthful in that last sentence. Too bad IPv6 couldn't have been simply an application of (perhaps) NSAP Addresses to IPv4.

I'm still not clear why a well-defined private address space is considered useless with IPv6. If I use the global address space in a private network, or worse in many private networks that I configured identically, and somehow one or more of these gets inadvertently connected to the Internet, wouldn't it be easier to have a well-defined address space that all routers would by default NOT route?

The argument that 128-bit addresses are enough for everyone does not preclude the point that these addresses must still be unique. Perhaps I'm missing the whole story, since I wasn't at the meeting.

Bert
_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Brian Haberman <[email-masked]>
Date: Mon, 24 Mar 2003 13:34:08 -0500

Manfredi, Albert E wrote:
> Tony Li wrote:
> 
> 
>> Yes, obviously the architecture SHOULD be able to support NAT, and
>> it clearly does.  However, we do NOT have to actively support NAT,
>> especially when support of NAT eliminates the only true need for
>> v6.
> 
> 
> Tony,
> 
> You said a mouthful in that last sentence. Too bad IPv6 couldn't have
> been simply an application of (perhaps) NSAP Addresses to IPv4.
> 
> I'm still not clear why a well-defined private address space is
> considered useless with IPv6. If I use the global address space in a
> private network, or worse in many private networks that I configured
> identically, and somehow one or more of these gets inadvertently
> connected to the Internet, wouldn't it be easier to have a
> well-defined address space that all routers would by default NOT
> route?
> 
> The argument that 128-bit addresses are enough for everyone does not
> preclude the point that these addresses must still be unique. Perhaps
> I'm missing the whole story, since I wasn't at the meeting.

I think we have jumped the gun here a little bit.  The tentative
consensus in the IPv6 WG meeting was to "deprecate" site local
addresses.  First, that consensus needs to be verified on the mailing
list.  Second, there was no agreement on what deprecation would entail.
The FEC0:: address range could still be retained for completely
disconnected networks.

I think we will have a better understanding once the addressing
architecture doc is updated and a site-local Informational/BCP
draft is written.

Regards,
Brian

---

From: Brian Haberman <[email-masked]>
Date: Mon, 24 Mar 2003 13:34:08 -0500

Regards,
Brian