Subject: RE: IPv6 site-locals... end of story...

From: "Manfredi, Albert E" <[email-masked]>
Date: Tue, 25 Mar 2003 12:08:02 -0500

Eliot Lear wrote:

> Manfredi, Albert E wrote:
> 
> > And I don't think that IPv6, by design, should make it mandatory
> > for every private network to obtain globally unique addresses from
> > the IANA. That's sort of obnoxious.
> 
> I would point out that (a) nobody suggested that addresses be gotten 
> from IANA, and (b) globally unique addressses WERE the norm 
> prior to the 
> addressing shortage that precipitated RFC 1597.

But, Eliot, things have evolved in the past decade. Internet Protocols are now being used for more than just e-mail and web browsing. So tools provided in IPv4 have been adapted quite nicely to solve problems for which they may not have been intended originally. We shouldn't have to ignore these perfectly legitimate solutions. I think enough people have expressed this general sentiment that perhaps it shouldn't be swept aside.

> Also, the methods of peer-to-peer you mentioned involve a server. 
> That's not peer to peer.  Think telephones with IP addresses when you 
> think about peer to peer.

Yes, I'm well aware of what constitutes a peer-peer network. The mention of a server was an aside. I meant only to express that one _can_ easily implement a server with a NAT in the circuit.

Bert
_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Eliot Lear <[email-masked]>
Date: Tue, 25 Mar 2003 09:35:01 -0800

Bert,

What you describe as tools I would call coping mechanisms.  On the other 
hand, if you like what you have now, why bother moving to IPv6?

Eliot

---

From: Eliot Lear <[email-masked]>
Date: Tue, 25 Mar 2003 09:35:01 -0800

Bert,

Eliot