Subject: RE: IPv6 site-locals... end of story...

From: "Manfredi, Albert E" <[email-masked]>
Date: Mon, 24 Mar 2003 17:43:18 -0500

Tony Li wrote:

> 1) If the site is not connected, then use any number space to begin
> with.  When the site connects, renumber.

Sure enough. However, it is far safer to provide an *obviously* private address to something that must be renumbered, instead of configuring this device (or network) with addresses that appear globally unique already. (Has this thing already been renumbered?)

> 2) If the site is connected, then the real benefit out of site
> local addressing is to support NAT.  NAT is not necessary so you
> don't need an address space to support it.

Sure it is.

Take the case of IP being used in specific control systems. In factory control systems, for example, or in individual platforms. Often, these would be peer-peer networks, where DHCP might not be the answer.

The systems are preconfigured, at the factory, pre-tested, and all look alike. They are pumped out by the hundreds.

When they are installed, wherever that might be, they can then be connected to the Internet or local intranet. The most trouble-free way of doing this could very well be to install edge routers that provide the NAT function. This is *not* to economize on address space. It is to facilitate the manufacture and installation, and maintenance (customer support), of entire IP-based systems.

Bert
_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 24 Mar 2003 21:25:44 -0500

In message <[email-masked]>
, "Manfredi, Albert E" writes:
> Sure enough. However, it is far safer to provide an *obviously* private addre
> ss to something that must be renumbered, instead of configuring this device (
> or network) with addresses that appear globally unique already. (Has this thi
> ng already been renumbered?)
> 
> Take the case of IP being used in specific control systems. In factory contro
> l systems, for example, or in individual platforms. Often, these would be pee
> r-peer networks, where DHCP might not be the answer.
> 

Kinda like small routers and it takes all of about a minute to
initially configure them when they arive in the field, most of which
is unpacking the box and the boot up time.  So what's your point.

We installed a thousand or so when I was at an ISP and we had machine
generated configs.  The boxes got shipped to us, a tech hand entered
about 3 lines of config, enough for the box to be identified (and
secure), and the full config was loaded, then the box got shipped to
the field and installed by even less skilled techs.

> When they are installed, wherever that might be, they can then be connected t
> o the Internet or local intranet. The most trouble-free way of doing this cou
> ld very well be to install edge routers that provide the NAT function. This i
> s *not* to economize on address space. It is to facilitate the manufacture an
> d installation, and maintenance (customer support), of entire IP-based system
> s.

NATs very much get in the way of peer-to-peer in case you weren't
aware of that.  Try running any kind of server behind a NAT and
accessing it from outside the NAT.  If two factory widgets are behind
the same NAT they need unique addresses and you're back to DHCP or
configured addresses.

At any time during this process do SNMP communities and default
passwords or any sort of encryption keys get changed or do they all
stay at the factory settings too?

> Bert

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 24 Mar 2003 21:25:44 -0500

Curtis