Subject: Software upgradation time

From: "Karthikeyan Subramaniam" <[email-masked]>
Date: 29 May 2003 06:54:08 -0000

Hi,

    I have doubt about restart timer value in protocols.

In OSPF default restart timer is specified as 120 seconds in the 
draft
"draft-ietf-ospf-hitless-restart-07.txt" and in the case of BGP 
default
restart timer should not be greater than the HOLDTIME(suggested 
value as
per RFC 1771 is 90 secs)carried in OPEN.

Can control software  be upgraded within 120/90 seconds? On what 
basis
this timer value has been fixed?

with regards,
S.Karthikeyan.

___________________________________________________
Get www. mycompany .com and 5 matching email ids.
Just Rs. 1499/ year.
Click here http://www.rediffmailpro.com

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Acee Lindem <[email-masked]>
Date: Thu, 29 May 2003 06:25:44 -0400

Karthikeyan Subramaniam wrote:
> In OSPF default restart timer is specified as 120 seconds in the draft
> "draft-ietf-ospf-hitless-restart-07.txt" and in the case of BGP default
> restart timer should not be greater than the HOLDTIME(suggested value as
> Can control software  be upgraded within 120/90 seconds?

I guess that depends on your implementation and the type of upgrade. If
your software is modular it is certainly enough time for an incremental
upgrade or a switchover to a redundant control processor.

> On what basis

This was thought to be an upper bound on restart time, redistribution, and
synchronization with other protocols. The restart should complete much sooner.
Note the timer value is configurable.

-- 
Acee

---

From: Acee Lindem <[email-masked]>
Date: Thu, 29 May 2003 06:25:44 -0400

-- 
Acee