Subject: RE: CODE:BELLMAN FORD

From: "Tony Li" <[email-masked]>
Date: Tue, 20 May 2003 16:36:36 -0700

Homework is only educational if you do it.

Tony

|    -----Original Message-----
|    From: [email-masked] [mailto:[email-masked]] 
|    Sent: Friday, May 16, 2003 1:37 AM
|    To: [email-masked]
|    Cc: [email-masked]
|    Subject: CODE:BELLMAN FORD
|    
|    
|    Hi,
|     
|     I need a code for Bellman Ford algorithm.It could be in any 
|    language.
|    My question is:
|    Write a program which generates a network with controllable 
|    number of nodes N.The easiest way 2 do this is to start with 
|    a rectangle with sides X and Y.Use a pair of random numbers rx
|    (n) and ry(n) to set coordianates of point, n at X rx(n) and 
|    Y ry(n).Allow n to cover the range 1 to N.ur program must 
|    decide whether a link exists between every pair of nodes.This 
|    can be done based on distance between them. It could be 
|    decided that a link exists if the distance between 2 nodes is 
|    less than a certain distance.
|    Extend the program so that it simulates operation of BGP for 
|    1 node at a time.Start the program with a fixed set of link 
|    costs perhaps unity.Set N=10.Now change value of 1 link only 
|    and allow program 2 run until all routing tables r 
|    stable.Measure time taken 2 reach stability.Repeat this test 
|    100 times & find average time 2 reach stability.Repeat this 
|    with N=32,100,316,1000.Present results graphically showing 
|    settling time vs number of nodes.
|    I request you 2 send me this solution by 20 May to 
|    [email-masked]
|    Thanks a lot.I would appreciate ur favour very much.
|    Robin.
|    
|    _______________________________________________
|    routing-discussion mailing list
|    [email-masked]
|    https://www1.ietf.org/mailman/listinfo/routing-discussion
|    
_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: guStaVo ZaeRa <[email-masked]>
Date: Tue, 20 May 2003 16:46:57 -0700 (PDT)

i love this, and i definitely agree.  figure it out on your own, that's how you 
learn..

gustavo

On Tue, 20 May 2003, Tony Li wrote:

| 
| 
| Homework is only educational if you do it.
| 
| Tony
| 
| 
| |    -----Original Message-----
| |    From: [email-masked] [mailto:[email-masked]] 
| |    Sent: Friday, May 16, 2003 1:37 AM
| |    To: [email-masked]
| |    Cc: [email-masked]
| |    Subject: CODE:BELLMAN FORD
| |    
| |    
| |    Hi,
| |     
| |     I need a code for Bellman Ford algorithm.It could be in any 
| |    language.
| |    My question is:
| |    Write a program which generates a network with controllable 
| |    number of nodes N.The easiest way 2 do this is to start with 
| |    a rectangle with sides X and Y.Use a pair of random numbers rx
| |    (n) and ry(n) to set coordianates of point, n at X rx(n) and 
| |    Y ry(n).Allow n to cover the range 1 to N.ur program must 
| |    decide whether a link exists between every pair of nodes.This 
| |    can be done based on distance between them. It could be 
| |    decided that a link exists if the distance between 2 nodes is 
| |    less than a certain distance.
| |    Extend the program so that it simulates operation of BGP for 
| |    1 node at a time.Start the program with a fixed set of link 
| |    costs perhaps unity.Set N=10.Now change value of 1 link only 
| |    and allow program 2 run until all routing tables r 
| |    stable.Measure time taken 2 reach stability.Repeat this test 
| |    100 times & find average time 2 reach stability.Repeat this 
| |    with N=32,100,316,1000.Present results graphically showing 
| |    settling time vs number of nodes.
| |    I request you 2 send me this solution by 20 May to 
| |    [email-masked]
| |    Thanks a lot.I would appreciate ur favour very much.
| |    Robin.
| |    
| |    _______________________________________________
| |    routing-discussion mailing list
| |    [email-masked]
| |    https://www1.ietf.org/mailman/listinfo/routing-discussion
| |    
| _______________________________________________
| routing-discussion mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/routing-discussion
| 

-- 

. g u s t a v o   z a e r a .

"My goal is to make any information
  available from anywhere,
    at anytime."