Subject: Bellman-Ford's Shortest Path algorithm

From: Sudip Misra <[email-masked]>
Date: Thu, 8 May 2003 21:58:23 -0400 (EDT)

Hi,

Does anyone have the implementation of Bellman-Ford's
shortest path algorithm or an analogous algorithm.

I am sure someone out there must have already done it
already. 

I would be thankful, if someone can share his/her code
with me. 

Thanks,

Sudip

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca
_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 08 May 2003 23:42:20 -0400

In message <[email-masked]>, Sudip Misra wr
> I am sure someone out there must have already done it

No.  Never been implemented.  Try the IRTF.

[Just kidding.]

> I would be thankful, if someone can share his/her code

There is a complete implementation of the OSPF protocol in John Moy's
book with the CD.  Also the gated code, zebra, probably lots of other
sources.  These are likely to be optimized Dykstra rather than
Bellman-Ford.  Plus Bellman-Ford, Dykstra, or optimized Dykstra is
trivial to write yourself.  Read Moy's book please.

btw - Do you think you could shotgun your question to a few thousand
more people?  Routing-discuss is specifically for the work of the IETF
routing area and NOT for newbie questions about routing!  That also
means that you probably shouldn't bother with a thank you or followup
questions like "what's Dykstra" or "does anyone know the ISBN number".

Curtis

ps - appologies to the lists for keeping you on the Cc.  Better one
reply than many.

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 08 May 2003 23:42:20 -0400

[Just kidding.]

Curtis

---

From: [email-masked]
Date: Fri, 9 May 2003 10:31:38 +0200

Hi,

you can find some on the web :

http://www.people.virginia.edu/~ec3z/software.html

one in excel :

http://www.cs.uwyo.edu/~duden/spring2002/cs3020/lab9/

one in java :

http://rollerjm.free.fr/pro/graphs.html

kr,
sebastien.

-----Original Message-----
From: Sudip Misra [mailto:[email-masked]]
Sent: vendredi 9 mai 2003 3:58
To: [email-masked]; [email-masked]; [email-masked]
Subject: [MPLS-OPS]: Bellman-Ford's Shortest Path algorithm

Hi,

Thanks,

Sudip

-------
The MPLS-OPS Mailing List
Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---

From: [email-masked]
Date: Fri, 9 May 2003 10:31:38 +0200

Hi,

one in excel :

one in java :

kr,
sebastien.

-----Original Message-----
From: Sudip Misra [mailto:[email-masked]]
Sent: vendredi 9 mai 2003 3:58
To: [email-masked]; [email-masked]; [email-masked]
Subject: [MPLS-OPS]: Bellman-Ford's Shortest Path algorithm

Hi,

Thanks,

Sudip

-------

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 23 May 2003 14:09:44 +0200

Curtis Villamizar wrote:
> questions like "what's Dykstra"

What's Dykstra?  Is it something like Dijkstra?  What does Dijk stand 
for?  Is it because there are many dikes in Holland?

Alex
GBU

---

From: Curtis Villamizar <[email-masked]>
Date: Fri, 23 May 2003 09:07:20 -0400

> for?  Is it because there are many dikes in Holland?

Thanks for the spelling correction.

Curtis