Subject: bgp router id

From: Tulip Rasputin <[email-masked]>
Date: Wed, 26 Nov 2003 20:23:18 -0500 (EST)

Hi,

I noticed a BGP behaviour and just wanted to confirm if it is indeed an anormal thing to happen. I
am not using a loopback IP address nor have I configured a BGP router ID. It thus picks up the
highest IP address available as its Router ID for all the BGP session that it establishes. Now
when this interface goes down it picks up the next highest IP address that is available and uses
it for all subsequent peerings.

Isnt this odd? A single router using 2 different router IDs with two different peers?

I know this is wrong. Either this router should continue with the same old router ID (even though
the interface it not there .. but that hardly matters!) that it had or it should select a new
router ID, break off connections with all the previous peers (very expensive!) and establish new
connections with peers using this new Router ID.

I think it should be the former one. And when it finds that it has no more BGP speakers in FSM
state > OpenConfirm it can update use the new Router ID for all subsequent peerings.

WOuld like to hear your opinion,

Tulip

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: "Tony Li" <[email-masked]>
Date: Wed, 26 Nov 2003 20:31:17 -0800

a) Since this is a BGP question, it truly belongs on the IDR list.
b) Since the router ID is used to resolve the opening of the connection,
   it does NOT matter which address the router uses as long as it is
   globally unique.  Using an RFC 1918 address would be... unfortunate.

Tony

|  -----Original Message-----
|  From: Tulip Rasputin [mailto:[email-masked]] 
|  Sent: Wednesday, November 26, 2003 5:23 PM
|  To: [email-masked]
|  Subject: bgp router id
|  
|  
|  Hi,
|  
|  I noticed a BGP behaviour and just wanted to confirm if it 
|  is indeed an anormal thing to happen. I
|  am not using a loopback IP address nor have I configured a 
|  BGP router ID. It thus picks up the
|  highest IP address available as its Router ID for all the 
|  BGP session that it establishes. Now
|  when this interface goes down it picks up the next highest 
|  IP address that is available and uses
|  it for all subsequent peerings.
|  
|  Isnt this odd? A single router using 2 different router IDs 
|  with two different peers?
|  
|  I know this is wrong. Either this router should continue 
|  with the same old router ID (even though
|  the interface it not there .. but that hardly matters!) that 
|  it had or it should select a new
|  router ID, break off connections with all the previous peers 
|  (very expensive!) and establish new
|  connections with peers using this new Router ID.
|  
|  I think it should be the former one. And when it finds that 
|  it has no more BGP speakers in FSM
|  state > OpenConfirm it can update use the new Router ID for 
|  all subsequent peerings.
|  
|  WOuld like to hear your opinion,
|  
|  Tulip
|  
|  
|  
|  _____________________________________________________________
|  _________ 
|  Post your free ad now! http://personals.yahoo.ca
|  
|  _______________________________________________
|  routing-discussion mailing list
|  [email-masked]
|  https://www1.ietf.org/mailman/listinfo/routing-discussion
|