Subject: Re: WG Review: Transparent Interconnection of Lots of Links (tril l)

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Mon, 20 Jun 2005 17:42:59 -0400

Hi,

A few points:

This has been presented to IEEE 802 in the form of a tutorial session at the March 2005 IEEE 802 plenary meeting.

In my opinion it is extremely unlikely that 802.1 will have anything to do with routing. They are dedicated to the Spanning Tree Protocol and minor variations thereof.

It is true that the deadline for submission of proposals to 802.11 TGs (Mesh Networking) was last week. I would expect some of the 15 proposals that were received to include some forms of "routing on MAC addresses". However, the charter for 802.11 TGs is fairly narrow, mainly targeting radio meshes of 32 APs or less. Whatever form of network path selection is adopted by 802.11 TGs is likely to be specialized.

Furthermore, in my opinion IEEE 802 does not have as much routing expertise as the IETF and IEEE 802 would be unlikely to include any IP optimizations in its standards.

So it does not appear to me that any group in IEEE 802 will do what the proposed TRILL Charter covers and "having the IEEE do it" is not an available option.

Donald (Chair of 802.11 TGs but just speaking for myself)

--------------------------------------------------------------------------------
Sue,

Please allow me to be a bit more direct...

What part of this should be in the IETF?  The IESG has made it quite
clear that they do not want a turf battle with the IEEE.

There seems like a clear separation of layers here and this is still L2
work.  As such, it would seem consistent for this should go over to
IEEE, even if it is  borrowing heavily from IETF technology.

Tony

Susan Hares wrote:
> Eric and Tony:
> 
> See my comments about Wireless Mesh proposal an Wi-Mesh alliance I'm a
> part of submitted 6/15/05 to the 802.11s.
> 
> Radia or others may know more about 802.1 since they have more history
> with IEEE.
> 
> Sue
> ------------------------------------------------------------------------
> 
> *From:* Eric W Gray [mailto:ewgray2k at netscape.net]
> *Sent:* Monday, June 20, 2005 2:45 PM
> *To:* Tony Li
> *Cc:* Susan Hares; Alex Zinin; rtg-dir at ietf.org;
> routing-discussion at ietf.org; rtg-chairs at ietf.org
> *Subject:* Re: WG Review: Transparent Interconnection of Lots of Links
> (trill)
> 
> Tony,
> 
>     No disagreement from me.  Perhaps the next obvious question is - has
> anyone taken this to the
> IEEE?
> --
> Eric
> Tony Li wrote:
> 
> In other instances, when proposals were IEEE'ish, we were directed to
> take them to the IEEE.
> 
> Tony
> 
> 
> Eric W Gray wrote:
> 
>>Sue,
>>
>>    The trouble with obvious questions is that everybody assumes they've
>>been  asked already.
>>Now this question has been asked at least once, for sure.  :-)
>>
>>    From the charter attached in Alex's previous message, the purpose is
>>to "route" Ethernet
>>Frames. Quote:
>>
>>The TRILL WG will design a solution for shortest-path frame routing in
>>multi-hop IEEE 802.1 Ethernet networks with arbitrary topologies,
>>using the link-state routing protocol technology.
>>
>>Since it is clear that at least some people are not satisfied with the
>>802.1 approach (perhaps
>>because of the relative inefficiency associated with completely unused
>>high capacity links), I
>>assume you mean to ask "why is it not IEEE" - rather than "why is it not
>>802.1".
>>
>>    I believe that is a very good question.  I know of no very good
>>reason why the IEEE might
>>not specify how to use an OSPF-like routing protocol to fulfill the role
>>previously handled by
>>Spanning Tree Protocol. Perhaps the only reason why it is being
>>discussed here is that it might
>>be better - for implementers - if the protocol used was more than
>>"OSPF-like."
>>--
>>
>>Eric
>>
>>shares at nexthop.com <mailto:shares at nexthop.com> wrote:
>>    
>>>Why are we doing this?  Is it IP or is it Frames?
>>>If it is Frames, why is it not 802.1 - etc? 
>>>
>>>Sue Hares
>>>
>>>-----Original Message-----
>>>
>>>From: Alex Zinin [mailto:zinin at psg.com] 
>>>Sent: Thursday, June 16, 2005 10:00 PM
>>>To: routing-discussion at ietf.org <mailto:routing-discussion at ietf.org>
>>>Cc: rtg-dir at ietf.org <mailto:rtg-dir at ietf.org>; rtg-chairs at ietf.org <mailto:rtg-chairs at ietf.org>
>>>Subject: Fwd: WG Review: Transparent Interconnection of Lots of Links (trill)
>>>
>>>Since the second BOF on this topic was inconclusive regarding community
>>>support, the IESG is reevaluating the community consensus on whether a WG
>>>should be formed or not.
>>>
>>>If you have input on this, positive or negative, please send it to
>>>iesg at ietf.org <mailto:iesg at ietf.org>.

_______________________________________________
routing-discussion mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/routing-discussion

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Mon, 20 Jun 2005 18:08:51 -0400

Some of this seems like semantics to me, though. The purpose of
replacing the existing RSTP with a more OSPF-like algorithm is not to
introduce IP optimization into 802.1, but rather to make 802.1 more
efficient than it currently is with RSTP.

I see such a new protocol as a functional replacement for the L2 RSTP,
not anything more. Specifically, dense L2 mesh nets today are very fault
tolerant, but also very wasteful of installed bandwidth. I don't think
we're talking about "routing," in the sense of going beyond L2
boundaries, correct? Just replacing one "node interconnection algorithm"
with another one.

Viewed as a next iteration beyond the new RSTP, which was introduced in
IEEE 802.1D-2004, that work by all rights belongs in the IEEE, I think.
Sue Hares is right, I think. If this new work involves only MAC frames,
it belongs in the IEEE and not IETF.

Bert

> From: Eastlake III Donald-LDE008 
> [mailto:[email-masked]] 
> Sent: Monday, June 20, 2005 4:43 PM
> To: [email-masked]'
> Subject: Re: WG Review: Transparent Interconnection of Lots 
> of Links (tril l)
> 
> Hi,
> 
> A few points:
> 
> This has been presented to IEEE 802 in the form of a tutorial 
> session at the March 2005 IEEE 802 plenary meeting.
> 
> In my opinion it is extremely unlikely that 802.1 will have 
> anything to do with routing. They are dedicated to the 
> Spanning Tree Protocol and minor variations thereof.
> 
> It is true that the deadline for submission of proposals to 
> 802.11 TGs (Mesh Networking) was last week. I would expect 
> some of the 15 proposals that were received to include some 
> forms of "routing on MAC addresses". However, the charter for 
> 802.11 TGs is fairly narrow, mainly targeting radio meshes of 
> 32 APs or less. Whatever form of network path selection is 
> adopted by 802.11 TGs is likely to be specialized.
> 
> Furthermore, in my opinion IEEE 802 does not have as much 
> routing expertise as the IETF and IEEE 802 would be unlikely 
> to include any IP optimizations in its standards.
> 
> So it does not appear to me that any group in IEEE 802 will 
> do what the proposed TRILL Charter covers and "having the 
> IEEE do it" is not an available option.
>