Subject: RE: [RPSEC] Draft Status, from a protocol developer's angle.

From: "Michel Py" <[email-masked]>
Date: Sun, 28 Jul 2002 13:36:13 -0700

Michael / Charlie

>> Michel Py wrote:
>> If an attacker flows you with 3 gbit of useless packets that
>> require an auth check, it effectively denies half of the
>> traffic that uses auth checks, as the flow of auth checks
>> would be 4 gbit (1 legit and 3  attacker); out of these 4,
>> half of it would be dropped by the 2 gbit rate-limit, which
>> includes half of the legit 1 gbit.

> Michael Richardson wrote:
> Unfortunately, your analysis, while correct, is far too simple
> if you assume IPsec with symmetric keys.

You are the one making the assumption; I meant to stay generic and only
mentioned "auth checks".

Michael and Charlie, I think the discussion you are having about the
crypto-DoS issue is premature, because it is too focused or too
specific, see below.

Michael, I agree that this problem, in order to be solved, needs to
solve the trust model first.

However, you are making two assumptions that I don't.

1. You assume that a suitable trust model will be found, which remains
to be seen.
2. You assume that the trust model that will be found will allow the use
of symmetric keys, which is even more hypothetical.

In other words, it might end up that the trust model will call for
public/private keys, we just don't know this yet, and I am uncomfortable
being the one that brought the issue on the table because I think this
level of detail about a protocol under development is not of interest
for the WG as a whole.

Michel.

_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

---

From: Michael Richardson <[email-masked]>
Date: Sun, 28 Jul 2002 17:29:58 -0400

-----BEGIN PGP SIGNED MESSAGE-----

>>>>> "Michel" == Michel Py <[email-masked]> writes:
    Michel> You are the one making the assumption; I meant to stay generic and only
    Michel> mentioned "auth checks".

    Michel> Michael and Charlie, I think the discussion you are having about the
    Michel> crypto-DoS issue is premature, because it is too focused or too
    Michel> specific, see below.

    Michel> Michael, I agree that this problem, in order to be solved, needs to
    Michel> solve the trust model first.

    Michel> However, you are making two assumptions that I don't.

    Michel> 1. You assume that a suitable trust model will be found, which remains
    Michel> to be seen.
    Michel> 2. You assume that the trust model that will be found will allow the use
    Michel> of symmetric keys, which is even more hypothetical.
  
  Back to rpsec. Re-reading the charter.

  There are two kinds of threats:
	- transport threats	"make sure it gets there okay"
	- content threats	"make sure we aren't talking to a crazy"

  I believe that transport threats are well understood, and well addressed by
IPsec. The biggest problem is that pre-shared secrets for authenticating IKE
do not scale, yet are the only "easy" method. PK authentication is not
available on most routers without the *I*, which is overkill.

===

  I believe that we need to strongly look at authenticating who may speak for
what network blocks.  The threats here -- particularly due to misconfiguration
rather than malice -- are very real.

]    Internet Security. Have encryption, will travel           |1 Fish/2 Fish [
]  Michael Richardson, Sandelman Software Works, Ottawa, ON    |Red F./Blow F [
][email-masked] http://www.sandelman.ottawa.on.ca/ |strong crypto [
]    At the far end of some dark fiber - wait that's dirt!     |for everyone  [

---

From: Charles Lynn <[email-masked]>
Date: Sun, 28 Jul 2002 22:29:41 -0400 (EDT)

>   I believe that we need to strongly look at authenticating who may
> speak for what network blocks.  The threats here -- particularly due
> to misconfiguration rather than malice -- are very real.

Yes, we must do that.

Charlie