Subject: RE: [RPSEC] Draft Status....

From: Gregory Lebovitz <[email-masked]>
Date: Tue, 23 Jul 2002 18:18:53 -0700

>-----Original Message-----
>From: Alex Zinin [mailto:[email-masked]]
>Sent: Monday, July 22, 2002 8:01 PM
>To: Brian Haberman
>Cc: [email-masked]; [email-masked]; [email-masked]
>Subject: Re: [RPSEC] Draft Status....
>
>
>--snip--
>
>>> I'm not sure that we should try to come up with threat models for
>>> each different type in each way of assigning types - too much work.
>
>> We just need to look at the different protocols to see if the threat
>> model varies.
>
>right, as well as make sure that the model we come up with is
>descriptive enough to cover at least the existing RPs and those
>under development.

[gregory] Maybe we should start with creating the list of RPs that we care
to consider. There are many RPs out there, but the deployment and use may
not justify the effort of consideration here. An example that comes to mind
(hope I'm not stomping anyone's baby here) is DVMPR, which just simply is
not widely used or deployed these days.

[gregory]Here is a list to start, and is intentionally NOT comprehensive, so
please chime in with agreement/disagreement:
==v4==
- OSPF
- BGP
- IS-IS
- PIM-SM
- RIP
==v6==
- RIPng
- OSPFv3
- BGP

> Alex

_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

_______________________________________________
RPSEC mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rpsec

---

From: Brian Haberman <[email-masked]>
Date: Wed, 24 Jul 2002 08:24:28 -0400

> please chime in with agreement/disagreement:

PIM-SM supports IPv6 as well.  I would not include DVMRP and MOSPF gets
carried along with OSPF.

Brian

---

From: Brian Haberman <[email-masked]>
Date: Wed, 24 Jul 2002 12:02:23 -0400

> PIM-SM supports IPv6 as well.  I would not include DVMRP and MOSPF gets

I just had one more thought.  Should MSDP be included in this list?

Brian

---

From: "David G. Boney" <[email-masked]>
Date: Wed, 24 Jul 2002 21:11:33 -0400

Brian Haberman wrote:

Brian Haberman wrote:

Gregory Lebovitz wrote:

Brian

I would suggest that MPLS/GMPLS be included in this list. There is a high
degree of overlap in the functions of switching and routing. I think security
of the control plane is the issue.

--

Sincerely,

David G. Boney

Graduate Research Assistant

Department of Electrical and Computer Engineering

The George Washington University

Phillips Hall, Suite 607

801 22nd Street, N.W.

Washington, DC 20052

http://student.seas.gwu.edu/~dboney

mailto:[email-masked]

Department Phone (202) 994-6083

Department Fax (202) 994-0227

---

From: Alex Zinin <[email-masked]>
Date: Wed, 24 Jul 2002 18:30:59 -0700

Tuesday, July 23, 2002, 6:18:53 PM, Gregory Lebovitz wrote:
> to consider.
...

Might be a good idea. Note, however, that we should not use this list
to have different models for each, but rather to make sure that the
model we produce includes classifications that cover at least the
existing protocols. The way one could do this is by identifying
the subsystems within each protocol and classifying them. This will
let us collect multiple examples of each class of subsystem.

Alex

---

From: Alex Zinin <[email-masked]>
Date: Wed, 24 Jul 2002 18:34:33 -0700

Brian,

> PIM-SM supports IPv6 as well.

What about DM?

> I would not include DVMRP

Doesn't hurt looking at it from the classification
perspective.

> and MOSPF gets

Hmmm... yes and no. Some subsystems do, some don't.
E.g., transport, neighbors, adjacencies, DB maintenance
are shared, but routing and forwarding state creation
are different from OSPF.

Alex

---

From: Alex Zinin <[email-masked]>
Date: Wed, 24 Jul 2002 18:47:55 -0700

David,

Please disable HTML, we have people with non-html clients

> of the control plane is the issue.

<AD>

 You have to be more specific, which part of MPLS you mean.
 If IGP extensions for TE, then we're essentially talking about
 extended topology info in IGPs and I have no problem with this,
 if signalling or VPNs, then no--let's walk first.

</AD>

Alex

---

From: Brian Haberman <[email-masked]>
Date: Thu, 25 Jul 2002 08:51:54 -0400

Alex,

> > PIM-SM supports IPv6 as well.

draft-ietf-pim-dm-new-v2-01.txt was revised to include IPv6 as well.

> Doesn't hurt looking at it from the classification

I suppose not.  My feeling though is that it may be wasted effort.

> are shared, but routing and forwarding state creation

Do you envision type 6 LSAs being protected differently than other
LSAs?

Brian

---

From: Alex Zinin <[email-masked]>
Date: Fri, 26 Jul 2002 22:19:47 -0700

Brian,

> I suppose not.  My feeling though is that it may be wasted effort.

Don't get too deep into it, just look if there's anything
sufficiently different from other protocols in it that would
be interesting for security analysis--you never know what
you'll see tomorrow.

> Do you envision type 6 LSAs being protected differently than other

No, but I do envision the difference between the amount of state
and CPU calculation performed by OSPF and MOSPF (their state
calculation models are different) depending on the number of new
groups per sec that MOSPF has to deal with. Since exhaustion of
CPU and memory is a threat, I would think there's a sufficient
difference here. Note that I'm not saying the protocols are completely
different, but that there are differences in their vulnerabilities.

Thanks.
Alex