Subject: [rrg] Next topic: properties of identifiers

From: Toni Stoev <[email-masked]>
Date: Mon, 20 Apr 2009 16:04:27 +0300

Now

The Domain Name System identifies a node by its fully qualified domain name, which:
- is topology‐independent;
- is stable, and has a defined lifetime;
- is unambiguous;
- is distinguishable (two for same object);
- has hierarchical structure;
- is generated, distributed, managed.

But domain names are meaningful to humans, and therefore are network eccentric.

On the other hand, Internet Protocol addresses are easily issuable, because they consist of numbers.

So let us take a numeric fully qualified identifier.
The innermost part is a number of a node, and any previous numbers denote authorities that have issued sublevel numbers.

We put a news that the identified sublevel knows locator of its parent. So acquaintance is mutual, and bidirectionally is to be used.

Toni

---

From: Xu Xiaohu <[email-masked]>
Date: Tue, 21 Apr 2009 09:46:52 +0800

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Toni Stoev
> 发送时间: 2009年4月20日 21:04
> 收件人: IRTF RRG
> 主题: [rrg] Next topic: properties of identifiers
> 
> Now
> 
> On the other hand, Internet Protocol addresses are easily 
> issuable, because they consist of numbers.
> 
> The innermost part is a number of a node, and any previous 
> numbers denote authorities that have issued sublevel numbers.

Sound interesting. By the way, taken the following items mentioned by Tony
in his previous email together into account,  the identifiers should have
the same length as IPv6 address (or IPv4 address) and be capable of
asserting ownership.

- facilitate session‐level referrals
- stable, at discretion of owner

Xiaohu

> We put a news that the identified sublevel knows locator of 
> its parent. So acquaintance is mutual, and bidirectionally is 
> to be used.
> 
> Toni
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>