Subject: [rrg] Numeric fully qualified identifier

From: Toni Stoev <[email-masked]>
Date: Wed, 22 Apr 2009 02:42:32 +0300

Summary

I am offering a solution for identifier.

The solution is a numeric-only variation of FQDN with mutual locator cognition between adjacent levels.
Innermost level numbers can be negotiated instead of assigned.

Let us first see conformance of this solution, and then consider any inherited restrictions.

---

From: Toni Stoev <[email-masked]>
Date: Thu, 23 Apr 2009 16:54:08 +0300

Bi-directional numerical DNS

Let us imagine a simple numeric fully qualified identifier:

p.n

where p and n are positive integers.
p is the number of a provider issuing node numbers,
n is the number of a node, issued by that provider.

The role of p.n is to identify the specified node on the general network.
Usage of this identifier for connection initiation I like to call inicast:

Knowing identifier p.n we are heading for the node it identifies.
Luckily, we've got our own identifier p.o with the same provider p.
So, we send initial packet for p.n to p, we know p's locator.
p knows locator of p.n and relays the packet that way.
Duly, p.n receives the packet with our locator. Ready to communicate directly.

This longest prefix match is also applied in cases with different providers and/or more levels.
To know current locators, adjacent levels keep each other informed about any changes.

On Wednesday 22 April 2009 02:42:32 Toni Stoev sent:
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>