Subject: Re: [rrg] Locator: routing scalability

From: [email-masked]
Date: Thu, 14 May 2009 15:10:18 EDT

In einer eMail vom 14.05.2009 10:31:34 Westeuropäische Normalzeit schreibt  
[email-masked]:

So  locator may name node. And node may be host/router.

Being confident  routing researchers, let us go on for the routing 
scalability.

Please  answer the following question:
Does locator have to facilitate routing with  its structure?
My answer is: yes, it  must.

Toni

I have the same answer.
Yes it must.
With strategy C such that by 90 % a single table-offset (i.e. as by the  
locator) retrieves the next hop.
Note: GPS is state of the art. We don't live in the 1980s anymore.
 
Heiner

---

From: Toni Stoev <[email-masked]>
Date: Fri, 15 May 2009 05:03:14 +0300

> locator) retrieves the next hop.

The next hop is a neighbor node. What is the easiest case to retrieve it from locator? Locator containing it.
So here's next question I have the pleasure to ask our attentive peers:
Must locator structure show explicit topology/reachability/routability?

My answer: Let me listen before speak.

Toni

---

From: Toni Stoev <[email-masked]>
Date: Mon, 18 May 2009 22:57:27 +0300

> My answer: Let me listen before speak.

My opinion is that locator must contain next hops along a path from a root router to a node within a routing domain. Thus locator will be a safe way for a packet en route to its destination, within locator's routing domain.
And especially, being quite relevant to topology, locator will natively provide intra-domain routing scalability.
Furthermore, locator being an intra-domain asset, locator quantity growth will be clearly decoupled from inter-domain routing.

Consider,
Toni Stoev

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 18 May 2009 16:26:24 -0700

There hasn't been much new here in the way of proposals lately,
so I thought I'd take a moment to announce "RANGER Scenarios"
and its precursor "RANGER":

http://tools.ietf.org/html/draft-russert-rangers
http://tools.ietf.org/html/draft-templin-ranger

RANGERS picks up where RANGER left off; it not only completes
the architectural framework, but also highlights the myriad
use cases for which the architecture applies. It cannot really
be claimed that this work is "new" (far from it!), but in our
experience RANGER(S) is the only proposal with a consistent
architectural framework that applies recursively in a
"network-of-networks" fashion from the global Internet core
all the way outward to even the simplest of edge networks.
Indeed, the limiting factor for recursion is a singleton node
and its associated devices. 

Please take a moment to review the proposal and send comments.
Tony and Lixia - can we have this work added to the wiki page
as an active rrg proposal?

Thanks - Fred
[email-masked]