Subject: Re: [rrg] Inter/intra-domain routing separation

From: [email-masked]
Date: Thu, 7 May 2009 05:03:26 EDT

Toni,
An important question is: what means "routable" ? Is an address routable  
because it is "summarizable" ? Most IETF-folks think so, whereas I do not.  
IMHO, neither a HIT, nor an IPv4/6 address nor an AS number is routable.  
Well,wrt these, just IPv4/6 unicast addresses are summarizable. Your  proposal 
tends towards  E.164 (enum inverse :-), right ?
 
Heiner

In einer eMail vom 07.05.2009 04:40:32 Westeuropäische Normalzeit schreibt  
[email-masked]:

Robert,  Xiaohu, thanks for commenting.

To be clear, I use the term "autonomous  system" in the sense of "routing 
domain", considering both  interchangeable.

On Wednesday 6 May 2009 02:35:52 Toni Stoev  sent:
> How can locator have default association with its containing  autonomous 
system?
> Easy. Autonomous system number shall be  incorporated into locator. 
Universally recognizable locator shall start with  it.
> 
> On Tuesday 5 May 2009 12:35:41 Toni Stoev sent:
>  > Intra-domain routing can be considered as a general solution. This  
general solution is the provision of reachability throughout an autonomous  
system.
> > Node locators can be considered intra-domain locators.  Every locator 
shall have default association with its containing autonomous  system in 
order to be universally recognizable.
> > Utilizing these  approaches inter-domain routing can be separated from 
intra-domain routing.  Inter-domain routing shall be based on autonomous 
system paths and not on IP  addresses and prefixes. Thus inter-domain routing 
tables will be substantially  unloaded and more easily managed.
> > This will provide significant  improvement to inter-domain routing 
scalability.
> >  _______________________________________________
> > rrg mailing  list
> > [email-masked]
> >  http://www.irtf.org/mailman/listinfo/rrg
> >
>  _______________________________________________
> rrg mailing  list
> [email-masked]
>  http://www.irtf.org/mailman/listinfo/rrg
>
_______________________________________________
rrg  mailing  list
[email-masked]
http://www.irtf.org/mailman/listinfo/rrg

---

From: Scott Brim <[email-masked]>
Date: Thu, 07 May 2009 07:48:01 -0400

[email-masked] allegedly wrote on 05 07 2009 5:03 AM:
> because it is "summarizable" ? Most IETF-folks think so, whereas I do
> not. IMHO, neither a HIT, nor an IPv4/6 address nor an AS number is
> routable. Well,wrt these, just IPv4/6 unicast addresses are
> summarizable. Your proposal tends towards  E.164 (enum inverse :-), right ?

Anything that names a point of attachment to the network is "routable".
   "Routable" just means that information about its topological location
can be propagated and used by forwarding.  The reason we say that
location naming has to follow topology is for aggregation.

---

From: Toni Stoev <[email-masked]>
Date: Fri, 8 May 2009 13:19:15 +0300

Scott Brim wrote:
> The reason we say that

In my not humble opinion, location naming has to follow reachability.
So having location we know how to reach.