Subject: Re: [rrg] Aggregatable EIDs

From: [email-masked]
Date: Sun, 27 Dec 2009 08:39:31 EST

In einer eMail vom 26.12.2009 20:34:56 Westeuropäische Normalzeit schreibt  
[email-masked]:

This  argument fails for exactly the same reason that geographically
based BGP  aggregation fails.

Brian, who has ever done it ? Why do you say this and what do you mean by  
saying this ?
It must be something quite different from what I  understand.  

This thread "Aggregatable EIDs" is concerned about aggregating EIDs and the 
 problems with mapping the prefixes to RLOCs. This objective wouldn't even  
exist if both EID and RLOC-ID are  asigned a "third" information (I  
proposed it not long ago) which itself is universally routable and  which wouldn't 
need any authoritative provisioner either. No need for  aggregating any two 
EIDs! No need for mapping any EID-IP-address to any  RLOC-IP-address 
provided that they share a common attribute that is derived from  geographical 
coordinates.
 
By sticking to  non-routable identifiers none of the 14 solutions  becomes 
any better than LISP. 
Note, not only IPv4 / IPv6 addresses are non-routable, AS  numbers aren't 
either. 
 
With 99 % of the hosts being mobile, wouldn't it be appropriate to have  
mainly provider-independent FQDNs  
and a DNS that is fairly up-to-date with the correlation between a  
respective HIT and the current location, i.e. completely independent of the  
current AS? 
 
The geographic coordinates would be the only non-mobile data in a  world of 
mobile hosts, mobile routers and fast changed  providers
 
Heiner

---

From: Xu Xiaohu <[email-masked]>
Date: Mon, 28 Dec 2009 09:17:41 +0800

_____  

发件人: [email-masked] [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2009年12月27日 21:40
收件人: [email-masked]; [email-masked]
抄送: [email-masked]
主题: Re: [rrg] Aggregatable EIDs

In einer eMail vom 26.12.2009 20:34:56 Westeuropäische Normalzeit schreibt [email-masked]:

Brian, who has ever done it ? Why do you say this and what do you mean by saying this ?

 

This thread "Aggregatable EIDs" is concerned about aggregating EIDs and the problems with mapping the prefixes to RLOCs. This objective wouldn't even exist if both EID and RLOC-ID are  asigned a "third" information (I proposed it not long ago) which itself is universally routable and which wouldn't need any authoritative provisioner either. No need for aggregating any two EIDs! No need for mapping any EID-IP-address to any RLOC-IP-address provided that they share a common attribute that is derived from geographical coordinates.

By sticking to  non-routable identifiers none of the 14 solutions becomes any better than LISP. 

Note, not only IPv4 / IPv6 addresses are non-routable, AS numbers aren't either. 

With 99 % of the hosts being mobile, wouldn't it be appropriate to have mainly provider-independent FQDNs  

and a DNS that is fairly up-to-date with the correlation between a respective HIT and the current location, i.e. completely independent of the current AS? 

Since the HIT is already a provider-independent host identifier, why should each host be assigned with a FQDN as another provider-independent ID? Taken the current cell-phone mobile network as an example, does every cell-phone need a FQDN-like global name besides the cell-phone number itself?

Xiaohu

The geographic coordinates would be the only non-mobile data in a world of mobile hosts, mobile routers and fast changed providers

Heiner

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 28 Dec 2009 16:43:15 +1300

Hi,

On 2009-12-28 14:17, Xu Xiaohu wrote:
...
> Brian, who has ever done it ? 

Nobody, as far as I know.

> Why do you say this and what do you mean by saying this ?

There have been a lot of geo-based or metro-based proposals over
the years. Most recently, draft-hain-ipv6-geo-addr.
As far as I know, none of them has ever been deployed, because
this isn't how Internet economics works. There is no financial
incentive to deploy geographically based exchange points which also
act as address delegators to customers. (Note, there is no technical
argument against it. But nobody knows how to make money out of it.)

By the way, I don't consider HRA locators to be geo-based. They
are fundmentally PA locators. The geographic part is secondary.
In RANGI, you don't mention any geo component of the locators.

But this was all a side comment. What I meant is that the problem
of mapping PI identifiers to PA locators is just the same as
mapping geo addresses to topological addresses. I don't see any
evidence that the mapping can be significantly more compact
than if the identifiers are assigned randomly. Wei Zhang seemed
to argue that by some special assignment scheme for identfiers,
we can get a significantly smaller map. I would like to see
the data supporting that.

> This thread "Aggregatable EIDs" is concerned about aggregating EIDs and the problems with mapping the prefixes to RLOCs. This objective wouldn't even exist if both EID and RLOC-ID are  asigned a "t…

My point is that aggregation of EIDs is basically artificial.

> By sticking to  non-routable identifiers none of the 14 solutions becomes any better than LISP. 

At some level they are probably all isomorphic, yes. Except maybe ILNP.

> Note, not only IPv4 / IPv6 addresses are non-routable, AS numbers aren't either. 

But there are about 10 times fewer active AS numbers than there are active
prefixes. So flat-routing on AS numbers would gain one order of magnitude
immediately.

> With 99 % of the hosts being mobile, wouldn't it be appropriate to have mainly provider-independent FQDNs  

Well, yes, which is why Christian Vogt's proposal for name-based
sockets is very interesting. But actually it only hides the problem
in the socket layer; the problem doesn't go away.

> and a DNS that is fairly up-to-date with the correlation between a respective HIT and the current location, i.e. completely independent of the current AS? 

If the locator is PA, sure. But that's the problem - making the locator PA.

> Since the HIT is already a provider-independent host identifier, why should each host be assigned with a FQDN as another provider-independent ID? Taken the current cell-phone mobile network as an e…

Well, until people drop the stupidity of reverse DNS lookup as a "security check"
it's very hard to drop this. Of course it's bogus. (Do you really care
that my FQDN right now is 121.98.142-??.bitstream.orcon.net.nz?)

    Brian

---

From: [email-masked]
Date: Mon, 28 Dec 2009 02:02:58 -0500

> argument against it. But nobody knows how to make money out of it.)

I'm curious. Has anyone ever fully/clearly articulated the *reasons*  
behind the absence of financial incentive to embrace addressing and  
routing solutions that would create (actually, to restore) a binding  
association between addressing and geography -- or better yet, made a  
positive argument for the financial incentives and broader economic  
factors that often recommend deploying networks in aggressively  
geography-indifferent patterns?

I tend to think that the reasons are so obvious as to be self-evident,  
but I'd be quite surprised to find that everyone's list of self- 
evident reasons is identical.

Can anyone point me to some approximation of an "authoritative list"  
of reasons? If not, does anyone see any merit (or problem) in the idea  
of compiling such a list?

Thanks in advance,

TV

>> This thread "Aggregatable EIDs" is concerned about aggregating EIDs  
>> and the problems with mapping the prefixes to RLOCs. This objective  
>> wouldn't even exist if both EID and RLOC-ID are  asigned a "third"  
>> information (I proposed it not long ago) which itself is  
>> universally routable and which wouldn't need any authoritative  
>> provisioner either. No need for aggregating any two EIDs! No need  
>> for mapping any EID-IP-address to any RLOC-IP-address provided that  
>> they share a common attribute that is derived from geographical  
>> coordinates.
>
>> respective HIT and the current location, i.e. completely  
>> independent of the current AS?
>
>> Since the HIT is already a provider-independent host identifier,  
>> why should each host be assigned with a FQDN as another provider- 
>> independent ID? Taken the current cell-phone mobile network as an  
>> example, does every cell-phone need a FQDN-like global name besides  
>> the cell-phone number itself?
>
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg

---

From: Peter Sherbin <[email-masked]>
Date: Mon, 28 Dec 2009 08:31:16 -0800 (PST)

> I tend to think that the reasons are so obvious...

Precisely. To function smoothly the Internet requires a set of access points patterned in and around planet's surface, atmo- / aquasphere and crust (pick the "proper" density of AP/sq.km). Keep in mind that any end system can connect seamlessly (wired or wireless) to any access point. The model suggests that an individual ISP supports a certain part of AP grid with no control whatsoever over end systems. No single ISP seems to be excited about such a model.

Thanks,

Peter

--- On Mon, 12/28/09, [email-masked] <[email-masked]> wrote:

> From: [email-masked] <[email-masked]>
> Subject: Re: [rrg] Aggregatable EIDs
> To: "RRG" <[email-masked]>
> Date: Monday, December 28, 2009, 2:02 AM
> 
> I'm curious. Has anyone ever fully/clearly articulated the
> *reasons* behind the absence of financial incentive to
> embrace addressing and routing solutions that would create
> (actually, to restore) a binding association between
> addressing and geography -- or better yet, made a positive
> argument for the financial incentives and broader economic
> factors that often recommend deploying networks in
> aggressively geography-indifferent patterns?
> 
> I tend to think that the reasons are so obvious as to be
> self-evident, but I'd be quite surprised to find that
> everyone's list of self-evident reasons is identical.
> 
> Can anyone point me to some approximation of an
> "authoritative list" of reasons? If not, does anyone see any
> merit (or problem) in the idea of compiling such a list?
> 
> Thanks in advance,
> 
> TV
> 
> >> This thread "Aggregatable EIDs" is concerned about
> aggregating EIDs and the problems with mapping the prefixes
> to RLOCs. This objective wouldn't even exist if both EID and
> RLOC-ID are  asigned a "third" information (I proposed
> it not long ago) which itself is universally routable and
> which wouldn't need any authoritative provisioner either. No
> need for aggregating any two EIDs! No need for mapping any
> EID-IP-address to any RLOC-IP-address provided that they
> share a common attribute that is derived from geographical
> coordinates.
> > 
> >> By sticking to  non-routable identifiers none
> of the 14 solutions becomes any better than LISP.
> > 
> >> With 99 % of the hosts being mobile, wouldn't it
> be appropriate to have mainly provider-independent FQDNs
> > 
> >> and a DNS that is fairly up-to-date with the
> correlation between a respective HIT and the current
> location, i.e. completely independent of the current AS?
> > 
> >> Since the HIT is already a provider-independent
> host identifier, why should each host be assigned with a
> FQDN as another provider-independent ID? Taken the current
> cell-phone mobile network as an example, does every
> cell-phone need a FQDN-like global name besides the
> cell-phone number itself?
> >

---

From: [email-masked]
Date: Mon, 28 Dec 2009 12:38:19 -0500

Hi Peter,

I suspect that there may have been a miscommunication. I actually  
meant that the economic factors that motivate non-geographic  
addressing and network deployment are so obvious as to be self-evident.

Regardless, thanks very much for the reaction...

TV

On Dec 28, 2009, at 11:31 AM, Peter Sherbin wrote:

> Precisely. To function smoothly the Internet requires a set of  
> access points patterned in and around planet's surface, atmo- /  
> aquasphere and crust (pick the "proper" density of AP/sq.km). Keep  
> in mind that any end system can connect seamlessly (wired or  
> wireless) to any access point. The model suggests that an individual  
> ISP supports a certain part of AP grid with no control whatsoever  
> over end systems. No single ISP seems to be excited about such a  
> model.
>
> Thanks,
>
> Peter
>

---

From: Xu Xiaohu <[email-masked]>
Date: Tue, 29 Dec 2009 11:15:25 +0800

> -----邮件原件-----
> 发件人: Brian E Carpenter [mailto:[email-masked]]
> 发送时间: 2009年12月28日 11:43
> 收件人: Xu Xiaohu
> 抄送: [email-masked]; [email-masked]

Yes, your observation is correct. No matter in the HRA or in its successor
RANGI, The locators are fundmentally PA locators. The initial intention of
embedding some geographical info into HRA locators was to realize
location-awareness based services, e.g., achieving P2P traffic localization
by allowing hosts to obtain information from the nearest ones of all
available peers.

> problems with mapping the prefixes to RLOCs. This objective wouldn't even
exist
> if both EID and RLOC-ID are  asigned a "third" information (I proposed it
not
> long ago) which itself is universally routable and which wouldn't need any
> authoritative provisioner either. No need for aggregating any two EIDs! No
need
> for mapping any EID-IP-address to any RLOC-IP-address provided that they
share
> a common attribute that is derived from geographical coordinates.
> 
mainly
> provider-independent FQDNs
> 
respective
> HIT and the current location, i.e. completely independent of the current
AS?
> > Since the HIT is already a provider-independent host identifier, why
should
> each host be assigned with a FQDN as another provider-independent ID?
Taken
> the current cell-phone mobile network as an example, does every cell-phone
need
> a FQDN-like global name besides the cell-phone number itself?
> 

Your FQDN example seems much similar to the RANGI host identifier, the
leftmost part of which is administrative domain (AD) ID, while the remaining
part is a hash value of the public key and the AD ID. The AD ID is
delegation-oriented aggregatable. The major difference is that the AD ID
itself is in fixed length, rather than variable length.

Xiaohu