Subject: [rrg] Summary of Tuneled Inter-domain Routing (TIDR)

From: Juan Jose Adan <[email-masked]>
Date: Tue, 22 Dec 2009 22:48:35 +0100

Hi Lixia:

Here is the summary of Tunneled Inter-domain Routing (TIDR).

Merry Christmas.

Juanjo

PROPOSAL
--------

Tunneled Inter-domain Routing (TIDR)

KEY IDEA
--------
Provides a method for locator-identifier separation using tunnels between
routers
of the edge of the Internet transit infrastructure. It enrichs BGP protocol
for
distributing the identifier-to-locator mapping. Using new BGP atributes
"identifier
prefixes" are assigned interdomain routing locators so that they will not be
installed in the RIB and will be moved to a new table called Tunnel
Information Base
(TIB). Afterwards, when routing a packet to the "identifier prefix", the TIB
will be
searched first to perform tunnel imposition, and secondly the RIB for actual
routing.
After the edge router performs tunnel imposition, all routers in the middle
will
route this packet until the router being the tail-end of the tunnel.

GAINS
-----
- Smooth deployment
- Size Reduction of the Global RIB Table
- Deterministic Customer Traffic Engineering for Incoming Traffic
- Numerous Forwarding Decisions for a Particular Address Prefix
- TIDR Stops AS Number Space Depletion
- Improved BGP Convergence
- Protection of the Inter-domain Routing Infrastructure
- Easy Separation of Control Traffic and Transit Traffic
- Different Layer-2 Protocol-IDs for Transit and Non-Transit Traffic
- Multihoming Resilience
- New Address Families and Tunneling Techniques
- TIDR for IPv4 or IPv6, and Migration to IPv6
- Scalability, Stability and Reliability
- Faster Inter-domain Routing

COSTS
-----
- Routers of the edge of the interdomain infrastructure will need to be
 upgraded
to hold the mapping database (i.e. the TIB)

- "Mapping updates" will need to be treated differently from usual BGP
"routing updates"

DOCUMENTATION
-------------
The draft I submitted to the IETF is located on:
http://tools.ietf.org/html/draft-adan-idr-tidr-01

Here there are some other links that add more information:

--> on scalability of the global BGP table and reducing BGP churn
http://www.ietf.org/mail-archive/web/ram/current/msg01308.html
[RAM] TIDR using the IDENTIFIERS attribute (19-April-2007)

--> on the different role of transit and non-transit ASes
http://www.ops.ietf.org/lists/rrg/2007/msg00902.html
[RRG] LISP etc architecture  (20-Sept-2007)

--> on AS-based routing with very fine granularity
http://www.ops.ietf.org/lists/rrg/2008/msg00716.html
[RRG] yetAnotherProposal: AS-number forwarding  (11-March-2008)

---

From: Tony Li <[email-masked]>
Date: Wed, 23 Dec 2009 16:38:36 -0800

Received and incorporated.

Tony

Juan Jose Adan wrote:
> Provides a method for locator-identifier separation using tunnels 
> between routers
> of the edge of the Internet transit infrastructure. It enrichs BGP 
> protocol for
> (TIB). Afterwards, when routing a packet to the "identifier prefix", the 
> TIB will be
> searched first to perform tunnel imposition, and secondly the RIB for 
> actual routing.
> After the edge router performs tunnel imposition, all routers in the 
> middle will
> - Routers of the edge of the interdomain infrastructure will need to 
> be upgraded
> ------------------------------------------------------------------------
> 
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg