Subject: [rrg] internet economics

From: [email-masked]
Date: Mon, 11 Jan 2010 13:10:25 EST

Both Bill and Darrel used to argue against my concept of geo-location  
rather than prefix-based routing by stressing the "internet  economics". 
In compliance with the distance-vector paradigm, internet  
economics/policies like "who is allowed to use my ISP network" are soustained  implicitly: 
it is up to whether or not a particular prefix is communicated to  the 
respective next-ISP. Admitted, my non-DV-based concept does not provide this  
implicitly.
 
However, and see the email-excerpt below from the  LISP-ml:  LISP cannot 
provide it either !!!
 
Heiner

 

Subject: Re: [lisp] Design discussion -06-(3) -> returnalloverlapping prefixes
From: Florin Coras <[email-masked]>
To: Luigi Iannone <[email-masked]>
Cc: Noel Chiappa <[email-masked]>, [email-masked]
Date: Mon, 11 Jan 2010 11:34:28 +0100
List-Id: List for the discussion of the Locator/ID Separation Protocol <lisp.ietf.org>

Hello Luigi,

Luigi Iannone wrote:
> Hi Noel,
>
> On Jan 7, 2010, at 17:24 , Noel Chiappa wrote:
>
> [snip]
>
>   
>> As to LISP, ITRs could refuse to forward traffic from sources they are not
>> supposed to handle, but the problem is 'how do they know what sources they
>> are supposed to be handling'?
>>     
>
> Can't they just check the lisp database? 
>
>   
>> If they are also an ETR, they know,
>>     
>
> Isn't the contrary? Current spec do not mandate a mapping for the source address of a packet in the ETR (unless it is also an ITR and there is bidirectional traffic).
>
> If the ETR has a mapping for the source address in its cache, then it do some sanity checks and eventually drop the packet.
>
> .. or am I wrong somewhere?
>
>
>   

I might be the one confused but isn't Noel speaking here about some sort
of uRPF? Meaning the ITR should not forward packets from within its
domain if the source EID of the packet is not from the domains
EID-prefix. But the boxes that are simple ITRs don't know the domain's
EID-prefix, only the ETRs know it (they use it in registrations at
Map-Servers).

.. or maybe I'm wrong :)

Florin

> Luigi
>
>   
>> but the
>> design does allow of exit-only (i.e. ITR-only) boxes; handling those would
>> mean more configuration (bad).
>>
>>  Noel
>> _______________________________________________
>> lisp mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/lisp
>>     
>
>   

_______________________________________________
lisp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lisp

---

From: Eliot Lear <[email-masked]>
Date: Mon, 11 Jan 2010 19:43:32 +0100

Heiner,

While your subject line piques my interest, there is not enough context
either in the original message you are quoting or in your responding
text below for me to understand what you are claiming.  I would suggest
that you more formally lay out your point of view.

Regards,

Eliot

On 1/11/10 7:10 PM, [email-masked] wrote:
> economics/policies like "who is allowed to use my ISP network" are
> soustained implicitly: it is up to whether or not a particular prefix
> is communicated to the respective next-ISP. Admitted, my non-DV-based
> concept does not provide this implicitly.
>  
> However, and see the email-excerpt below from the LISP-ml:  LISP
> cannot provide it either !!!
>  
> Heiner
>  
>  
>  
>  
>  
>  
>  
>  
>
>
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg
>