Subject: [rrg] TARA draft, successfully expired

From: [email-masked]
Date: Tue, 22 Mar 2011 05:21:38 -0400

Last year Ireceived an email from Joel Halpern by which he proclaimed TARA does not work,PAR FORCE, unless I submitted a draft. Well, so  I did submit draft-hummel-tara-00.txt which has now successfullyexpired. During its lifetime I received no single comment which showed thatTARA does not work. Hence, I like to add: TARA works par force. 
 
Myself I doknow that TARA works as sure as a²+b²=c² according to Pythagoras, because Iknow that all my algorithms work. 
 
In the pastI also was told that the TARA objectives are not persuasive enough:
Neither theelimination of the scalability problem (getting rid of prefix building,stopping reachability info dissemination, stopping collecting paths (needing noRIBs), nor the increased speed (1 table offset for getting the next hop – bothfor the best next hop as well as any temporary alternative), nor the improvedrouting capabilities (by providing 100 % orientation such that endless loopswill  be safely disabled even whiledetouring via more remote routers), nor the new capabilities like well-scoped broadcast, state-less multicast, northe way to make distributed denial-of-service attacks ineffective, nor theenabling of well scoped traffic load notifications towards the upstreamsurrounding, nor its help to make the IPv4 address depletion a non-issue, etc.etc. 
 
Over thelast eight years I have tried many times to fan discussions about the IETFrouting paradigms themselves which I consider to be the true causes for a) thescalability problem and b) for having a such under-performing network layerthat only “try-and-see” driven efforts like shim6, conex, rtgwg,… do/can evolvebased on them.  In vain: all attemptswere blocked by common silence, either due to lack of arguments or because theyare right par force –particularly prefix building. Lixia would favour smarterprefix building, but how can something be made smarter, if it is the oppositeof smartness?
 
One lastword about Hierarchical Routing (HR): I opposed Dima Krioukov’s critics on HR’sbad stretch behavior. But he was right wrt. that kind of  HR that has no scrolling capability. HoweverTARA (just like Google’s route planner which has caught up with TARA meanwhile)does not fall under this category.
 
AproposPythagoras. He was the first man (570 B.C.) who propagated that the earth is aball. 
About 2000years passed until Christopher Columbus utilized this knowledge and sailed Westin order to get East. That was about 500 years ago. My conclusion: It will takeabout 2000 - 500 = 1500 years until the IETF will realize that this planet is a balland that Columbus-routing is a real and appropriate option. According tocurrent BGP however, this planet is as flat as a pancake and its masterpiecealgorithm won’t enable paths where, by going to more and more remote routers,you may get to some turning point from whereon you will get closer and closerto your destination. Neither today nor in 1500 years!  .
So I canonly encourage the young students to disbelieve in all these rescue attemptslike LISP or ILNP whose goal is to restore rather than to reform.
 
Heiner

---

From: Toni Stoev <[email-masked]>
Date: Tue, 22 Mar 2011 11:45:04 +0200

Heiner, how does TARA relate to interplanetary communication?