Subject: Re: [rrg] Rebooting the RRG

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 4 Feb 2014 11:02:12 +0000

Hi,

so it looks like the effort to reboot the RRG has fizzled out, since we didn't manage to get critical mass for a meeting in London. That's not a good sign.

I'm happy to have a conversation on the list or face-to-face in London about the future of the group; at the moment, my inclination is to close it in the near future, since we seem to have run out of steam.

Lars

---

From: Scott Brim <[email-masked]>
Date: Tue, 4 Feb 2014 11:30:07 -0500

> I'm happy to have a conversation on the list or face-to-face in London about the future of the group; at the moment, my inclination is to close it in the near future, since we seem to have run out…

Getting together informally in London would be great, because by
sitting down together, even if it's only a few of us, we may generate
enough energy and focus to do something in IRTF. I believe RRG needs
to be complementary with the IETF, and what that would mean to RRG
isn't obvious right now.  So I would be delighted if you could set up
a face-to-face.

Please don't kill the mailing list. It doesn't hurt anyone, and having
it around will make it easier to have ad hoc discussions. You can
declare the RRG suspended (it is :-)) but I don't see the point in
expunging it.

Thanks ... Scott

---

From: "Osterweil, Eric" <[email-masked]>
Date: Tue, 4 Feb 2014 16:50:01 +0000

> isn't obvious right now.  So I would be delighted if you could set up

+1

> declare the RRG suspended (it is :-)) but I don't see the point in

+1

Eric

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 4 Feb 2014 16:52:31 +0000

Hi,

On 2014-2-4, at 17:30, Scott Brim <[email-masked]> wrote:
> enough energy and focus to do something in IRTF.

I'd be happy to get anyone wanting to make this happen a room for a side meeting; or just pick a pub and announce the time.

Lars

---

From: Matthias Wübbeling <[email-masked]>
Date: Tue, 04 Feb 2014 18:59:32 +0100

Hi list,

i'm rather new to the rrg mailing list and the first thread i've to
follow is "rebooting the rrg". I didn't know and hardly can believe,
that there is currently no ongoing research regarding routing issues.
But that's what the discussion looks like.

As a phd student at University of Bonn (it-security group) i'm
currently working in the field of BGP inter-AS routing anomalies and
the evaluation and classification of these.

I'm interested in the past and future work of the rrg and i'll try to
attend the meeting in london, if i'm able to convince my boss of the
necessity of it and get it paid :)

Unfortunately i can't present results at the very next meeting because
they are not yet made up.

You, as rrg veterans should keep it alive and find young researchers
to support it now and in the future.

Thanks for your time.

Kind regards,

Matthias

On 04.02.2014 17:52, Eggert, Lars wrote:
>> sitting down together, even if it's only a few of us, we may
>> generate enough energy and focus to do something in IRTF.
> 
> I'd be happy to get anyone wanting to make this happen a room for a
> side meeting; or just pick a pub and announce the time.
> 
> Lars

---

From: Sampo Syreeni <[email-masked]>
Date: Tue, 4 Feb 2014 20:00:02 +0200 (EET)

>> declare the RRG suspended (it is :-)) but I don't see the point in

-1. In the sense that stale lists really *can* hurt the normal IETF 
process. It's not for nothing that they are kept to a minimum.

At the same time, even as the kind of lurker that I am, it'd be sad to 
see the list go, especially when there's so much research level routing 
stuff out there. Starting with my two favourites, which are content/name 
based routing as a fundamental primitive, and how to model+push the data 
from current overlays into the primary routing fabric.
-- 
Sampo Syreeni, aka decoy - [email-masked], http://decoy.iki.fi/front
+358-40-3255353, 025E D175 ABE5 027C 9494 EEB0 E090 8BA9 0509 85C2

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 4 Feb 2014 18:35:34 +0000

Hi,

nobody is debating that there's interesting routing research being done. We even gave quite a number of ANRPs (Applied Networking Research Prizes) to routing papers, and flew the main authors to IETF meetings to present.

What we don't seem to have is a core group of RRG participants with the energy of reaching out to and bringing the research that is out there into the group, on a continuous basis. Those of you who feel that the group should stay around, please realize that you need to dedicate some of your own time towards making that happen.

Lars

---

From: Scott Brim <[email-masked]>
Date: Tue, 4 Feb 2014 14:14:53 -0500

> What we don't seem to have is a core group of RRG participants with the energy of reaching out to and bringing the research that is out there into the group, on a continuous basis. Those of you who…

I see it as a problem of utility. Researchers already have at least
one well-respected way to convene. Why would any researcher want to
push an idea through the RRG as it is now? The last time we rebooted,
it was specifically for "architectural alternatives, including, but
not limited to, separating host location and identification
information". There was a unifying mission, a plan, an end goal, all
related to IETF efforts.

RGs are often successful through being complementary to what is going
on in the IETF. I propose that we have an exploratory f2f meeting with
the goal of coming up with one or two missions at that level, truly
relevant to the IETF. We announce it widely in the routing area.
Presentations and papers would not be required but they would be
welcome. If none are offered, we meet anyway.

OK?

Scott

---

From: Michael Menth <[email-masked]>
Date: Tue, 04 Feb 2014 20:24:28 +0100

Hi,

+1

I plan to participate.

Best wishes,

    Michael

> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://kn.inf.uni-tuebingen.de

---

From: [email-masked]
Date: Tue, 4 Feb 2014 19:38:38 -0500 (EST)

Lixia excepted, I tried in vain to stimulate a discussion about the IETF's routing paradigms which I have questioned many times:

- the diffserv philosophy (the total absence of the WHERE-awareness)
- the intra-versus inter-domain distinction (Dijkstra versus distance vector)

and also about
- the absence of a MULTICAST FIB.
- the absence of a ANYCAST FIB
- the absence of (scoped) Broadcast
- the negligence of IPv4

This week the German government has been suit by the CCC because it missed/is missing to protect people against spy attacks by the US's  NSA.

With the current routing architecture and its complete absence of any WHERE-awareness there is no way to give back any country its sovereignty. 
With TARA that wouldn't be a problem: Each country would recognize "its" part of the internet (intra- and inter-domain portions alike) and could take action that within its borders packets were encrypted according to its own keys. Packets which are being sent to outside of the country would be recognized as such ones and the user might be questioned to confirm whether forwarding should be done or not - just like he is reminded  to add a subject line if missing.

Whenever an airplane crosses illegally some country, it is conceived as a violation of the respective nation's sovereignty. But spying  out  a l l   communication data is by far worse.
That crashes any nation's sovereignty. Attempts to accomplish mutual no-spy treaties show the helplessness of the German government. The right way would be  - and here is the  IETF asked to come up with results - to provide  solutions which PREVENT spy attacks as we are experiencing today in the first place!  

I know that NSA folks are as well subscribed to this list (but eventually they may have positive feeling towards Edward S. too).

I think such a security service is the most important one of all that can be based on the WHERE-awareness, much more important than to be able to redirect parts of the traffic such that they bypass some congested area to the left or to the right.

But so far no one has even tried to explain the advantages of the current architecture.

Heiner

-----Ursprüngliche Mitteilung----- 
Von: Eggert, Lars <[email-masked]>
An: IRTF Routing RG <[email-masked]>
Verschickt: Di, 4 Feb 2014 7:35 pm
Betreff: Re: [rrg] Rebooting the RRG

Hi,

nobody is debating that there's interesting routing research being done. We even 
gave quite a number of ANRPs (Applied Networking Research Prizes) to routing 
papers, and flew the main authors to IETF meetings to present.

What we don't seem to have is a core group of RRG participants with the energy 
of reaching out to and bringing the research that is out there into the group, 
on a continuous basis. Those of you who feel that the group should stay around, 
please realize that you need to dedicate some of your own time towards making 
that happen.

Lars

---

From: [email-masked]
Date: Tue, 11 Feb 2014 16:58:12 -0500 (EST)

By my last email (see below) I also addressed the need to do something against a total spay of the internet traffic by the NSA.
But there is neither interest nor doubts wrt my email, just complete silence.

Today people are demonstrating against what the NSA is doing persistently. see
http://www.sueddeutsche.de/digital/aktionstag-the-day-we-fight-back-alle-gegen-goliath-1.1884738

But what can I deduct from the silence on this list?

Does it mean that all on this list ok what the NSA is doing? 

Heiner, 
pretty disappointed 

with

-----Ursprüngliche Mitteilung----- 
Von: heinerhummel <[email-masked]>
An: rrg <[email-masked]>
Verschickt: Mi, 5 Feb 2014 1:38 am
Betreff: Re: [rrg] Rebooting the RRG

and also about

Heiner

-----Ursprüngliche Mitteilung----- 
Von: Eggert, Lars <[email-masked]>
An: IRTF Routing RG <[email-masked]>
Verschickt: Di, 4 Feb 2014 7:35 pm
Betreff: Re: [rrg] Rebooting the RRG

Hi,

Lars

---

From: "Christian Huitema" <[email-masked]>
Date: Tue, 11 Feb 2014 23:43:17 -0800

> But what can I deduct from the silence on this list?

The IETF work on pervasive monitoring and its prevention is discussed in the "perpass" mailing list: https://www.ietf.org/mailman/listinfo/perpass. Please feel free to join, participate, write drafts...

- -- Christian Huitema

---

From: [email-masked]
Date: Wed, 12 Feb 2014 03:42:01 -0500 (EST)

Thank you Christian, I have just subscribed successfully.
I do have some proposal to contribute which is not of RRG relevance.

"WHERE-awareness or not" however would be RRG relevant. But obviously, the alternative (which I like to call the DiffServ-mantra) shall prevail.
That fits to ILNP. That fits to making AS#s the leading part of IPv6 addresses. That will extend the fun with prefix building.
But no one should be wondering if IPv6 won't fly like an eagle (in spite of the IPv4 depletion issue).

Heiner

-----Ursprüngliche Mitteilung----- 
Von: Christian Huitema <[email-masked]>
An: heinerhummel <[email-masked]>; rrg <[email-masked]>
Verschickt: Mi, 12 Feb 2014 8:43 am
Betreff: RE: [rrg] Rebooting the RRG

> But what can I deduct from the silence on this list?

The IETF work on pervasive monitoring and its prevention is discussed in the 
"perpass" mailing list: https://www.ietf.org/mailman/listinfo/perpass. Please 
feel free to join, participate, write drafts...

- -- Christian Huitema