Subject: Re: [Rserpool] comments on draft-ietf-rserpool-asap-02.txt

From: Qiaobing Xie <[email-masked]>
Date: Wed, 10 Apr 2002 12:23:16 -0500

Hi, Harrie,

Thanks for your comments. Overall, the asap (as well as enrp) draft is
going to go through some major revisions (typical to all IETF protocol
deve). Therefore I am not too much concerned about some editorial
problems at this point. But I will definitely keep in mind all your
editorial suggestions when I revise the draft and try to improve on it.

Pls see my other comments in-line.

Harrie Hazewinkel wrote:
...snip....
> --- Section 1.1 Definitions
> The are already definitions in the architecture draft.
> I suggest, deleting the definitions which are duplicate.
> I also see a lot of ENRP specific definitions that I
> did not see in the enrp-draft, odd. :-))
> Some maybe needed since they are ASAP specific.

Agreed. This will be cleaned up eventually.

> 
> --- Section 3.1 ASAP Parameter Formats
> I do not see the need for including the 4 bytes that are
> representing the parameter type and length in the value
> that is placed in the parameter length.
> (Equal to ENRP).
> 
> ---
> IMHO, if the highest-order two bits specify the action
> that must be taken if the processing endpoint does
> not recognize the Parameter Type, these values should not
> be included in the TYPE. I suggest a seperation of these
> bits into a different flags field.

We've discussed both above two points in previous emails when we talked
about ENRP. In summary, I see two non-tech reasons for the current
design: 1) ease and convenience for implementors, and 2) consistency
with other protocols. Unless some one can come up some solid technical
reasons (e.g., performance, security, etc.) to show that an alternative
is better, I don't see why we should change them.

regards,
-Qiaobing

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Qiaobing Xie <[email-masked]>
Date: Wed, 10 Apr 2002 12:23:16 -0500

Hi, Harrie,

Harrie Hazewinkel wrote:
...snip....

regards,
-Qiaobing