Subject: [Rserpool] RSerPool implementations

From: "Aron Silverton"<[email-masked]>
Date: Thu, 06 Mar 2003 12:43:50 -0600

Hello all,

If you are working on an implementation of RSerPool or plan on working
on an implementation, can you please provide me a few bits of
information including:

-Who you are
-Status
-Goal
-Timeline
-Anything else you would like to add

I'll be making some remarks about the various implementation efforts at
the IETF 56 meeting in San Francisco.

Please provide your information to me by 3/12.

Thank you,

Aron

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Thomas Dreibholz <[email-masked]>
Date: Thu, 6 Mar 2003 21:24:15 +0100

> on an implementation, can you please provide me a few bits of

Thomas Dreibholz, Institute for Experimental Mathematics at the University of 
Essen, Germany

> -Status

- - ASAP implemented (except control channel)
- - nameserver (currently without ENRP)
- - example application (echo service)
- - Currently, we support Linux, FreeBSD and DarwinOS
- - Uses sctplib userland implementation of the University of Essen

> -Goal

Complete, open source, prototype implementation of the RSerPool architecture: 
the rsplib prototype.

> -Timeline

- - Soon: ASAP control channel
- - Soon: Support for kernel SCTP under FreeBSD
- - About summer 2003: Implementation of ENRP

> -Anything else you would like to add

For more information about our implementation, see 
http://tdrwww.exp-math.uni-essen.de/dreibholz/rserpool/ and 
http://www.sctp.de/rserpool.html. An introduction to design and 
implementation of our rsplib prototype is given in our paper at 
http://tdrwww.exp-math.uni-essen.de/dreibholz/rserpool/#Research. It has been 
presented by me at the Linux Conference Australia 2003.

> the IETF 56 meeting in San Francisco.

Please send me a copy of your remarks. I am very interested who else is 
implementing RSerPool.

Best regards
- -- 
=======================================================================
 Dipl.-Inform. Thomas Dreibholz
 Molbachweg 7
 D-51674 Wiehl-Forst    Mail: [email-masked]
 Germany                WWW:  http://www.exp-math.uni-essen.de/~dreibh
=======================================================================

---

From: Thomas Dreibholz <[email-masked]>
Date: Thu, 6 Mar 2003 21:24:15 +0100

Best regards
- --

---

From: "Aron Silverton"<[email-masked]>
Date: Thu, 06 Mar 2003 16:12:06 -0600

Thank you Thomas.

If others could also provide any associated URLs as Thomas did, that 
would be great.

I will send a PDF version of my summary slides to anybody that requests 
them sometime around 3/17.

Regards,

Aron

Thomas Dreibholz wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.0.6 (GNU/Linux)
> Comment: For info see http://www.gnupg.org
> 
> iD8DBQE+Z65x32BbsHYPLWURAmcRAJ0Vy8eT+sBKIiUdfxuSj+by3kfmcgCggQ3f
> aoFUZeVcv3ZNb8HoVDe/Ut8=
> =FWgK
> -----END PGP SIGNATURE-----
> 
> 

-- 
Aron J. Silverton
Senior Staff Research Engineer
Motorola Laboratories, Networks and Infrastructure Research
Motorola, Inc.

Telephone: 847-576-8747
Fax: 847-576-3240
mailto: [email-masked]

---

From: "Aron Silverton"<[email-masked]>
Date: Thu, 06 Mar 2003 16:12:06 -0600

Thank you Thomas.

Regards,

Aron

Telephone: 847-576-8747
Fax: 847-576-3240
mailto: [email-masked]