Subject: Re: [Rserpool] AD comments on draft-ietf-rserpool-overview-02

From: Magnus Westerlund <[email-masked]>
Date: Mon, 18 Feb 2008 17:25:31 +0100

Hi,

The update did resolve the first issue. I hade expected more on the 
second, but I think it is okay.

Cheers

Magnus

Magnus Westerlund skrev:
> Hi,
> 
> I have spent a few days reviewing the full set of RSERPOOL documents. So
> here is the comments in a number of different emails. A general comment
> about my comments on the full set is that some are not blocking
> publication but things I think should be fixing anyway for getting the
> document into better shape. However, many are such that I think they are
> preventing people from making interoperable implementations.
> 
> I think I have only one real comment about this document. It fails a bit
> short in being clear on the different communication flows that exist.
> This lack of clear separation of the roles is also present in the
> protocol specs that I think brings up details that belongs in other
> specifications. More about this in the protocol spec docs.
> 
> I think one should work on expanding figure 1 to be better covering the
> different elements of the solution and their flows. So a few proposals.
> 
> 1. Try to work multiple ENRP into the figure or abstract them in this
> one and add another figure that explains the relation between ENRP servers.
> 
> 2. Look at the individual communication flows.
> a. PU <-> ENRP
> b. PU <-> PE
> c. PE <-> ENRP
> d. ENRP <-> ENRP
> 
> I would focus on what is happening in the different flows. But there is
> problematic that an ENRP server uses both ASAP and ENRP depending who
> and why it communicates with someone.
> 
> Cheers
> 
> Magnus Westerlund
> 
> IETF Transport Area Director & TSVWG Chair
> ----------------------------------------------------------------------
> Multimedia Technologies, Ericsson Research EAB/TVM/M
> ----------------------------------------------------------------------
> Ericsson AB                | Phone +46 8 4048287
> Torshamsgatan 23           | Fax   +46 8 7575550
> S-164 80 Stockholm, Sweden | mailto: [email-masked]
> ----------------------------------------------------------------------
> 
> 
> _______________________________________________
> rserpool mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rserpool
> 

-- 

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Torshamsgatan 23           | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

_______________________________________________
rserpool mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/rserpool

---

From: Thomas Dreibholz <[email-masked]>
Date: Tue, 19 Feb 2008 11:34:50 +0100

> second, but I think it is okay.

I have reworked the ENRP paragraph and also created an additional figure to 
show the role of ENRP:

<!-- ------ ENRP server <-> ENRP server --------------------------------- -->
<t>It is envisioned that ENRP servers provide a fully distributed and
fault-tolerant registry service. They use
<xref target="I-D.ietf-rserpool-enrp">ENRP</xref> to
maintain synchronization of data concerning the pool handle mapping space.
For PUs and PEs, the ENRP servers are functionally equal. Due to the
synchronization provided by ENRP, they can contact an arbitrary one for
registration/deregistration (PE) or PH resolution (PU).  An illustration
containing 3 ENRP servers is provided in
<xref target="examplefig-enrp"/> below:</t>

<figure anchor="examplefig-enrp">
<artwork><![CDATA[

                 ______          _____
   ...          / ENRP \        / ENRP \          ...
 PEs/PUs  <---->|Server| <----> |Server|<---->  PEs/PUs
   ...     ASAP \______/  ENRP  \______/ ASAP     ...
                  ^                  ^
                  |                  |
                  |     / ENRP \     |
                  +---->|Server|<----+
                   ENRP \______/ ENRP
                           ^
                           | ASAP
                           v
                          ...
                        PEs/PUs
                          ...

]]></artwork>
</figure>

Best regards
-- 
=======================================================================
 Dr. Thomas Dreibholz

 University of Duisburg-Essen,                   Room ES210
 Inst. for Experimental Mathematics              Ellernstraße 29
 Computer Networking Technology Group            D-45326 Essen/Germany
-----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://www.iem.uni-due.de/~dreibh
=======================================================================
_______________________________________________
rserpool mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/rserpool