Subject: [RSN] RL2N Pre-WG meeting minutes - Boston - November 15

From: JP Vasseur <[email-masked]>
Date: Tue, 20 Nov 2007 14:41:35 -0500

Dear all,

Please below the minutes of the RL2N pre-WG meeting that took place on Nov
15 in Boston. The meeting was extremely fruitful and productive with a
excellent consensus between the attendees and we made significant progress
on several fronts. Of course, nothing is decided during meetings and is
shared with you on the list for comments/suggestions/...

Instead of capturing the minutes in a narrative form, you will find below
the outcome of productive discussions.

We had an excellent representation from end-users, Service Providers,
Vendors, Academia:

Attendees
    * Kris Pister: Dust Networks
    * David Culler: Arch Rock
    * Ralph King: Crossbow
    * Anders Brandt: Zensys
    * Mary Murphy-Hoye: Intel
    * Ed Butker: Intel
    * Pete St Pierre: Sun
    * Andrew Mc Lachlan: British Telecom
    * Nabil Bitar: Verizon
    * Misha Dolher: France Telecom
    * Pierre Colle: Schneider Electric
    * Todd Snide: Schneider Electric
    * Phil Levis: Standford
    * Jaudelice D. Olveira: Drexel
    * Jim Butler: Cimetrics
    * JP Vasseur: Cisco
    * David Ward: IETF RTG AD

Several people mentioned that they were interested but could not attend this
meeting - Will be in Vancouver.

Agenda And Objectives
    - Review of the current Routing Requirements ID:
       - draft-brandt-rl2n-home-routing-reqs-01- Anders
       - draft-pister-rl2n-industrial-routing-reqs-01- Kris
       - draft-levis-rl2n-overview-protocols-01 - Phil
    - Discussion of the Proposed WG charter and Milestones
    - Interaction with other SDOs, Industrial Alliances
    - Open issues
    
Summary

JP/David: Introduction, historical background, objectives.

Anders: overview of the Routing requirement for Connected Home
Discussion of the specific routing requirements in the home.
draft-brandt-rl2n-home-routing-reqs is a good basis, further discussion on
the list. Particular attention should be given to routing manageability in
home networks (self-configuration) of the routing protocols.

Kris: overview of the Routing requirement for Industrial application
ID already well fleshed out, driven by a strong experience in deploying
sensor networks in such environments. Very specific constraints (see the
ID). 

Phil: overview of the protocol survey
The aim of the document is to serve as a base to decide whether we can
borrow an existing routing protocol (potentially with adaptations), we need
to define a new protocol, ... Important work item for the potential future
WG. New revision to be posted for this IETF. Still several items to be
covered (security, manageability, ...) in light of the use-case requirements
documents. The evaluation will be made for IGPs, MANET, DTNs, ...

Discussion on the proposed WG charter

1) Use cases
Although the number of applications is wide, the objective is to stay very
focused with a limited number of use cases from which we will derive the
requirements for the routing protocol.
Agreement to work on: Industrial, Connected Home, Building.
Smart cities is too vague ... And will be removed from the WG charter.

Use case will be used to derive routing requirements but the use of the
routing protocol (TBD) will of course not be limited to these environments.
Applicability statements will document how the routing protocol will be used
in other environments.

2) Special attention will be given to routing manageability/self
configuration considering the scale at which L2Ns may be deployed (
O(thousands of nodes)) with battery operated nodes, ...

3) Security issues: key work item. Clear consensus to work on a Routing
Security Framework for L2Ns (many attacks are L2Ns specific due to the
traffic pattern nature, use of wireless links, ...).

4) Interaction with other IETF WGs, Industrial Alliances, SDOs, ...
The interaction with the 6lowpan WG is clear: the effort exclusively focuses
on the layer 3 routing issues (Route Over) and we will interact with
6lowpan. It is also highly desirable to establish some liaisons with other
Industrial alliances (SP100, Zigbee, ...).

5) The WG will work on both v4 and v6, need for unicast and multicast
routing.

6) The WG will have to work on whether a centralized/distributed (or both)
routing approach is needed and whether routing hierarchy is required.

A general comment: let's use the ML a bit more rather than off-line
discussions.

The new proposed WG charter will be sent to the list very soon for further
comments.

The new Milestones will of course be aligned with the new proposed WG
charter.

JP and David.

_______________________________________________
RSN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rsn

---

From: Geoff Mulligan <[email-masked]>
Date: Tue, 20 Nov 2007 20:54:25 -0700

On Tue, 2007-11-20 at 20:52 -0700, Geoff Mulligan wrote:
> JP,
>   You left me off of the list of attendees!
> 
> 	geoff
> 
> On Tue, 2007-11-20 at 14:41 -0500, JP Vasseur wrote:
> > Dear all,
> >

---

From: "DOHLER Mischa RD-TECH-GRE" <[email-masked]>
Date: Wed, 21 Nov 2007 14:05:55 +0100

Dear JP,

Thanks for the minutes. Since you asked to use the list, here a comment and a question:

1) As said before, I understand and support your 'application-driven' spec approach and - as you highlighted below - I also think that it is important to stay focused per application. However, with the removal of Smart City, there is no application left which is outdoors and truly large-scale. We and likely other service providers/operators believe that there is business for this type of scenario and would hence like it - in modified form - to be included in the charter. We have had an offline exchange where you proposed a different naming and approach, which we will follow whilst preparing a draft so as to comply with IETF requirements.

2) I had left the PhC when you discussed this but what exactly do you mean by centralized and distributed routing in the context of (range-limited) multi-hop RL2Ns?

Thanks and kind regards,
Mischa.

PS: Please, don't forget to change my name from Misha Dolher to Mischa Dohler :).

_______________________________________

Dr Mischa Dohler
France Telecom R&D
Senior Research Expert

Tel: +33 4 76 76 45 14
Fax: +33 4 76 76 44 50
Mob: +33 6 74 70 86 75

http://perso.rd.francetelecom.fr/dohler
_______________________________________

... visit http://www.pimrc2008.org/ ...
_______________________________________

-----Message d'origine-----
De : JP Vasseur [mailto:[email-masked]] 
Envoyé : mardi 20 novembre 2007 20:42
À : [email-masked]
Objet : [RSN] RL2N Pre-WG meeting minutes - Boston - November 15

Dear all,

Please below the minutes of the RL2N pre-WG meeting that took place on Nov
15 in Boston. The meeting was extremely fruitful and productive with a excellent consensus between the attendees and we made significant progress on several fronts. Of course, nothing is decided during meetings and is shared with you on the list for comments/suggestions/...

Instead of capturing the minutes in a narrative form, you will find below the outcome of productive discussions.

We had an excellent representation from end-users, Service Providers, Vendors, Academia:

Attendees

Several people mentioned that they were interested but could not attend this meeting - Will be in Vancouver.

Agenda And Objectives
    
Summary

Anders: overview of the Routing requirement for Connected Home Discussion of the specific routing requirements in the home.
draft-brandt-rl2n-home-routing-reqs is a good basis, further discussion on the list. Particular attention should be given to routing manageability in home networks (self-configuration) of the routing protocols.

Kris: overview of the Routing requirement for Industrial application ID already well fleshed out, driven by a strong experience in deploying sensor networks in such environments. Very specific constraints (see the ID). 

Phil: overview of the protocol survey
The aim of the document is to serve as a base to decide whether we can borrow an existing routing protocol (potentially with adaptations), we need to define a new protocol, ... Important work item for the potential future WG. New revision to be posted for this IETF. Still several items to be covered (security, manageability, ...) in light of the use-case requirements documents. The evaluation will be made for IGPs, MANET, DTNs, ...

1) Use cases
Although the number of applications is wide, the objective is to stay very focused with a limited number of use cases from which we will derive the requirements for the routing protocol.
Agreement to work on: Industrial, Connected Home, Building.
Smart cities is too vague ... And will be removed from the WG charter.

Use case will be used to derive routing requirements but the use of the routing protocol (TBD) will of course not be limited to these environments.
Applicability statements will document how the routing protocol will be used in other environments.

2) Special attention will be given to routing manageability/self configuration considering the scale at which L2Ns may be deployed ( O(thousands of nodes)) with battery operated nodes, ...

3) Security issues: key work item. Clear consensus to work on a Routing Security Framework for L2Ns (many attacks are L2Ns specific due to the traffic pattern nature, use of wireless links, ...).

4) Interaction with other IETF WGs, Industrial Alliances, SDOs, ...
The interaction with the 6lowpan WG is clear: the effort exclusively focuses on the layer 3 routing issues (Route Over) and we will interact with 6lowpan. It is also highly desirable to establish some liaisons with other Industrial alliances (SP100, Zigbee, ...).

5) The WG will work on both v4 and v6, need for unicast and multicast routing.

6) The WG will have to work on whether a centralized/distributed (or both) routing approach is needed and whether routing hierarchy is required.

A general comment: let's use the ML a bit more rather than off-line discussions.

The new proposed WG charter will be sent to the list very soon for further comments.

The new Milestones will of course be aligned with the new proposed WG charter.

JP and David.

---

From: JP Vasseur <[email-masked]>
Date: Wed, 21 Nov 2007 11:38:14 -0500

*Correction*

Geoff Mulligan (co-chair of 6lowpan) did actively participate to the
meeting. Geoff thanks again for having attended ! I had started that email
saying that I would avoid the narrative form for the minutes, I should have
;-) since I started the meeting, thanking you for your implication in this
work and day-1 support of the RL2N initiative.

Cheers.

JP.

> From: JP Vasseur <[email-masked]>
> Date: Tue, 20 Nov 2007 14:41:35 -0500
> To: <[email-masked]>
> Conversation: RL2N Pre-WG meeting minutes - Boston - November 15
> Subject: [RSN] RL2N Pre-WG meeting minutes - Boston - November 15
> 
> Dear all,
>

---

From: JP Vasseur <[email-masked]>
Date: Wed, 21 Nov 2007 12:15:42 -0500

Hi Mischa,

> From: DOHLER Mischa RD-TECH-GRE <[email-masked]>
> Date: Wed, 21 Nov 2007 14:05:55 +0100
> To: JP Vasseur <[email-masked]>, <[email-masked]>
> Conversation: [RSN] RL2N Pre-WG meeting minutes - Boston - November 15
> Subject: RE: [RSN] RL2N Pre-WG meeting minutes - Boston - November 15
> 
> Dear JP,
> 
> 1) As said before, I understand and support your 'application-driven' spec
> approach and - as you highlighted below - I also think that it is important to
> stay focused per application. However, with the removal of Smart City, there
> is no application left which is outdoors and truly large-scale. We and likely
> other service providers/operators believe that there is business for this type
> of scenario and would hence like it - in modified form - to be included in the
> charter. We have had an offline exchange where you proposed a different naming
> and approach, which we will follow whilst preparing a draft so as to comply
> with IETF requirements.

You're absolutely right and this will reflected in the new proposed charter,
which should be sent very shortly. We're in sync. It would be nice to have a
first draft of the corresponding requirements document before the BOF. We
passed the cut-off to submit it but I can host it on the non official web
page for the moment.

> 
> 2) I had left the PhC when you discussed this but what exactly do you mean by
> centralized and distributed routing in the context of (range-limited)
> multi-hop RL2Ns?

Referring to the two known path computation models: (1) distributed (IGPs,
AODV, ...) (3) Centralized where a path computation engine computes the
routes for all elements in the networks. There are many pros and cons with
each model (in term of scalability, route optimality, robustness, ...). So
we will have to have that discussion: do we need a distributed and a
centralized or both models for RL2N in light of the use case requirements?
Makes sense ?

> PS: Please, don't forget to change my name from Misha Dolher to Mischa Dohler

Sure ;-)

Cheers.

Jean-Philipp Vassuer (this is usually how people write my name too ;-))

> excellent consensus between the attendees and we made significant progress on
> several fronts. Of course, nothing is decided during meetings and is shared
> with you on the list for comments/suggestions/...
> 
> Anders: overview of the Routing requirement for Connected Home Discussion of
> the specific routing requirements in the home.
> draft-brandt-rl2n-home-routing-reqs is a good basis, further discussion on the
> list. Particular attention should be given to routing manageability in home
> networks (self-configuration) of the routing protocols.
> 
> Kris: overview of the Routing requirement for Industrial application ID
> already well fleshed out, driven by a strong experience in deploying sensor
> networks in such environments. Very specific constraints (see the ID).
> 
> The aim of the document is to serve as a base to decide whether we can borrow
> an existing routing protocol (potentially with adaptations), we need to define
> a new protocol, ... Important work item for the potential future WG. New
> revision to be posted for this IETF. Still several items to be covered
> (security, manageability, ...) in light of the use-case requirements
> 2) Special attention will be given to routing manageability/self configuration
> considering the scale at which L2Ns may be deployed ( O(thousands of nodes))
> with battery operated nodes, ...
> 
> Security Framework for L2Ns (many attacks are L2Ns specific due to the traffic
> pattern nature, use of wireless links, ...).
> 
> on the layer 3 routing issues (Route Over) and we will interact with 6lowpan.
> It is also highly desirable to establish some liaisons with other Industrial
> alliances (SP100, Zigbee, ...).
>

---

From: "DOHLER Mischa RD-TECH-GRE" <[email-masked]>
Date: Wed, 21 Nov 2007 21:24:01 +0100

Dear JP,

"Referring to the two known path computation models: (1) distributed (IGPs, AODV, ...) (3) Centralized where a path computation engine computes the routes for all elements in the networks. There are many pros and cons with each model (in term of scalability, route optimality, robustness, ...). So we will have to have that discussion: do we need a distributed and a centralized or both models for RL2N in light of the use case requirements?
Makes sense ?"

Not really. The reason why I asked is because we are likely to propose a protocol which is neither one nor the other as per your definition above. I actually wouldn't specify 'distributed' or 'centralised' in the charter so as to leave the doors open for novel and creative routing approaches. What do you and the others think?

Kind regards,
Mischa.

Dr Mischa Dohler
France Telecom R&D
Senior Research Expert

Tel: +33 4 76 76 45 14
Fax: +33 4 76 76 44 50
Mob: +33 6 74 70 86 75

-----Message d'origine-----
De : JP Vasseur [mailto:[email-masked]] 
Envoyé : mercredi 21 novembre 2007 18:16
À : DOHLER Mischa RD-TECH-GRE; [email-masked]
Objet : Re: [RSN] RL2N Pre-WG meeting minutes - Boston - November 15

Hi Mischa,

> Thanks for the minutes. Since you asked to use the list, here a 
> comment and a
> question:
> 
> 1) As said before, I understand and support your 'application-driven' 
> spec approach and - as you highlighted below - I also think that it is 
> important to stay focused per application. However, with the removal 
> of Smart City, there is no application left which is outdoors and 
> truly large-scale. We and likely other service providers/operators 
> believe that there is business for this type of scenario and would 
> hence like it - in modified form - to be included in the charter. We 
> have had an offline exchange where you proposed a different naming and 
> approach, which we will follow whilst preparing a draft so as to comply with IETF requirements.

You're absolutely right and this will reflected in the new proposed charter, which should be sent very shortly. We're in sync. It would be nice to have a first draft of the corresponding requirements document before the BOF. We passed the cut-off to submit it but I can host it on the non official web page for the moment.

> 
> 2) I had left the PhC when you discussed this but what exactly do you 
> mean by centralized and distributed routing in the context of 
> (range-limited) multi-hop RL2Ns?

Referring to the two known path computation models: (1) distributed (IGPs, AODV, ...) (3) Centralized where a path computation engine computes the routes for all elements in the networks. There are many pros and cons with each model (in term of scalability, route optimality, robustness, ...). So we will have to have that discussion: do we need a distributed and a centralized or both models for RL2N in light of the use case requirements?
Makes sense ?

Sure ;-)

Cheers.

> De : JP Vasseur [mailto:[email-masked]] Envoyé : mardi 20 novembre 
> 2007 20:42 À : [email-masked] Objet : [RSN] RL2N Pre-WG meeting minutes 
> - Boston - November 15
> 
> Dear all,
> 
> excellent consensus between the attendees and we made significant 
> progress on several fronts. Of course, nothing is decided during 
> meetings and is shared with you on the list for comments/suggestions/...
> 
> Instead of capturing the minutes in a narrative form, you will find 
> below the outcome of productive discussions.
> 
> Vendors,
> Academia:
> Several people mentioned that they were interested but could not 
> attend this meeting - Will be in Vancouver.
> 
> Agenda And Objectives
> draft-brandt-rl2n-home-routing-reqs is a good basis, further 
> discussion on the list. Particular attention should be given to 
> routing manageability in home networks (self-configuration) of the routing protocols.
> 
> ID already well fleshed out, driven by a strong experience in 
> deploying sensor networks in such environments. Very specific constraints (see the ID).
> 
> borrow an existing routing protocol (potentially with adaptations), we 
> need to define a new protocol, ... Important work item for the 
> potential future WG. New revision to be posted for this IETF. Still 
> several items to be covered (security, manageability, ...) in light of 
> the use-case requirements documents. The evaluation will be made for IGPs, MANET, DTNs, ...
> 
> Although the number of applications is wide, the objective is to stay 
> very focused with a limited number of use cases from which we will 
> derive the requirements for the routing protocol.
> Use case will be used to derive routing requirements but the use of 
> the routing protocol (TBD) will of course not be limited to these environments.
> 3) Security issues: key work item. Clear consensus to work on a 
> Routing Security Framework for L2Ns (many attacks are L2Ns specific 
> due to the traffic pattern nature, use of wireless links, ...).
> 
> The interaction with the 6lowpan WG is clear: the effort exclusively 
> focuses on the layer 3 routing issues (Route Over) and we will interact with 6lowpan.
> It is also highly desirable to establish some liaisons with other 
> 6) The WG will have to work on whether a centralized/distributed (or 
> both) routing approach is needed and whether routing hierarchy is required.
>

---

From: JP Vasseur <[email-masked]>
Date: Wed, 21 Nov 2007 15:39:59 -0500

Hi Mischa,

> Date: Wed, 21 Nov 2007 21:24:01 +0100
> "Referring to the two known path computation models: (1) distributed (IGPs,
> AODV, ...) (3) Centralized where a path computation engine computes the routes
> for all elements in the networks. There are many pros and cons with each model
> (in term of scalability, route optimality, robustness, ...). So we will have
> to have that discussion: do we need a distributed and a centralized or both
> models for RL2N in light of the use case requirements?
> Makes sense ?"
> 
> Not really. The reason why I asked is because we are likely to propose a
> protocol which is neither one nor the other as per your definition above. I
> actually wouldn't specify 'distributed' or 'centralised' in the charter so as
> to leave the doors open for novel and creative routing approaches. What do you
> and the others think?

*if* the WG decides that none of the existing routing protocols satisfy the
requirements and a novel/new/... Path computation model needs to be adopted,
there is clearly no issue there in term of charter. The notion of
distributed/centralized is purely indicative and not a black and white
choice. Note that the (proposed) WG would not be chartered at this point to
specify a protocol, just to discuss the requirements, propose a routing
architecture, ... 

Thanks for your comment.

Cheers.

JP.

> passed the cut-off to submit it but I can host it on the non official web page
> for the moment.
> 
>> 
> AODV, ...) (3) Centralized where a path computation engine computes the routes
> for all elements in the networks. There are many pros and cons with each model
> (in term of scalability, route optimality, robustness, ...). So we will have
> to have that discussion: do we need a distributed and a centralized or both
> models for RL2N in light of the use case requirements?
> Makes sense ?
> 
>> 
>> Thanks and kind regards,
>> Mischa.
>>

---

From: "DOHLER Mischa RD-TECH-GRE" <[email-masked]>
Date: Wed, 21 Nov 2007 21:52:50 +0100

I see, JP. Great! Thanks, Mischa :) PS: I am currently drafting the 4th application spec which should be ready by Friday ...

-----Message d'origine-----
De : JP Vasseur [mailto:[email-masked]] 
Envoyé : mercredi 21 novembre 2007 21:40
À : DOHLER Mischa RD-TECH-GRE
Cc : [email-masked]
Objet : Re: [RSN] RL2N Pre-WG meeting minutes - Boston - November 15

Hi Mischa,

> "Referring to the two known path computation models: (1) distributed 
> (IGPs, AODV, ...) (3) Centralized where a path computation engine 
> computes the routes for all elements in the networks. There are many 
> pros and cons with each model (in term of scalability, route 
> optimality, robustness, ...). So we will have to have that discussion: 
> do we need a distributed and a centralized or both models for RL2N in light of the use case requirements?
> Makes sense ?"
> 
> Not really. The reason why I asked is because we are likely to propose 
> a protocol which is neither one nor the other as per your definition 
> above. I actually wouldn't specify 'distributed' or 'centralised' in 
> the charter so as to leave the doors open for novel and creative 
> routing approaches. What do you and the others think?

*if* the WG decides that none of the existing routing protocols satisfy the requirements and a novel/new/... Path computation model needs to be adopted, there is clearly no issue there in term of charter. The notion of distributed/centralized is purely indicative and not a black and white choice. Note that the (proposed) WG would not be chartered at this point to specify a protocol, just to discuss the requirements, propose a routing architecture, ... 

Thanks for your comment.

Cheers.

JP.

> De : JP Vasseur [mailto:[email-masked]] Envoyé : mercredi 21 
> novembre 2007 18:16 À : DOHLER Mischa RD-TECH-GRE; [email-masked] Objet 
> : Re: [RSN] RL2N Pre-WG meeting minutes - Boston - November 15
> 
> Hi Mischa,
> 
> 
>> spec approach and - as you highlighted below - I also think that it 
>> is important to stay focused per application. However, with the 
>> removal of Smart City, there is no application left which is outdoors 
>> and truly large-scale. We and likely other service 
>> providers/operators believe that there is business for this type of 
>> scenario and would hence like it - in modified form - to be included 
>> in the charter. We have had an offline exchange where you proposed a 
>> different naming and approach, which we will follow whilst preparing 
>> a draft so as to comply with IETF requirements.
> 
> You're absolutely right and this will reflected in the new proposed 
> charter, which should be sent very shortly. We're in sync. It would be 
> nice to have a first draft of the corresponding requirements document 
> before the BOF. We passed the cut-off to submit it but I can host it 
> on the non official web page for the moment.
> 
>> 
> Referring to the two known path computation models: (1) distributed 
> (IGPs, AODV, ...) (3) Centralized where a path computation engine 
> computes the routes for all elements in the networks. There are many 
> pros and cons with each model (in term of scalability, route 
> optimality, robustness, ...). So we will have to have that discussion: 
> do we need a distributed and a centralized or both models for RL2N in light of the use case requirements?
> Makes sense ?
> 
>> 
>> Thanks and kind regards,
>> Mischa.
>> 
>> 15 in Boston. The meeting was extremely fruitful and productive with 
>> a excellent consensus between the attendees and we made significant 
>> Phil: overview of the protocol survey The aim of the document is to 
>> serve as a base to decide whether we can borrow an existing routing 
>> protocol (potentially with adaptations), we need to define a new 
>> protocol, ... Important work item for the potential future WG. New 
>> revision to be posted for this IETF. Still several items to be 
>> covered (security, manageability, ...) in light of the use-case 
>> requirements documents. The evaluation will be made for IGPs, MANET, 
>> DTNs, ...
>>