Subject: Why UDP instead of RSVP in IP tunnels

From: ashish kulshreshtha <[email-masked]>
Date: Wed, 11 Jul 2001 23:11:07 -0700 (PDT)

My question is why do we use UDP in IP tunnels to
differentiate between sessions.
Why not we use RSVP directly ?

regards,
ashish

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/

---

From: Andreas Terzis <[email-masked]>
Date: Thu, 12 Jul 2001 00:45:57 -0700 (PDT)

> Why not we use RSVP directly ?

Ashish,

RSVP's role is to  configures the classifier filters
so packets belonging to different flows can be
identified and given different service.

In the case of RSVP Tunnels, since all packets
are encapsulated using the IP address of the entry
point as src addr and the address of the tunnel
exit point as dst addr we need to add a UDP
header so packets belonging to different flows
can also be differentiated inside the tunnel.

For example

S1---F1-->--+                                   +->--R1
            |   +-------+   F1'      +------+   |
            +---|       | --->------ |      |---+
                |R_entry|------------|R_exit|
            +---|       | --->------ |      |---+
            |   +-------+   F2'      +------+   |
S2---F2-->--+                                   +->--R2

Suppose that we have two flows F1 and F2 (where a flow is
defined by the 5 tuple (proto, src ip, dst ip, src port,
dst port)).

Packets from these two flows are going to be encapsulated
inside the tunnel between R_entry and R_exit using the
same IP header (protocol is going to be IP-in-IP,
src_ip == R_entry and dst_ip == R_exit). So if you
want to differentiate between the two flows you need
some other identifier. That's why we decided to add
a UDP header where different sessions are associated
to different src UDP ports.

Hope this helps

regards,

-andreas