Subject: RTEAR message processing

From: "amit limaye" <[email-masked]>
Date: Sat, 21 Jul 2001 17:08:14 +0530

hello 
i am imlementing a RSVP server on a WIN NT system
while reading RFC 2209 i could not understand this PArticular clause for RTEAR message processing 
could somebody please help me on these

2.   Select a flow descriptor (Qj,Fj) (where Fj may be a
                  list) in the RTEAR message whose FILTER_SPEC matches
                  the SENDER_TEMPLATE in the PSB.  If not match is
                  found, return for next PSB.

                  -    Search for an RSB (for any outgoing interface) to
                       which the PSB routes and whose Filter_spec_list
                       includes the SENDER_TEMPLATE from the PSB.

                  -    If an RSB is found, add the PHOP of the PSB to
                       the Refresh_PHOP_list.

which RSB what is meant by selecting 
Search for a RSB to which the PSB routes 
i did not get it 
could somebody please help me n this
-SIGTERM
amit
A good question is never answered.  It is not a bolt to be tightened
into place but a seed to be planted and to bear more seed toward the
hope of greening the landscape of idea.

---

From: Khuzema Pithewan <[email-masked]>
Date: Sat, 21 Jul 2001 18:20:38 +0530

Its a tipical case of multicast. As PSB may route to more than one RSBs, so
if atleast one RSB exist for PSB, then the node shouldn't forward ResvTear
for that PSB, instead it should send ResvRefresh for it.

Khuzema.

> ----------
> From: 	amit limaye
> Sent: 	Saturday, July 21, 2001 5:08 PM
> To: 	[email-masked]
> Subject: 	RTEAR message processing
> 
> hello

---

From: Khuzema Pithewan <[email-masked]>
Date: Sat, 21 Jul 2001 18:28:25 +0530

PSB routing to RSB means, one of the outgoing interface of PSB matches with
the RSB's NHOP

Khuzema.

> ----------
> From: 	amit limaye
> Sent: 	Saturday, July 21, 2001 6:34 PM
> To: 	Khuzema Pithewan
> Subject: 	Re: RTEAR message processing
> 
> my doubt has been what is meant by a PSB routing to an RSB ?
> -SIGTERM
> amit
> thanx
> ----- Original Message -----
> From: Khuzema Pithewan <[email-masked]>
> To: <[email-masked]>; 'amit limaye' <[email-masked]>
> Sent: Saturday, July 21, 2001 6:20 PM
> Subject: RE: RTEAR message processing
> 
> 
> > > while reading RFC 2209 i could not understand this PArticular clause
> for
> > > RTEAR message processing

---

From: Bob Braden <[email-masked]>
Date: Mon, 23 Jul 2001 16:43:05 GMT

*> which RSB what is meant by selecting 
  *> Search for a RSB to which the PSB routes 

This is the same as "Search for a matching RSB", terminology used
elsewhere in RFC 2209.  Here is the text under "PTEAR MESSAGE
ARRIVES":

      o    Find each RSB that matches this PSB, i.e., whose
             Filter_spec_list matches Sender_Template in the PSB and
             whose OI is included in OutInterface_list.

Hopefully that is clear.  Khuzema Pithewan's answers are also correct.
 
Bob Braden