Subject: RE: path mesg

From: "Feng, Mark" <[email-masked]>
Date: Fri, 2 Nov 2001 10:27:49 -0800

That's not true. First of all, it is purely implementation dependant whether
the node does resource processing or not, while processing the Path message.
Furthermore, the ultimate decision is made by the receiver. A intermediate
node can allocate resources based on the information it has, i.e. TSPEC.
However, the receiver can send out a Resv message with a different set of
requirements. For example, the style could be SE and the receiver needs to
merge multiple senders' requirements to accomodate all the senders. In the
case of multicast, the merging can even happen at various nodes along the
path.

Hope this helps.

- Mark

> -----Original Message-----
> From: Swayam Prakash [mailto:[email-masked]]
> Sent: Friday, November 02, 2001 12:47 AM
> To: Feng, Mark
> Cc: [email-masked]'; [email-masked]
> Subject: path mesg
> 
> 
> 
> 
> Hi Mark
> 
> In that case theres no need for reservation message.As per my 
> knowledge
> Sender_Tspec is to convey to the reciever about the traffic 
> it generates,
> based on which receiver requests for resource allocation.
> 
> -Swayam
> 
> "Feng, Mark" wrote:
> 
> > Hi,
> >
> > I agree. That's why I said they "might" try to do it, based 
> on the TSPEC.
> >
> > - Mark
> >
> > > -----Original Message-----
> > > From: Suman S K [mailto:[email-masked]]
> > > Sent: Thursday, November 01, 2001 6:03 AM
> > > To: 'Feng, Mark'; 'Swayam Prakash'; [email-masked]
> > > Subject: RE: (no subject)
> > >
> > >
> > > Hi Mark,
> > >
> > > This may not be true always to allocate resource based on
> > > path message.
> > > I doubt what amount of resources shall be allocated during
> > > path message
> > > processing.
> > >
> > > Thanks and regards
> > > Suman
> > >
> > >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of Feng,
> > > Mark
> > > Sent: Wednesday, October 31, 2001 10:40 PM
> > > To: [email-masked]'; 'Swayam Prakash'; [email-masked]
> > > Subject: RE: (no subject)
> > >
> > >
> > > IMO, this is implementation dependant. For example, some
> > > implementation
> > > might try to pre-allocate resources when processing the 
> Path message.
> > >
> > > - Mark
> > >
> > > > -----Original Message-----
> > > > From: Suman S K [mailto:[email-masked]]
> > > > Sent: Tuesday, October 30, 2001 10:39 PM
> > > > To: 'Swayam Prakash'; [email-masked]
> > > > Subject: RE: (no subject)
> > > >
> > > >
> > > > Hi,
> > > > Path message does not go through Admission control.
> > > > Only resv message is going through Admission and policy
> > > > control module.
> > > > Policy control may be optional for path message.
> > > > Please correct me if wrong.
> > > >
> > > > Thanks and regards
> > > > Suman
> > > >
> > > > -----Original Message-----
> > > > From: [email-masked] [mailto:[email-masked]]On Behalf
> > > > Of Swayam
> > > > Prakash
> > > > Sent: Wednesday, October 31, 2001 11:09 AM
> > > > To: [email-masked]
> > > > Subject: (no subject)
> > > >
> > > >
> > > >
> > > > Hi
> > > > I have a querry
> > > >
> > > > "Does Path message has to go through Admission control 
> and Policy
> > > > control
> > > > modules.If so why?"
> > > >
> > > > Thanks
> > > > Swayam
> > > >
> > >
>

---

From: "Suman S K" <[email-masked]>
Date: Sat, 3 Nov 2001 18:21:19 +0530

Hi,
The rsvp-node should not allocate resource based on T_Spec received in path
message.
Basically T_Specs gives the source traffic generation rate. Moreover each
node may
have varying capacity so IMO, it does not needed
to allocate resource during path message. Also could not find any specific
reason
to do that.
It is the resv message derived from AD_Spec, T-Spec and policy should be
basis for
allocating the resource.

Thanks and regards
Suman

-----Original Message-----
From: Feng, Mark [mailto:[email-masked]]
Sent: Friday, November 02, 2001 11:58 PM
To: 'Swayam Prakash'; Feng, Mark
Cc: [email-masked]'; [email-masked]
Subject: RE: path mesg

Hope this helps.

- Mark