Subject: Traffic Control

From: Swayam Prakash <[email-masked]>
Date: Sun, 02 Dec 2001 12:05:39 +0530

Hi
  I got a doubt regarding traffic control module

(1) Can a traffic control module modify flow spec during the course of journey
of a RESV message ? Under what circumstances it modifies ???
(2)What happens in the following scenario where i have 3 routers R1,R2 and R3
   R1 has 8Mbps link
   R2 has 9Mbps link
   R3 has 4Mbps link

Now if a reservation request has come with request for 5Mbps bandwidth. What
happens at R3.
Will traffic control module as stated in Question-1 modifies the flowspec , If
not what happens ????

Thanks
Swayam Prakash

Aditya M Thomas wrote:

> hi,
>
> You could develop the signalling part of RSVP independantly.
> Of course, for the data you transmit to get the required QoS parameters
> you'd have to have a Traffic Control (scheduler and classifier) module.
>
> Some information on how RSVP could interact with the TC module could be
> obtained from rfc2209.
> Also, you could take a look at: http://qos.ittc.ukans.edu/howto/
>
> -aditya.
>
> Kiran Kumar A wrote:
>
> > Hi,
> >           So whoever is developing RSVP need not to develop
> > the  PacketScheduler and PacketClassifier modules compulsorily.
> > Where can we find the source code of these two modules with documentation
> > so that we can understand the complete functionality and can start
> > deloping RSVP.
> >
> >
> > Aditya M Thomas wrote:
> >
> >
> >>Hi,
> >>
> >>As Swayam indicated, the Scheduler and Classifier are not part of RSVP.
> >>So it's no wonder you didn't find any description in rfc2205 :-)
> >>
> >>The Flowspec parameters are opaque to RSVP. These are passed to the
> >>Traffic Control module, which implements the scheduling and
> >>classification functionality.
> >>
> >>-aditya.
> >>
> >
>
> --
> Aditya Thomas,
> Software Engineer,
> Sasken Communication Technologies Ltd.,
> Bangalore,India.
> Tel:080-5355501 ext:8249
>
> learning curve, n.:
>         An astonishing new theory, discovered by management consultants
>         in the 1970's, asserting that the more you do something the
>         quicker you can do it.

---

From: Swayam Prakash <[email-masked]>
Date: Sun, 02 Dec 2001 12:07:39 +0530

In the below  question routers R1,R2 and R3
 are connected as below R1------R2--------R3

---

From: Kiran Kumar A <[email-masked]>
Date: Mon, 03 Dec 2001 11:44:33 +0530

Hi prakash,
                        The following are my solutions to ur questions.
Pl. acknowledge me if u find the correct answers.

(1)    Traffic Control module CAN MODIFY flow spec during the course of journey
          of a RESV msg.
         If suppose two receivers are sending RESV msgs with 3Mbps bandwidth and
5 Mbps bandwith.
        Then these two have to be merged and the new flowspec is to be forwarded
upstream.
        This situation also arises at the time of reservations in a multicast
tree,
        ( refer page no. - 10  RFC 2205 )

(2)    I think the reservation req will be rejected at R3 b'coz of higher
bandwidth req.
          Traffic Control will not modify the flowspec in this case.  Always the
requested bandwidth
          should be less than the available bandwidth.

Pl. correct answers if found wrong..........

> Will traffic control module as stated in Question-1 modifies the flowspec , If

Thanx and regards,
Kiran Kumar Alampally

---

From: Swayam Prakash <[email-masked]>
Date: Mon, 03 Dec 2001 12:33:53 +0530

Khuzema can u give ur comments on kirans answers.i feel they are correct.what do u
say.