Subject: RE: Traffic Control

From: Khuzema Pithewan <[email-masked]>
Date: Mon, 3 Dec 2001 12:31:50 +0530

Yes ..Kiran is correct!!

In case of SE style RSVP will modify the forwarding flowspec if 2 or more
Path is being setup in same session.

Khuzema.

> ----------
> From: 	Swayam Prakash[SMTP:[email-masked]]
> Sent: 	Monday, December 03, 2001 12:33 PM
> To: 	[email-masked]; [email-masked]; [email-masked]
> Subject: 	Re: Traffic Control
> Importance: 	High
> 
> 
> Khuzema can u give ur comments on kirans answers.i feel they are
> correct.what do u
> say.
> 
> Kiran Kumar A wrote:
> 
> > Hi prakash,
> >                         The following are my solutions to ur questions.
> > Pl. acknowledge me if u find the correct answers.
> >
> > (1)    Traffic Control module CAN MODIFY flow spec during the course of
> journey
> >           of a RESV msg.
> >          If suppose two receivers are sending RESV msgs with 3Mbps
> bandwidth and
> > 5 Mbps bandwith.
> >         Then these two have to be merged and the new flowspec is to be
> forwarded
> > upstream.
> >         This situation also arises at the time of reservations in a
> multicast
> > tree,
> >         ( refer page no. - 10  RFC 2205 )
> >
> > (2)    I think the reservation req will be rejected at R3 b'coz of
> higher
> > bandwidth req.
> >           Traffic Control will not modify the flowspec in this case.
> Always the
> > requested bandwidth
> >           should be less than the available bandwidth.
> >
> > Pl. correct answers if found wrong..........
> >
> > Swayam Prakash wrote:
> >
> > > Hi
> > >   I got a doubt regarding traffic control module
> > >
> > > (1) Can a traffic control module modify flow spec during the course of
> journey
> > > of a RESV message ? Under what circumstances it modifies ???
> > > (2)What happens in the following scenario where i have 3 routers R1,R2
> and R3
> > >    R1 has 8Mbps link
> > >    R2 has 9Mbps link
> > >    R3 has 4Mbps link
> > >
> > > Now if a reservation request has come with request for 5Mbps
> bandwidth. What
> > > happens at R3.
> > > Will traffic control module as stated in Question-1 modifies the
> flowspec , If
> > > not what happens ????
> > >
> > > Thanks
> > > Swayam Prakash
> >
> > Thanx and regards,
> > Kiran Kumar Alampally
>

---

From: Swayam Prakash <[email-masked]>
Date: Mon, 03 Dec 2001 15:44:07 +0530

Hi
  Dont u think that in WF style, say receivers request for bandwidth, always the
largest reservation(say 10Mbps) is the one which is forwarded upstream,the
router that has requested much less than 10Mbps say it has requested 2Mbps ,even
then it gets 10Mbps .Is this not a wastage of resource ???.

Thanks
Swayam