Subject: RE: Traffic Control

From: Khuzema Pithewan <[email-masked]>
Date: Mon, 3 Dec 2001 11:02:44 +0530

Flowspec wont get modified, but it will return Admission Control Failure.

Khuzema.

> ----------
> From: 	Swayam Prakash[SMTP:[email-masked]]
> Sent: 	Sunday, December 02, 2001 12:07 PM
> To: 	Aditya M Thomas; [email-masked]; [email-masked]
> Subject: 	Re: Traffic Control
> Importance: 	High
> 
> In the below  question routers R1,R2 and R3
>  are connected as below R1------R2--------R3
> 
> Swayam Prakash wrote:
> 
> > Hi
> >   I got a doubt regarding traffic control module
> >
> > (1) Can a traffic control module modify flow spec during the course of
> journey
> > of a RESV message ? Under what circumstances it modifies ???
> > (2)What happens in the following scenario where i have 3 routers R1,R2
> and R3
> >    R1 has 8Mbps link
> >    R2 has 9Mbps link
> >    R3 has 4Mbps link
> >
> > Now if a reservation request has come with request for 5Mbps bandwidth.
> What
> > happens at R3.
> > Will traffic control module as stated in Question-1 modifies the
> flowspec , If
> > not what happens ????
> >
> > Thanks
> > Swayam Prakash
> >
> > Aditya M Thomas wrote:
> >
> > > hi,
> > >
> > > You could develop the signalling part of RSVP independantly.
> > > Of course, for the data you transmit to get the required QoS
> parameters
> > > you'd have to have a Traffic Control (scheduler and classifier)
> module.
> > >
> > > Some information on how RSVP could interact with the TC module could
> be
> > > obtained from rfc2209.
> > > Also, you could take a look at: http://qos.ittc.ukans.edu/howto/
> > >
> > > -aditya.
> > >
> > > Kiran Kumar A wrote:
> > >
> > > > Hi,
> > > >           So whoever is developing RSVP need not to develop
> > > > the  PacketScheduler and PacketClassifier modules compulsorily.
> > > > Where can we find the source code of these two modules with
> documentation
> > > > so that we can understand the complete functionality and can start
> > > > deloping RSVP.
> > > >
> > > >
> > > > Aditya M Thomas wrote:
> > > >
> > > >
> > > >>Hi,
> > > >>
> > > >>As Swayam indicated, the Scheduler and Classifier are not part of
> RSVP.
> > > >>So it's no wonder you didn't find any description in rfc2205 :-)
> > > >>
> > > >>The Flowspec parameters are opaque to RSVP. These are passed to the
> > > >>Traffic Control module, which implements the scheduling and
> > > >>classification functionality.
> > > >>
> > > >>-aditya.
> > > >>
> > > >
> > >
> > > --
> > > Aditya Thomas,
> > > Software Engineer,
> > > Sasken Communication Technologies Ltd.,
> > > Bangalore,India.
> > > Tel:080-5355501 ext:8249
> > >
> > > learning curve, n.:
> > >         An astonishing new theory, discovered by management
> consultants
> > >         in the 1970's, asserting that the more you do something the
> > >         quicker you can do it.
>

---

From: Swayam Prakash <[email-masked]>
Date: Wed, 05 Dec 2001 15:22:38 +0530

Hi

  There is something called protocol id in Session object ,what this will be
any examples
-Swayam

---

From: Kiran Kumar A <[email-masked]>
Date: Wed, 05 Dec 2001 16:51:39 +0530

Hi prakash,

                        I think this protocol-id resembles the 'protocol' field
in the IP HEADER.
i.e. for TCP it is 0x06 and for UDP it is 0x11.
As we have two types of communication ( connection-less and connection-oriented
)
we have to specify which type of communication we are opting for to reserve
bandwidth.

pl  correct me if I am wrong...........

--
Thanx and regards,

 __/__/__/__/__/__/__/__/__/__/__/__/__/__/__/
         __/
        __/   Kiran Kumar Alampally
       __/   Software Engineer
      __/   Rendezvous On Chip
     __/   Banjara Hills, Hyderabad.
    __/   Off:: 3351175/84
   __/   Res:: 3526313
  __/   @:: [email-masked]

---

From: Swayam Prakash <[email-masked]>
Date: Wed, 05 Dec 2001 18:02:07 +0530

Hi
let us consider the below scenario
                                                R3
                                              /
               R1--------------R2
                                              \
                                                 R4

R3 has requested for 2Mbps  and R4 has requested for 1Mbps .At R2 these
will be merged and the largest of the two reservations will be forwarded
upstream. that is 2Mbps.Now say R4 has gone down,its not sending any
RESV refresh mesg upstream.

(1)so what happens under this conditions for the reservation done from
R2 to R1

(2)R2 sends a Resv teardown mesg upstream to R1.coz its not receivng any
refresh mesg from R4,what will happen to traffic on the path
R1----R2---R3

(3)Will the reservation exists btn R1 and R2,will there be any packets
lost by R3 bcoz of this.

Please explain

Thanks
Swayam

Kiran Kumar A wrote:

> Hi prakash,
>
>                         I think this protocol-id resembles the
> 'protocol' field in the IP HEADER.
> As we have two types of communication ( connection-less and
> connection-oriented )
> we have to specify which type of communication we are opting for to
> reserve bandwidth.
>

---

From: Kiran Kumar A <[email-masked]>
Date: Wed, 05 Dec 2001 18:21:12 +0530

Hi,

   The following is my idea. Pl don't take it granted unless and until
u confirm from others.

------------------------------------------------------------------------------

    Generally refresh messages will be coming from R3 & R4 to R2.
    After R4 has gone down then R2 will not receive any refresh
    messages from R4 but R3 will be sending refresh messages to R2.
    Eventhough if the existing state is removed u will have new state
    as the refresh message from R3 is coming.
    I think that particular session will exist but as it is receiving
    refresh messages only from R3 flowspec will be changed and
    new flowspec will be sent to R1 so that the reservation will be
    updated.
------------------------------------------------------------------------------

Swayam Prakash wrote:

> R3 has requested for 2Mbps  and R4 has requested for 1Mbps .At R2
> these will be merged and the largest of the two reservations will be
> forwarded upstream. that is 2Mbps.Now say R4 has gone down,its not
> sending any RESV refresh mesg upstream.
>
> (2)R2 sends a Resv teardown mesg upstream to R1.coz its not receivng
> any refresh mesg from R4,what will happen to traffic on the path
> R1----R2---R3
>

Thanx and regards,
Kiran Kumar Alampally

---

From: Swayam Prakash <[email-masked]>
Date: Wed, 05 Dec 2001 18:32:01 +0530

Hi Friends

Pl comment on the scenario i have given and the below answer. Is there
any other alternative way of things happening.

Thanks
Swayam

Kiran Kumar A wrote:

> ----------------------
> -------------------------------------------------------
> ------------
> -----------------------------------------------------------------
>
>
>
> Swayam Prakash wrote:
>
>> Hi
>> (1)so what happens under this conditions for the reservation done
>> from R2 to R1
>>
>> (3)Will the reservation exists btn R1 and R2,will there be any
>> packets lost by R3 bcoz of this.
>>
>> Please explain
>>
>> Thanks
>> Swayam
>>
>
> Thanx and regards,
> Kiran Kumar Alampally
>
>