Subject: Re: BFD Echo mode coverage in BFD for VXLAN

From: Jeffrey Haas <[email-masked]>
Date: Tue, 10 Sep 2019 13:51:48 -0400

[trimming headers]

Working Group,

While we're suspecting everyone is finishing up holidays, please take until
the end of this week to answer Reshad's question:  Should we require BFD for
vxlan to support Echo mode?

-- Jeff

On Thu, Aug 15, 2019 at 10:41:46PM +0000, Reshad Rahman (rrahman) wrote:
> Hi all,
> 
> It is up to the WG to decide whether echo support is desired for BFD over VxLAN (any other BFD use-cases also).  Since this hasn’t been brought up in the WG before, my take is that the WG isn’t interested in having echo for BFD over VxLAN. So if anybody feels that we need echo support, please speak up asap. Because it’s holiday season, let’s take 3 weeks instead of the usual 2, so please respond by September 5th.
> 
> Regards,
> Reshad (co-chair hat).
> 
> From: Greg Mirsky <[email-masked]>
> Date: Thursday, August 8, 2019 at 8:04 PM
> To: "Carlos Pignataro (cpignata)" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Martin Vigoureux <[email-masked]>
> Subject: Re: BFD Echo mode coverage in BFD for VXLAN
> Resent-From: <[email-masked]>
> Resent-To: Jeffrey Haas <[email-masked]>, <[email-masked]>
> Resent-Date: Thursday, August 8, 2019 at 8:04 PM
> 
> Dear All,
> I was pointed out that my previous e-mail asking for WG help to progress BFD over VXLAN document by sharing opinions regarding coverage of the BFD Echo mode may be overstepping the bounds of an Editor. I apologize, that was not my intention. I'm asking WG Chairs to help to arrive at the conclusion of this question in a reasonable time.
> 
> Regards,
> Greg
> 
> On Thu, Aug 8, 2019 at 4:06 PM Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:
> Dear All,
> I have not set the when this poll closes. I hope that two weeks would be sufficient time for the WG community to express their thoughts.
> 
> Dear Carlos,
> thank you for sharing your opinion on the scope of the document in regard to BFD Echo mode. You've expressed support for exploring the applicability of the BFD Echo mode. Would you support that effort by contributing some text, if WG decides that documenting the applicability of the Echo mode in BFD over VXLAN is useful?
> 
> Regards,
> Greg
> 
> 
> On Wed, Aug 7, 2019 at 6:18 PM Carlos Pignataro (cpignata) <[email-masked]<mailto:[email-masked]>> wrote:
> Dear Greg,
> 
> The option of replacing the existing text for something more ambiguous and implicit does not seem like progress in my humble opinion. The spec ends up with the same capabilities, but the text is more obscure. I do not support that option.
> 
> My recommendation for your consideration would be:
> 
>   1.  Explore if it is possible to run BFD Echo as a single-hop.
>   2.  If yes, add text supporting it.
>   3.  If no, add text explaining why not on technical grounds.
> 
> A less desirable option would be if the WG does not care about BFD Echo, to explicitly keep it out of scope (not on technical grounds).
> 
> Best,
> 
> Carlos.
> 
> 
> On Aug 5, 2019, at 6:16 PM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:
> 
> Dear All,
> in course of reviews of the draft, several times a question was asked about the rationale for excluding BFD Echo from the scope of this document:
> 
> 7.  Echo BFD
> 
>    Support for echo BFD is outside the scope of this document.
> Much appreciate your consideration of the following options:
> 
>   *   describe the applicability of BFD Echo in VXLAN environment in the document;
>   *   remove Section 7 and clarify in the Introduction
> NEW TEXT:
> This specification describes procedures only for BFD Asynchronous mode.
> 
>   *   make no changes at all.
> Regards,
> Greg
>

---

From: <[email-masked]>
Date: Wed, 11 Sep 2019 12:01:11 +0800 (CST)

Hi Jeff and Reshad,

From my personal perspective, I don't think we should require BFD for VxLAN to support Echo mode, because as I know, although the final standard is still on the way, many vendors including my company have already implemented BFD for VxLAN, and it seems that works fine, there is no request from them on Echo mode, which in my view is a lightweight BFD tool used to substitute a relatively more complex BFD implementation.

Best Regards,

Xiao Min

原始邮件

发件人：JeffreyHaas <[email-masked]>
收件人：[email-masked] <[email-masked]>;
日 期 ：2019年09月11日 01:49
主 题 ：Re: BFD Echo mode coverage in BFD for VXLAN

[trimming headers]

Working Group,

-- Jeff

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 11 Sep 2019 10:53:45 -0400

Xiam Min,

On Wed, Sep 11, 2019 at 12:01:11PM +0800, [email-masked] wrote:
> From my personal perspective, I don't think we should require BFD for
> VxLAN to support Echo mode, because as I know, although the final standard
> is still on the way, many vendors including my company have already
> implemented BFD for VxLAN, and it seems that works fine, there is no
> request from them on Echo mode, which in my view is a lightweight BFD tool
> used to substitute a relatively more complex BFD implementation.

Thanks for your commentary.

Also, as an implementor, does your implementation's bootstrapping for BFD
sessions follow the text that is in the current version of the
internet-draft?  There is some continuing debate holding up last call
comments on this point.

-- Jeff

---

From: <[email-masked]>
Date: Mon, 16 Sep 2019 10:10:34 +0800 (CST)

Hi Jeff,

I talked to implementor of my company, and I got the feedback that the provision of peer ip address is necessary, that means different ip address can be provisioned to different BFD session. As to VNI, there is no restriction on which VNI to choose. I guess this behavior is compiant with the current version of the draft.

Best Regards,

Xiao Min

原始邮件

发件人：JeffreyHaas <[email-masked]>
收件人：肖敏10093570;
抄送人：[email-masked] <[email-masked]>;
日 期 ：2019年09月12日 00:52
主 题 ：Re: BFD Echo mode coverage in BFD for VXLAN

Xiam Min,

-- Jeff