Subject: Lars Eggert's No Objection on draft-ietf-bfd-rfc9127-bis-02: (with COMMENT)

From: Lars Eggert via Datatracker <[email-masked]>
Date: Tue, 05 Apr 2022 06:02:04 -0700

Lars Eggert has entered the following ballot position for
draft-ietf-bfd-rfc9127-bis-02: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ 
for more information about how to handle DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bfd-rfc9127-bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Document updates RFC9127, but does not cite it as a reference.

Found terminology that should be reviewed for inclusivity; see
https://www.rfc-editor.org/part2/#inclusive_language for background and more
guidance:

 * Term "invalid"; alternatives might be "not valid", "unenforceable", "not
   binding", "inoperative", "illegitimate", "incorrect", "improper",
   "unacceptable", "inapplicable", "revoked", "rescinded".

Thanks to Joel Halpern for their General Area Review Team (Gen-ART) review
(https://mailarchive.ietf.org/arch/msg/gen-art/2_6QYcQc4Tflyh0-cr6_e9Gc43s).

-------------------------------------------------------------------------------
NIT
-------------------------------------------------------------------------------
All comments below are about very minor potential issues that you may choose to
address in some way - or ignore - as you see fit. Some were flagged by
automated tools (via https://github.com/larseggert/ietf-reviewtool), so there
will likely be some false positives. There is no need to let me know what you
did with these suggestions.

Document still refers to the "Simplified BSD License", which was corrected in
the TLP on September 21, 2021. It should instead refer to the "Revised BSD
License".

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 5 Apr 2022 12:42:37 -0700

Hi Lars,

Thanks first of all for the review. See comments inline.

> On Apr 5, 2022, at 6:02 AM, Lars Eggert via Datatracker <[email-masked]> wrote:
> 

Added.

>   "unacceptable", "inapplicable", "revoked", "rescinded".

The choice of the word ‘invalid’ is unfortunate. However, it is not in the text of the draft, but rather a node in the data model. Changing the name of the node in the data model would be considered a non-backwards compatible change, further complicating the publication of this draft.

Please advise.

> (https://mailarchive.ietf.org/arch/msg/gen-art/2_6QYcQc4Tflyh0-cr6_e9Gc43s).

Fixed.

Thanks.

Mahesh Jethanandani
[email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 6 Apr 2022 13:35:57 -0700

Hi Lars,

The -04 version of the draft should address your comments.

Cheers.

p.s. Due to some confusion with uploads, the -03 version only partially addressed some of the comments received during IESG review. 

> On Apr 5, 2022, at 12:42 PM, Mahesh Jethanandani <[email-masked]> wrote:
> 
> Hi Lars,
> 
>> On Apr 5, 2022, at 6:02 AM, Lars Eggert via Datatracker <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Please refer to https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/ <https://www.ietf.org/about/groups/iesg/statements/handling-ballot-positions/> 
>> https://datatracker.ietf.org/doc/draft-ietf-bfd-rfc9127-bis/ <https://datatracker.ietf.org/doc/draft-ietf-bfd-rfc9127-bis/>
>> 
>> 
>> 
>> https://www.rfc-editor.org/part2/#inclusive_language <https://www.rfc-editor.org/part2/#inclusive_language> for background and more
>> guidance:
>> 
>> (https://mailarchive.ietf.org/arch/msg/gen-art/2_6QYcQc4Tflyh0-cr6_e9Gc43s <https://mailarchive.ietf.org/arch/msg/gen-art/2_6QYcQc4Tflyh0-cr6_e9Gc43s>).
>> 
>> automated tools (via https://github.com/larseggert/ietf-reviewtool <https://github.com/larseggert/ietf-reviewtool>), so there
> [email-masked] <mailto:[email-masked]>

Mahesh Jethanandani
[email-masked]