Subject: RE: one comment on draft-ietf-rtgwg-cl-requirement-04

From: "So, Ning" <[email-masked]>
Date: Wed, 14 Sep 2011 10:32:08 -0400

Curtis and Xihua,

Including loss can be a very useful feature, but I do share the concern that it cannot lead to route oscillation.  That's similar requirement with all load/traffic balancing technology.  I think we should add the route oscillation damping into the requirement alongside of adding loss as Curtis suggested. 

Best regards,
 
Ning So
Verizon Corporate Technology
(office) 972-729-7905
(Cell) 972-955-0914

-----Original Message-----
From: Curtis Villamizar [mailto:[email-masked]] 
Sent: Wednesday, September 14, 2011 8:55 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; Malis, Andrew G. (Andy); So, Ning
Subject: Re: one comment on draft-ietf-rtgwg-cl-requirement-04

In message <[email-masked]>
[email-masked] writes:
 
> Hi,
>  
> Based on a short discussion with the authors of this draft on the 
> requirement of adding packet loss in FR#15, FR#16 and FR#17, Authors 
> suggested if no one objects, they can revise the text to include loss 
> as a performance parameter.
>  
> Thanks,
>  
> Xihua Fu

The discussion was extremely brief.  It occurred a while ago and there was no agreement among the authors (unless silence is interpreted as consent rather than lack of interest).

Including loss can easily result in route oscillations.  It is not an unsolvable problem, but any mechanism must be sufficiently damped in its response such that routing is stable and converges toward an optimal solution.  This is a lot like the OMP arguments of the mid to late 1990s, where percent utilization and loss were used as criteria.

IMO we can't just add loss as a parameter and leave it at that.  We need to be very clear that any mechanism that make use of the loss parameter to affect routing must be stable and preferably provably stable (nyquist analysis of the feedback loop or something similar).

This is a topic that is best left to the WG to decide.

Curtis

---

From: [email-masked]
Date: Wed, 14 Sep 2011 22:36:46 +0800

Hi Ning,

I agree with you. We should add the control of route oscillation for 
latency, jitter and loss.

Best Regards,

Xihua Fu

ZTE Corporation

"So, Ning" <[email-masked]> 
2011-09-14 22:32

收件人
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>
抄送
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>, "Malis, Andrew G. (Andy)" 
<[email-masked]>
主题
RE: one comment on draft-ietf-rtgwg-cl-requirement-04

Curtis and Xihua,

Including loss can be a very useful feature, but I do share the concern 
that it cannot lead to route oscillation.  That's similar requirement with 
all load/traffic balancing technology.  I think we should add the route 
oscillation damping into the requirement alongside of adding loss as 
Curtis suggested. 

Best regards,
 
Ning So

-----Original Message-----
From: Curtis Villamizar [mailto:[email-masked]] 
Sent: Wednesday, September 14, 2011 8:55 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; Malis, Andrew G. (Andy); So, 
Ning

In message 
<[email-masked]>
 
> as a performance parameter.

The discussion was extremely brief.  It occurred a while ago and there was 
no agreement among the authors (unless silence is interpreted as consent 
rather than lack of interest).

Including loss can easily result in route oscillations.  It is not an 
unsolvable problem, but any mechanism must be sufficiently damped in its 
response such that routing is stable and converges toward an optimal 
solution.  This is a lot like the OMP arguments of the mid to late 1990s, 
where percent utilization and loss were used as criteria.

IMO we can't just add loss as a parameter and leave it at that.  We need 
to be very clear that any mechanism that make use of the loss parameter to 
affect routing must be stable and preferably provably stable (nyquist 
analysis of the feedback loop or something similar).

Curtis