Subject: Discussion on draft-mjsraman-rtgwg-inter-as-psp-03

From: Balaji venkat Venkataswami <[email-masked]>
Date: Tue, 28 Aug 2012 13:39:59 +0530

Dear all,

We would like the working group members opinion and comments on the
following draft.

http://tools.ietf.org/html/draft-mjsraman-rtgwg-inter-as-psp-03

Please feel free to comment on the same.

thanks and regards,
balaji venkat

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Tue, 28 Aug 2012 14:53:05 +0000

Some comments:

1)  This is clearly a cut and paste of an academic paper, as your Acknowledgements indicate.  This sort of stuff rarely goes anywhere in the IETF as the IETF is not a research journal.  To move towards standardization you'd need support from one or more operators stating that the problem you solve is  a real problem for them, and that your solution is both effective and deployable in practice.  Note that this support has more heft if it comes from the operations side, not from the research department.  Do you have such support?

2) Your document assumes massive amounts of cooperation between ASes, including inter-AS TE LSPs.  You may want to investigate the operational feasibility of this cooperation.  

eric

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Balaji venkat Venkataswami
> Sent: Tuesday, August 28, 2012 4:10 AM
> To: [email-masked]
> Cc: Shankar Raman M J; Gaurav Raina
> Subject: Discussion on draft-mjsraman-rtgwg-inter-as-psp-03
> 
> Dear all,
>

---

From: Balaji venkat Venkataswami <[email-masked]>
Date: Wed, 29 Aug 2012 00:08:41 +0530

Dear Eric,

Here is an attempt that we made to get this draft and a few others entered
for consideration in the IRTF.

Tony Li responded as follows...

So, the first question is whether or not this counts as research or
engineering.  Glancing at it, it looks to me like you're on the engineering
side of the world.  It would then make sense to spark an email discussion
on the rtgwg mailing list.

You have on the other hand branded this as research.

Is there a different picture IRTF and IETF see or is it a question of
subjectivity ?

Your opinion would be most useful.

thanks and regards,
balaji venkat
On Tue, Aug 28, 2012 at 8:23 PM, Eric Osborne (eosborne) <[email-masked]
> wrote:

> Some comments:
>
> 1)  This is clearly a cut and paste of an academic paper, as your
> Acknowledgements indicate.  This sort of stuff rarely goes anywhere in the
> IETF as the IETF is not a research journal.  To move towards
> standardization you'd need support from one or more operators stating that
> the problem you solve is  a real problem for them, and that your solution
> is both effective and deployable in practice.  Note that this support has
> more heft if it comes from the operations side, not from the research
> department.  Do you have such support?
>
> 2) Your document assumes massive amounts of cooperation between ASes,
> including inter-AS TE LSPs.  You may want to investigate the operational
> feasibility of this cooperation.
>
>
>
>
>
> eric
>
>

---

From: Balaji venkat Venkataswami <[email-masked]>
Date: Wed, 29 Aug 2012 00:24:24 +0530

Including Tony Li

On Wed, Aug 29, 2012 at 12:08 AM, Balaji venkat Venkataswami <
[email-masked]> wrote:

> On Tue, Aug 28, 2012 at 8:23 PM, Eric Osborne (eosborne) <
> [email-masked]> wrote:
>
>> Some comments:
>>

---

From: "Eric Osborne (eosborne)" <[email-masked]>
Date: Tue, 28 Aug 2012 19:03:45 +0000

Hi Balaji-

  You're right that perception is by nature subjective.  Tony may have looked at the fact that you're proposing BGP changes and decided it was operations; I looked at it and saw that the bulk of your draft was about algorithms and graph theory and that it looked rather undeployable and decided it was research-y. I'm fine with discussion of the draft continuing on RTGWG (not that I have any power to stop it anyways), and you might want to try to answer the points I raised in my first mail as part of the discussion you'd like to spark.

eric

> From: Balaji venkat Venkataswami [mailto:[email-masked]]
> Sent: Tuesday, August 28, 2012 2:54 PM
> To: Eric Osborne (eosborne); [email-masked]
> Cc: Shankar Raman M J; [email-masked]
> Subject: Re: Discussion on draft-mjsraman-rtgwg-inter-as-psp-03
> 
> Including Tony Li
> 
> 
> On Wed, Aug 29, 2012 at 12:08 AM, Balaji venkat Venkataswami
> <[email-masked]> wrote:
> 
> 
> 	Dear Eric,
> 
> 	Here is an attempt that we made to get this draft and a few others
> entered for consideration in the IRTF.
> 
> engineering.  Glancing at it, it looks to me like you're on the engineering side
> of the world.  It would then make sense to spark an email discussion on the
> rtgwg mailing list.
> 
> 	On Tue, Aug 28, 2012 at 8:23 PM, Eric Osborne (eosborne)
> <[email-masked]> wrote:
> 
> 
> 		Some comments:
> 
> 		1)  This is clearly a cut and paste of an academic paper, as
> your Acknowledgements indicate.  This sort of stuff rarely goes anywhere in
> the IETF as the IETF is not a research journal.  To move towards
> the problem you solve is  a real problem for them, and that your solution is
> both effective and deployable in practice.  Note that this support has more
> heft if it comes from the operations side, not from the research department.
> Do you have such support?
> 
> 		2) Your document assumes massive amounts of cooperation
> between ASes, including inter-AS TE LSPs.  You may want to investigate the
> operational feasibility of this cooperation.
> 
> 
> 
> 
> 
> 		eric
> 
> 
>

---

From: Balaji venkat Venkataswami <[email-masked]>
Date: Wed, 29 Aug 2012 00:46:11 +0530

Dear Eric,

This draft at the present context aimed at service providers that have
multiple ASes spanning across the globe. Such an ISP may have large number
of ASes (in the 10s) each catering to the local geography / region. Amongst
these ASes which belong to a single ISP (though admin wise split up for
management purposes, but not ownership wise) there may be a necessity to
deploy this scheme.

As a first step they could derive the topology of the neighborhood and
isolate those ASes which belong to them and run the scheme proposed in the
draft. Integrating strands into a graph that too with just 10s of ASes is
quite trivial. There are specific algorithms that can construct the
topology proposed in the scheme.

Amongst these ASes sharing the power consumed to available bandwidth ratio
would be based on trust. However the ideal situation would be to run this
amongst the entire internet. That step though not currently realizable may
do good in the future.

Running up the stats on the major global ISPs there are some that have
presences in more than 150 countries. The ASes within each region
constituted by one or more countries makes this scheme plausible.

regards,
balaji venkat

On Wed, Aug 29, 2012 at 12:33 AM, Eric Osborne (eosborne) <
[email-masked]> wrote:

> Hi Balaji-
>
>   You're right that perception is by nature subjective.  Tony may have
> looked at the fact that you're proposing BGP changes and decided it was
> operations; I looked at it and saw that the bulk of your draft was about
> algorithms and graph theory and that it looked rather undeployable and
> decided it was research-y. I'm fine with discussion of the draft continuing
> on RTGWG (not that I have any power to stop it anyways), and you might want
> to try to answer the points I raised in my first mail as part of the
> discussion you'd like to spark.
>
>
> eric
>
>

---

From: Balaji venkat Venkataswami <[email-masked]>
Date: Wed, 29 Aug 2012 01:00:56 +0530

Dear Eric,

Forgot to answer question number one.

As far as operator support is concerned we will be familiarizing this as we
go along with the major ISPs and seeking their opinion.

Some informal conversations have shown the power reduction techniques are
necessary more than ever.

At this stage we are not even asking for standardization but just to convey
the fact that we did some simulations and the work was a result of these
experiments. The conference calls that we had with some providers with huge
opex costs with respect to power especially core routers of the kind that
are deployed today helped us gather more material from this research-y yet
technically feasible solution.

The mechanism proposed is primarily a PCE like architecture that constructs
the graph with weighted edges as consumed power to available bandwidth
ratios and which runs CSPF to do its job as proposed.

Hope this clarifies.

thanks and regards,
balaji venkat

---

From: Tony Li <[email-masked]>
Date: Tue, 28 Aug 2012 13:12:53 -0700

Hi Balaji,

And what happens normally here is that RG/WG chairs discuss and come to some decision.

However, given the tone of your previous private email, I'm not sure that collaboration within either IETF or IRTF is appropriate.

Regards,
Tony