Subject: Request for review - draft-psarkar-rtgwg-rlfa-node-protection-01.txt

From: Pushpasis Sarkar <[email-masked]>
Date: Wed, 10 Jul 2013 07:55:38 +0000

Hi All,

Yesterday we posted a new draft on Remote-LFA Node Protection and Manageability and would like to hear your views on it. Please feel free to raise any suggestion/comment on the content.

Best Regards,	
Pushpasis

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, July 09, 2013 2:28 PM
To: Harish Raghuveer; Shraddha Hegde; Hannes Gredler; Pushpasis Sarkar; psarkar@
Subject: New Version Notification for draft-psarkar-rtgwg-rlfa-node-protection-01.txt

A new version of I-D, draft-psarkar-rtgwg-rlfa-node-protection-01.txt
has been successfully submitted by Pushpasis Sarkar and posted to the IETF repository.

Filename:	 draft-psarkar-rtgwg-rlfa-node-protection
Revision:	 01
Title:		 Node Protecting R-LFA and Manageability
Creation date:	 2013-07-08
Group:		 Individual Submission
Number of pages: 11
URL:             http://www.ietf.org/internet-drafts/draft-psarkar-rtgwg-rlfa-node-protection-01.txt
Status:          http://datatracker.ietf.org/doc/draft-psarkar-rtgwg-rlfa-node-protection
Htmlized:        http://tools.ietf.org/html/draft-psarkar-rtgwg-rlfa-node-protection-01
Diff:            http://www.ietf.org/rfcdiff?url2=draft-psarkar-rtgwg-rlfa-node-protection-01

Abstract:
   The loop-free alternates computed following the current Remote-LFA
   [I-D.ietf-rtgwg-remote-lfa] specification gaurantees only link-
   protection.  The resulting Remote-LFA nexthops (also called PQ-
   nodes), may not gaurantee node-protection for all destinations being
   protected by it.

   This document describes procedures for determining if a given PQ-node
   provides node-protection for a specific destination or not.  The
   document also shows how the same procedure can be utilised for
   collection of complete characteristics for alternate paths.
   Knowledge about the characteristics of all alternate path is
   precursory to apply operator defined policy for eliminating paths not
   fitting constraints.

The IETF Secretariat

---

From: "Russ White" <[email-masked]>
Date: Wed, 10 Jul 2013 08:33:03 -0400

> Yesterday we posted a new draft on Remote-LFA Node Protection and
> Manageability and would like to hear your views on it. Please feel free to
> raise any suggestion/comment on the content.

Very interesting... I was trying to work out if this might also provide
better coverage in non-planar topologies, or even if there might be a way to
extend this to finding flooding domain boundaries, and hence to being able
to at least route to alternate boundary routers, rather than leaving things
completely unprotected. Haven't had the chance to sit down and go through
these areas in detail, but it's probably worth thinking about.

:-)

Russ

---

From: Pushpasis Sarkar <[email-masked]>
Date: Wed, 10 Jul 2013 14:17:51 +0000

Hi Russ,

Good to know that you found it interesting. Theoretically the mechanism proposed in our draft does not find more coverage than what standard R-LFA does. 

However we would also like to hear more on your idea on how this can be extended to find better coverage in non-planar topologies (not sure I understood the problem statement). Illustrating with an example (if possible) will help us understand the problem. And then probably can start thinking on such possibility :)

Thanks and Regards,
-Pushpasis

-----Original Message-----
From: Russ White [mailto:[email-masked]] 
Sent: Wednesday, July 10, 2013 6:03 PM
To: Pushpasis Sarkar; [email-masked]
Subject: RE: Request for review - draft-psarkar-rtgwg-rlfa-node-protection-01.txt

> Manageability and would like to hear your views on it. Please feel 
> free to raise any suggestion/comment on the content.

Very interesting... I was trying to work out if this might also provide better coverage in non-planar topologies, or even if there might be a way to extend this to finding flooding domain boundaries, and hence to being able to at least route to alternate boundary routers, rather than leaving things completely unprotected. Haven't had the chance to sit down and go through these areas in detail, but it's probably worth thinking about.

:-)

Russ