Subject: Remote LFA path length to PQ : draft-shen-mpls-ldp-nnhop-label

From: <[email-masked]>
Date: Sat, 3 Aug 2013 21:08:25 +0200

Hi Stewart,

Regarding your comment during RTGWG on resurrecting draft-shen-mpls-ldp-nnhop-label, here are the results of the path length to the best PQ using remote LFA node protection draft algorithm :

Path len to PQ  T1      T2      T3      T4      T5      T6
2 hops  98,78%  90,63%  90,55%  83,90%  99,86%  100,00%

The results are pretty good, showing that most of the time the PQ is two hops away, but there is still some situations where the PQ is more far, leading to the need of tldp session. The analysis was done on 6 topologies (different network size, network design ...), but may be the results could be worst on some other types of topologies.

IMHO, it would not be a good idea to mix two different mechanism with remote LFA (establishing TLDP session or using nnhop label) as it may complexify the code. Moreover using nnhop label, we could imagine some situation where first the PQ is two hops way leading the PLR to request NNHOP label and then due to an event (metric change ?), the path to the PQ becomes 3 or 4 hops away. This kind of situation would be hard to manage, so I would propose as simplicity to keep TLDP. Moreover implementing segment routing procedures would permit to avoid TLDP sessions in a near future as described in STATUS BOF.

Best Regards,

Stephane

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Hannes Gredler <[email-masked]>
Date: Mon, 5 Aug 2013 09:47:54 +0200

FWIW i agree to stephane's assertion. - SR provides us a session-less
indication what the PQ->Dest SPT Transport label will be, such
that implementations does not need to bring up dynamic T-LDP sessions.

furthermore with SR there is no topologic assumption how far a
PQ node may be located.

/hannes

On Aug 3, 2013, at 9:08 PM, <[email-masked]> wrote:

> IMHO, it would not be a good idea to mix two different mechanism with remote LFA (establishing TLDP session or using nnhop label) as it may complexify the code. Moreover using nnhop label, we could imagine some situation where first the PQ is two hops way leading the PLR to request NNHOP label and then due to an event (metric change ?), the path to the PQ becomes 3 or 4 hops away. This kind of situation would be hard to manage, so I would propose as simplicity to keep TLDP.

> Moreover implementing segment routing procedures would permit to avoid TLDP sessions in a near future as described in STATUS BOF.
           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^